Team Twiizers has released the Twilight Hack 0.1beta2, compatible with

Discussion in 'Wii - Hacking' started by djdynamite123, Nov 24, 2008.

  1. djdynamite123
    OP

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    [​IMG]
    Twilight Hack

    The Twilight Hack is currently the only safe, public way to enable homebrew on an unmodded Wii. The Twilight Hack is achieved by playing a hacked game save for The Legend of Zelda: Twilight Princess which executes a homebrew application from an external SD card.
    The Twilight Hack was created by Team Twiizers
    http://hbc.hackmii.com/dist/twilight-hack-v0.1-beta2.zipDOWNLOAD 3.4 ONLY

    http://hackmii.com/2008/11/rise-of-the-dead/ SOURCE

    Required Materials:
    SD card. You may want to format the card to ensure a consistent filesystem (for Windows user maybe use the SD formatter for better filesystem)
    SD card reader
    The Legend of Zelda: Twilight Princess that has been played at least once
    Some homebrew to load

    Inside the zip file you will find versions of the hack for all three regions. You may copy all of them to your SD card, but you will need to choose the correct one to copy to your Wii based on your version of Zelda: Twilight Princess. USA users, additionally, need to determine the correct save slot to load once inside Twilight Princess. The easiest way to check your version is to compare the text string which is on the inner circle of the data surface with the ones below.


    Rise of the Dead
    November 24th, 2008 by marcan


    So I said that the Twilight Hack was gone and probably wouldn’t be coming back.

    Good thing I left that probably in there.

    Yes, they screwed up the anti-Twilight Hack check. Again.

    There’s not much point in us publishing a detailed explanation on where the problems are this time around. It comes down to nothing remarkable anyway - just more stupid, silly bugs. They fixed some and added more. We didn’t look much this time because we thought that, well, they really couldn’t have screwed it up this time, could they? As it turns out, you didn’t even have to look at the code to figure out that something was wrong. Someone tried to copy the Twilight Hack out of a 3.3 Wii and into a 3.4 Wii. Go ahead, try it. It doesn’t quite work (it crashes the game when used), but the save copies. Oops. Props to Krusty for pointing this out.

    Will this finally be the last release of the Twilight Hack? Will Nintendo finally manage to beat it into the ground? Third time’s the charm, maybe? We don’t know.

    Enjoy: Twilight Hack v0.1-beta2 (special 3.4 edition)

    Notes: This is for 3.4 ONLY. 3.3 and earlier users should continue with the v0.1-beta1 Twilight Hack. The hacked savefile will be deleted on every boot, so you should copy it, run Zelda, and immediately install HBC, as the hack will be gone once you go back to the System Menu (and then you’ll have to copy it agan to use it again). JAP and PAL are untested but ought to work.

    Also, this in no way implies that updating is a good idea. It’s not. Don’t do it.
     


  2. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    hadrian just closed a topic about this cuz its posted in site news.
     
  3. djdynamite123
    OP

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    Did he, sorry Hadrian (my bad)
     
  4. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    well...it doesn't appear to be getting closed immediately so...hooray!!!!

    this is nice for new brewers.
     
  5. djdynamite123
    OP

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    certainly is, obviously there will be newer wii members who update before knowing about "hacking" then they have this [​IMG]
    Guess Hadrian like's the layout, so he isn't removing it... [​IMG] Sorry Hadrian
     
  6. denzil

    Newcomer denzil Advanced Member

    Joined:
    Jun 11, 2008
    Messages:
    88
    Country:
    United States
    Could you be bothered to link to sources instead of copying the fulltext in here?
     
  7. djdynamite123
    OP

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    there you go in the first post Mr Perfect, just making things "easier" for people.
     
  8. denzil

    Newcomer denzil Advanced Member

    Joined:
    Jun 11, 2008
    Messages:
    88
    Country:
    United States
    Yes, because people need it to be easier than clicking on a link, duh. But that's not the point: Instead of pointing people to the version the authors can maintain, you are making yourself maintainer of the fulltext in here. Do you get why that is a bad idea?
     
  9. FRanatic

    Member FRanatic GBAtemp Regular

    Joined:
    Nov 1, 2008
    Messages:
    277
    Country:
    Netherlands
    Maybe you could add the fact that you really don't need to play the game. The initial save is sufficient.

    Good thing twiizers didn't have to reveal one of the other exploits. Thanks nintendo, for still giving brewers the initiative.
     
  10. w_n_s

    Newcomer w_n_s Advanced Member

    Joined:
    Nov 19, 2008
    Messages:
    81
    Location:
    Belfast
    Country:
    United Kingdom
    so - just to clarify (in case anyone else asks) if on system menu update 3.4 - you can get homebrew and the backup loader to run if you use this specific twilight savegame hack?
     
  11. denzil

    Newcomer denzil Advanced Member

    Joined:
    Jun 11, 2008
    Messages:
    88
    Country:
    United States
    Deleted - I stand corrected.
     
  12. BL4Z3D247

    Member BL4Z3D247 GBAtemp Stoner

    Joined:
    Oct 22, 2008
    Messages:
    615
    Location:
    I'm so high I don't even know!
    Country:
    United States
    once you have the HBC on your wii can't you use a_running_pir8's method of getting "everything else" on your wii?

    if asked and answered already... sorry
     
  13. FRanatic

    Member FRanatic GBAtemp Regular

    Joined:
    Nov 1, 2008
    Messages:
    277
    Country:
    Netherlands
    Use the hack on 3.4 to install the HomeBrewChannel beta 9.
    But I guess you can't install the cIOS (yet) which is needed to run backup loader.

    I'm sure there will be a fix for that very soon.
     
  14. raulpica

    Supervisor raulpica With your drill, thrust to the sky!

    Joined:
    Oct 23, 2007
    Messages:
    10,674
    Location:
    _____________ PowerLevel: 9001
    Country:
    Italy
    Seeing the 3.4 update doesn't touches IOS16, yes, that should work.
     
  15. w_n_s

    Newcomer w_n_s Advanced Member

    Joined:
    Nov 19, 2008
    Messages:
    81
    Location:
    Belfast
    Country:
    United Kingdom
    Ok - so if on 3.4 you can get the HBC working - which should then enable you to downgrade again to 3.3E or 3.2E and then you can get the backup loader working.

    I guess the most asked question on these forums in the next couple of days will be - "I am on 3.4 - how do I downgrade to get the backup loader working?"
     
  16. BL4Z3D247

    Member BL4Z3D247 GBAtemp Stoner

    Joined:
    Oct 22, 2008
    Messages:
    615
    Location:
    I'm so high I don't even know!
    Country:
    United States
    ahh... thought so [​IMG]
     
  17. w_n_s

    Newcomer w_n_s Advanced Member

    Joined:
    Nov 19, 2008
    Messages:
    81
    Location:
    Belfast
    Country:
    United Kingdom
    ahhh, ok, so a new cIOS would be required for 3.4 in order for the backup loader to work, and if that comes out, then everything homebrew / backup loader wise should have caught up with Nintendo's 3.4 update.

    Would be impressive to see that happen this week.

    Would be nice to have some form of protection like starfall on 3.4 if we get to that point. I guess though bootMII would be the answer at that point.
     
  18. FRanatic

    Member FRanatic GBAtemp Regular

    Joined:
    Nov 1, 2008
    Messages:
    277
    Country:
    Netherlands
    No, it doesn't require a new cIOS (I guess), but I think the 3.4 won't let you install the needed cIOS. As you couldn't install wads on 3.3v2, you probably can't on 3.4.
    But I'll have to ask for confimation on this matter. Any takers ?
     
  19. BL4Z3D247

    Member BL4Z3D247 GBAtemp Stoner

    Joined:
    Oct 22, 2008
    Messages:
    615
    Location:
    I'm so high I don't even know!
    Country:
    United States
    just use a_running_pir8's method of getting cIOS installed, it should work on 3.4(as "N" didn't patch IOS16 in 3.4 update)
     
  20. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    well, hopefully its not that common, and hopefully people will realize they DO NOT have to downgrade...

    ...my pack, which will be updated tonight with newest files (check the sig), CURRENTLY as it stands will install just fine on any system (including 3.4 with this new T.P hack), no downgrade needed (in fact no HBC even needed).

    I always stand by 3.2 being the best, but not downgrading if you're a no-nothing and content with that is the best option.
     

Share This Page