TCP gecko Connection problem?

Discussion in 'Wii U - Hacking & Backup Loaders' started by [^Blark^], Oct 15, 2015.

  1. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    459
    130
    Dec 19, 2012
    United States
    I have A 5.3.2U WiiU

    I know how to run the kexploit and the TCP gecko.

    My problem is I just can not get it to connect with the PC client. I am inputting my WiiU url correctly. Im following the TUT like it says. Im launching the game before clicking connect.
    (Im not connecting at the home menu) and I have the right TCP gecko payload for 532.


    It seems there was one other person besides me with this problem and I tried everything from that post too. I've done everything and searched all over for answers To find just that one post

    Heres the link:
    https://gbatemp.net/threads/tcpgecko-dont-connect.397390/



    Games I've tried: (not sure if loading points matter?)
    NSMBU+NSLU
    (I've tried letting the game load to multiple diff. points before trying to connect)
    WindWaker HD
    (Tried at the save selection screen)
    Super Metroid SNES VC
    (Tried during gameplay and after touching gamepad screen,in that menu)


    Kexploit
    (I choose "A" for the official exploit......not the modified one)


    I can run TCP gecko fine
    (it takes me to home button menu. And I can confirm that kexploit was ran because it didnt give me the black screen saying to run kexploit first so it should be running)


    Methods for fix that I tried:
    Clear cookies/Tabs
    Allow TCPgeckoclient private/public in windows firewall
    Allow TCP gecko client in my antivrus
    Disable antivirus
    Disable firewall
    Disable antivirus+firewall
    I have reset my laptop and the client multiple times
     
    Last edited by [^Blark^], Oct 15, 2015
  2. ModderFokker619

    ModderFokker619 Advanced Member

    Newcomer
    57
    15
    Oct 2, 2015

    If you are putting your wiiU ip address in TCPGecko what do you get when you click connect. Wrong ip and you'll get reconnect attempts. With correct ip on my comp I get an error but then TCPGecko will display ready. Have you tried dumping apps in main menu?

    I get less freezing on my laptop.
     
  3. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    459
    130
    Dec 19, 2012
    United States


    I managed to get it to connect by opening up the web browser one last time and going to a random url then click on connect for the pc client for whatever reason it now connects everytime.

    Im now trying vc injection but it cant read my ip (snesinejector.exe) (ive changed it in the ip.txt)
    Also under FSA all i see is vol/content and what looks like language files. Is this the entire structure that i need to do an injection do you happen to know?

    All this stuff is a little confusing at first.
     
  4. fiveighteen

    fiveighteen High Hopes and Low Expectations

    Member
    1,755
    1,264
    Jun 30, 2008
    United States
    Using FIX94's VC injector, you need to close TCP Gecko Client, launch your VC game, go to the VC pause menu, and then do the injection. If you keep TCP Gecko Client up it won't transfer properly.

    EDIT: by "do the injection" I mean drag the ROM into snesinjector.exe

    EDIT2: don't forget to hit reset on the VC menu after injecting :) black screen just means incompatible. Also don't inject a game larger than the one you are injecting into. You will need to restart the Wii U completely if you do this or else no games will work until you do.
     
    Last edited by fiveighteen, Oct 16, 2015
    [^Blark^] likes this.
  5. merlin555

    merlin555 GBAtemp Regular

    Member
    109
    17
    Oct 27, 2014
    Swaziland
    yes.. i have the same problem.

    By:
    NSMBU+NSLU - go into game level and then press "connect" by tcpGecko. (go not in the PAUSE menu)
    Super Mario 3D World - on the level map only.. thats works !
    Donkey Kong - Country Freeze - go into the level.
     
  6. Ailuros27

    Ailuros27 GBAtemp Advanced Fan

    Member
    720
    115
    Apr 7, 2015
    United States
    When did you "open the web browser one last time"? After running the exploit and TCPgecko? I'm having the same problem and just can't get it to connect. Also, I know the regular code handler freezes the sockets, so I have to restart. Do I have to restart the computer, the Wii U, or both? I'm not self-hosting.
     
  7. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    459
    130
    Dec 19, 2012
    United States
    after running tcpgecko open the browser again and try connecting. (this is done after running the kexploit of course) it's the only way I can get mine to connect. i didn't have to restart my pc at all. only the WiiU if it failed to connect 3 times in a row. hope this helps.

    so here's the steps:
    1.run kexploit
    2.run tcpgecko
    3.open Web browser again and connect with tcpgecko pc client.
    4.exit browser once it connects to tcpgecko pc client.
    5. run game you want to use tcpgecko with.
    6. click connect again on tcpgecko pc client it should successfully connect. if not idk...


    things to check as well:
    1. allow TCPgecko connection in your firewall
    2.antivirus may be blocking it
    3. don't be on WiiU menu you must be in the game (game booted and loaded) before connecting otherwise it doesn't work at the Menu screen.

    hope this helps.
     
    Last edited by [^Blark^], Nov 16, 2015
  8. Ailuros27

    Ailuros27 GBAtemp Advanced Fan

    Member
    720
    115
    Apr 7, 2015
    United States
    Sorry. I got it working last night. I don't know what finally fixed it.
     
  9. carnby

    carnby Newbie

    Newcomer
    8
    0
    Oct 23, 2014
    Gambia, The
  10. icw35

    icw35 GBAtemp Fan

    Member
    480
    112
    Sep 22, 2010
    I ran the kexploit and tcpgecko. When I try to load the game it ALWAYS freezes and I have to hard reset. Game is CoD Black Ops II.

    Can I run the kexploit, then load the game and whilst in the game open a browser and run the tcpgecko and see if that will work?
     
  11. BullyWiiPlaza

    BullyWiiPlaza Nintendo Hacking <3

    Member
    1,750
    1,423
    Aug 2, 2014
    Germany
    Same. I have serious problems getting it to work. Using other clients such as pyGecko is no problem but TCP Gecko.NET won't really connect. Anyone?

    Edit:
    New topic.
     
    Last edited by BullyWiiPlaza, Dec 12, 2015