Switch Update 5.0.0 Released

Discussion in 'Switch - Hacking & Homebrew' started by Lia, Mar 13, 2018.

  1. Absintu

    Absintu Advanced Member

    Newcomer
    50
    37
    Feb 2, 2018
    Portugal
    and its time to release 4.1.0 hack :)
     
  2. VinsCool

    VinsCool Absconditus

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,616
    32,165
    Jan 7, 2014
    Canada
    Another World
    Oh crap, I hope my console in sleep mode didn't update itself while I was away...

    If not, time to apply the dns block setup. :unsure:
     
  3. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    9,548
    9,666
    Dec 1, 2014
    United States
    Under a rock
    Thankfully, I don't think the Switch is capable of updating itself. It's nicer than the Wii U and always asks permission first
     
  4. WiiUBricker

    WiiUBricker Insert Custom Title

    Member
    7,370
    5,105
    Sep 19, 2009
    Argentina
    Espresso
    Pretty lame. It seems the X.0.0 jump was mostly an anti-hax update. Pretty weird considering that “stability” updates usually are second-point or third-point releases.
     
  5. Memoir

    Memoir FTS I'm Out

    Member
    GBAtemp Patron
    Memoir is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,251
    7,420
    Jun 24, 2007
    United States
    Go Fuck Yourself
    Waste of the 5.x number. That's for sure.

    — Posts automatically merged - Please don't double post! —

    Yup. Went and deleted my internet settings. Im set with what I got. I feel the ball will only roll faster now.
     
    TotalInsanity4 likes this.
  6. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    9,548
    9,666
    Dec 1, 2014
    United States
    Under a rock
    Also, for people who have blocked already: Can you still access eShop and play online? I somehow doubt that'll be the case, but I'm curious all the same
     
  7. Lia
    OP

    Lia GBAtemp Advanced Maniac

    Member
    GBAtemp Patron
    Lia is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,794
    3,711
    Jan 29, 2016
    United Kingdom
    you need to be on latest fw to use them
    update blocking doesn't effect that
     
    TotalInsanity4 likes this.
  8. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    9,548
    9,666
    Dec 1, 2014
    United States
    Under a rock
    That's what I thought, ok
     
  9. conradcervantes

    conradcervantes GBAtemp Regular

    Member
    120
    24
    Dec 31, 2013
    United States
  10. Ghost92

    Ghost92 Advanced Member

    Newcomer
    79
    20
    Jun 29, 2017
    Colombia
    waiting for pluton to launch version 6.0.0
     
  11. ClockSmasher

    ClockSmasher Advanced Member

    Newcomer
    80
    6
    Feb 6, 2012
    United States
    Will this affect the ability to play Kirby when it comes out?
     
  12. Selim873

    Selim873 Nunnayobeesnes

    Member
    1,221
    603
    Jul 31, 2010
    United States
    Chillin' with Bob Ross
    Depends. The cart will have whatever firmware it requires. I'm sure someone will find out on day 1.
     
  13. Jay Boy

    Jay Boy GBAtemp Fan

    Member
    410
    1
    Oct 30, 2002
    Canada
    Yikes, I just purchased a Switch which will be arriving tomorrow. Is there a way to manually update to 4.1.0 now that 5.0.0 has been released?
     
  14. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    9,548
    9,666
    Dec 1, 2014
    United States
    Under a rock
    Not sure if there are any games with 4.1.0 specifically. If it's low enough, though, you might want to pick up Pokken and get to 3.0.0 for immediate homebrew
     
    Jay Boy likes this.
  15. Jay Boy

    Jay Boy GBAtemp Fan

    Member
    410
    1
    Oct 30, 2002
    Canada
    Thanks, will see what the Switch is on when it arrives tomorrow. One thing I'm wondering though is will I be forced to apply these system updates in order to apply the latest game updates/use DLC? Zelda BOW for example, which is pretty much the main reason why I bought a Switch. If I can run the latest Zelda BOW revision on 3.0.0 I will definitely be doing that.
     
    TotalInsanity4 likes this.
  16. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    9,548
    9,666
    Dec 1, 2014
    United States
    Under a rock
    If it is above 3.0.0, literally every cartridge game that's released up until now (and probably a little after), will definitely be safe for you
     
    Jay Boy likes this.
  17. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    4,260
    3,104
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Probably not for physical. The carts are already burned and shipped, theres no chance it comes with 5.0.0. You should be safe for a short bit to buy new physical releases.
     
  18. yummycake

    yummycake Advanced Member

    Newcomer
    78
    17
    Jan 22, 2017
    United States
    How ironic that this update showed up once I turned off the wifi through airplane mode.
     
    TotalInsanity4 likes this.
  19. delete12345

    delete12345 GBAtemp Advanced Fan

    Member
    558
    260
    Feb 27, 2010
    United States
    Taipei, Taiwan
    Pretty sure we had the same thing happening on the 3DS at some point. And this version references the 3DS 4.5.0-10 to 3DS 5.X.X-Y update.
     
    Last edited by delete12345, Mar 13, 2018
  20. Wishi

    Wishi Rareware Gamer

    Member
    199
    157
    Nov 24, 2015
    Mexico
    Switch 4.1.0 here, CAN play Splatoon 2 online without any problem (using url filtering with my modem, i think that the famous dns doesn't let you play online)
    So i will.be fine at least till splatoon 2 gets updated (or maybe it just updates as I can update games while blocking updates but that was when my 4.1 was the lastest firmware now with 5.0 released it may ask for update)
    whatever i still have a new game plus xenoblade 2 waiting for me :9
     
    snails1221 likes this.
Loading...