SuperDump 1.3 99%-problem

Discussion in 'Wii - Hacking' started by Toonne, Oct 31, 2009.

Thread Status:
Not open for further replies.
  1. Toonne
    OP

    Toonne Member

    Newcomer
    48
    4
    Apr 5, 2006
    Hello!

    I'm dumping some GameCube games mainly to play them on emulator on PC...
    And the problem I've got is that the program "SuperDump 1.3" completes on 99% while I want them to be 100% and complete for sure...

    I've read that cIOS38 rev14 could be the cause to this, but I've tried both rev13 and rev13b, but none works. I also read here on gbatemp
    that a modchip could be the reason to this, and I've got a WiiKey, but I dont know if thats the reason.

    Thanks
     
  2. Madridi

    Madridi Card Collector

    Member
    2,807
    754
    May 9, 2008
    Qatar
    Doha
    if I'm not mistaken, it will show 99% and stop but it actually reached 100%
    so what u can do is, wait a couple of minutes after it reaches 99% then u can get your dump [​IMG]
     
  3. Toonne
    OP

    Toonne Member

    Newcomer
    48
    4
    Apr 5, 2006
    Hi! Thanks, but that dosnt seems to work, I forgot it on like an hour and still dosnt get same
    checksum as on redump.org, what can I try?
     
  4. cracker

    cracker Nyah!

    Member
    3,139
    404
    Aug 24, 2005
    United States
    I've not used SuperDump (great name BTW) but it might be that the image is getting scrubbed automatically (basically only the valid data is copied and the garbage filler data is ignored for a faster rip). I would dump the image again and see if the CRCs from the two dumps match. If they do then you should be fine.

    On a side note GC emulation on PC isn't all too great so you will probably want to just play them on your Wii with a mod (hard or soft) or invest in a GC and XenoGC. [​IMG]
     
  5. Toonne
    OP

    Toonne Member

    Newcomer
    48
    4
    Apr 5, 2006
    I've read that SuperDump should give you a 1:1 dump or something like that.

    I'll dump a game again to see if get same crc on them.

    I know that GC emulation is not very good yet, but the games I've tried so far works very good actually [​IMG]
     
  6. Blue-K

    Blue-K No right of appeal.

    Member
    2,572
    1
    Jun 21, 2008
    Swaziland
    Helvetica
    Use cIOS rev13a (b is probably also good). cIOS rev14 is the worst choice for dumping, it can't read the last sectors of the first layer of a disc (that's why it says 99%), and Dual-Layer Support is broken.
     
  7. nutta_nic

    nutta_nic GBAtemp Advanced Fan

    Member
    556
    0
    Oct 25, 2008
    i had the same problem before, some games dump 100% but some wii sports for instance gets to 99% then fails i've tried it on rev 13 13b and 14,

    i might downgrade cios249 to rev7 or 8, i've always thought they were the best,
     
  8. BenieUK

    BenieUK GBAtemp Regular

    Member
    126
    0
    Jun 19, 2009
    I use SuperDump all the time without problems, i have wiikey2 installed and Rev10 as 14 gave errors with DL games.. the author (Tueidj) said it always only says 99% but is infact 100% if it completes with out any error.

    I have ripped many games with this software to 99% but stating complete and checked them and they 100% dumped correct, if you are getting 99% and complete without any errors then it should be fine, if not it seems you have one of the few mod-chips which cant read to the very end of the disc and you just end up with junk on the end.
     
  9. OSW

    OSW Wii King

    Former Staff
    4,796
    6
    Oct 30, 2006
    As stated, rev14 causes this problem. It won't dump your disk fully and it won'y work.

    It's annoying but use rev13 for now.
     
  10. Fishaman P

    Fishaman P Speedrunner

    Member
    3,239
    505
    Jan 2, 2010
    United States
    Wisconsin
    rev14 worked fine for me.

    Also, don't dump Gamecube games in 1 full run, do it in 2 instead.
     
  11. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    10,998
    7,230
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    This thread is 6 months old, and a lot of cIOS revisions have been released in the meanwhile.

    Please notice the previous post's date, before bumping a thread next time, thanks [​IMG]

    I'm closing this to avoid further bumps, mainly because this problem was probably caused by rev14, which is now obsolete.

    If someone still has this problem, feel free to open a new thread. Thanks.
     
Thread Status:
Not open for further replies.