Super Mario Advance 4 Save filed corrupted

Discussion in 'M3 Adapter' started by Jaems, Oct 2, 2008.

Oct 2, 2008
  1. Jaems
    OP

    Member Jaems GBAtemp Advanced Fan

    Joined:
    Aug 21, 2007
    Messages:
    687
    Country:
    United States
    I've been looking everywhere, but can't find a solution as no one seems to have a simple answer.
    I've tried multiple ROMs; US ones freeze after Game Boy Player screen with "Save File Corrupted" and EU ones freeze with a white screen.
    I've tried IPS-patching the US one; the patch I found worked until I started a new game in SMB3, where the game seemed to be playing, but pressing buttons didn't do anything and the camera kept shifting up and down for some unknown reason. I tried patching the EU version, no luck.

    SOOOO..
    Any suggestions?
    I have an M3 Real with GBA Expansion btw.
     
  2. Joe88

    Member Joe88 [λ]

    Joined:
    Jan 6, 2008
    Messages:
    11,186
    Location:
    NYC
    Country:
    United States
    have never gotten that problem
    using the iND release


    did you try changing any of the options like turning off RTS or anything?
     
  3. chr0m

    Member chr0m GBAtemp Regular

    Joined:
    Oct 9, 2007
    Messages:
    174
    Country:
    Australia
    I have the same problem. I was using an M3 Perfect as the GBA expansion and I got a proper GBA expansion and I get the same issues.
    I've tried many different dumps of the game and none work with the M3 Real.
    I can play it ok with the M3 Perfect directly though, but I really want to get it going with the GBA expansion.
    Any help would be appreciated.
    Cheers.
     
  4. thedicemaster

    Member thedicemaster GBAtemp Addict

    Joined:
    Apr 26, 2008
    Messages:
    2,412
    Country:
    Netherlands
    you can try an sram patch using gbata.
     
  5. granville

    Member granville GBAtemp Goat

    Joined:
    Aug 24, 2007
    Messages:
    4,977
    Location:
    Naples, Florida
    Country:
    United States
    The save patch in GBATA seems to get the game past the corruption screen, but it still gives you the error anytime you boot the game. You can just skip the screen. The game still seems to save though. [​IMG]
     

Share This Page