Star Wars Battlefront II Freezes

Discussion in 'PSP - Games & Content' started by ChrisMims, Nov 3, 2009.

Nov 3, 2009
  1. ChrisMims
    OP

    Banned ChrisMims Banned

    Joined:
    Mar 14, 2009
    Messages:
    206
    Country:
    United States
    I dumped my Star Wars Battlefront II UMD with UMDumper onto my memory stick. When I opened it, it would always freeze on the last 2 circles on the loading screen. I then used UMDGen and converted it into a .cso. Wow! I didn't freeze on the loading screen! I then went to the campaign mode and as soon as I would press "X" to start a battle, it would freeze. [​IMG] Can anyone help me with this problem?

    Firmware: CFWE 3.60
     
  2. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    Disregard this, my bad. [​IMG]
     
  3. ChrisMims
    OP

    Banned ChrisMims Banned

    Joined:
    Mar 14, 2009
    Messages:
    206
    Country:
    United States
    No. Should I need to? It's an old game... I'll try it anyways.
     
  4. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    Firmware?

    1) Try both of the useful ISO drivers
    2) Format your MS, repopulate it and try again, No luck->
    3) Try dumping it directly to your computer from the PSP by just dragging and dropping. Then transfer the whole ISO across to a formatted stick.
     
  5. ChrisMims
    OP

    Banned ChrisMims Banned

    Joined:
    Mar 14, 2009
    Messages:
    206
    Country:
    United States
    I followed the guide, but Game Decryptor just tell me that it's a fake X-Men 2 dump
     
  6. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    Oops, mistook it for Elite Squadron.
    Yeah, do what xist suggested.
    If none work then just play it from your UMD.
     
  7. ChrisMims
    OP

    Banned ChrisMims Banned

    Joined:
    Mar 14, 2009
    Messages:
    206
    Country:
    United States
    It didn't work [​IMG] I'll just use my UMD. Thanks to both of you [​IMG]
     

Share This Page