Snes9x using .cht files to cheat in games

Discussion in 'Wii - Emulation and Homebrew' started by Slimmmmmm, Jan 1, 2009.

Jan 1, 2009
  1. Slimmmmmm
    OP

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    Ok, rare for me to need to ask for help but that's exactly what I need to do me == fail [​IMG]
    *EDIT* - snes9x gx 008 won't allow loading on the .cht files confirmed. They do work in ver 7, and tantric has fixed the issue for the next release.

    I aint so dumb after all [​IMG]
    I'll re-edit my posts when time allows to add aguide of sorts, links etc and how to make your own on pc or sumin so this wont be a useless asking for help post

    So I got the snes emu and read everything related and today decided to apply some cheats to some roms and mess about with it a bit.
    They wouldn't work.

    I double checked all read me and guides etc etc nothing worked, however I did find a lot of other posts where no one got them working.

    I can't except they don't work, so followed the placements and naming and tried lots of variations. Too many to remember them all.

    I tried naming the .cht to exactly the same as rom and placing in snes9x/cheats
    snes9x/CHEATS
    snes9x/ROMS
    snes9x....
    saves etc etc etc etc.
    I tried writing a txt doc with the AR codes something like this

    This was from a site online as an example, I just tried it, didn't work.

    So I thought, typo maybe, or formating hmmm.

    I started up snes9x on the pc and made a .cht on that, examined it and noticed it was totally different, so thought I'll try one of these, and then copied it to the SD, and placed in every location imaginable, ran the rom and nothing.

    I've searched some more, but all I can really find on this are posts of people saying they can't get it to work.

    So does it work and I'm missing something maybe obvious, or does it not work?

    If anyone can help it will be appreciated and I will edit this first post for anyone else having trouble.

    Cheers in advance


    /me crosses fingers [​IMG]
     
  2. jspicher

    Newcomer jspicher Advanced Member

    Joined:
    Nov 18, 2008
    Messages:
    85
    Country:
    United States
    Hello Slimx6,

    I've had no problems using the cheats.
    Try downloading a cheat from: www.cheatzilla.com for the same game you're trying to apply the cheats too and see if a.) the format is the same as yours, b.) see if the file works on our wii.

    Another thing that might be tripping you up, is that the *.cht file must be named *exactly* the same as the rom... (less the file extension).

    I've not made any .cht files custom like you're attempting too but l've downloaded them from the aforementioned cheatzilla.com and they've worked fine for me.

    Best of luck!
     
  3. Slimmmmmm
    OP

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom

    Suuuuuuuuperb, thanks for confirming they do work.

    I have tried ones form that site, but not many as I don't have that much time, can you name any files specifically that did work?

    I'll try a few more and once I find one that does work I can examine the format and see why my other ones didn't work.

    I'll try a few more tomorrow and surely I'll get it sorted if it does work, but there just soooo many threads of people saying they can't get them to work, I'd love to figure out how to make them more "standard".

    Get back to me with game names of .cht's that worked [​IMG]

    *Edit*
    I went to that site just now and grabbed the Sim City for snes, renamed it exacly as the rom is named (except obviouslt .cht) placed in the snes9x/cheats folder, and still no cheat menu, so I'm guessing the Sim City on there site doesn't work. I've kept it to examine and it appears to be in RAW format, the same as a few I tried earlier. Any specific game someone can confirm working? (region of rom too)

    Converted it to AR format (minus the [​IMG] still no luck with that .cht.
    I'll test a few diff games later...

    *Another Edit*

    On a different forum someone claims they work in version 7, but then not in 8. What version are you using?

    When I get time tomorrow I'll grab the older releases and try them, thing is snes9x..7 had the SD bug so....hmmmm

    Tantric and co are superb coders so I'd expect them to be able to fix this easy if it is just a bug thats crept in
     
  4. jspicher

    Newcomer jspicher Advanced Member

    Joined:
    Nov 18, 2008
    Messages:
    85
    Country:
    United States
    Greetings Slimx6,

    Rom that l used cheats on is: SDCARD:\snes9x\roms\Donkey Kong Country 2 - Diddy's Kong Quest.smc
    (me and my GF needed infinate lives!)...
    Name of cheat file is: SDCARD:\snes9x\cheats\Donkey Kong Country 2 - Diddy's Kong Quest.cht

    The file was downloaded from here renamed and copied directly into my /cheats folder (no edits).
    Direct link to the *.cht file is here

    l am using version 8 of Snes9x GX, available here (just double checked that...) -- not sure what else could be stopping you from accessing the cheats menu. I'm on an SD card (not SDHC).

    I will download the simcity cheat from cheatzilla now and test it..


    ---------[[EDIT]]------------------

    Oaky i just tested it and you are right version 8 has no cheats menu. (l just updated all of my emulators this past weekend and must not have attempted to use any cheats since then.)

    So l downloaded version 7 from here
    tested both my older cheat (donkey kong country 2) and SimCity - both worked.
    So you are correct the cheats do not seem to work in version 8, but work in version 7.

    I'm off to watch the USC Vs PENN ST game...

    Regards,
     
  5. the-murderer

    Newcomer the-murderer Newbie

    Joined:
    Dec 2, 2008
    Messages:
    8
    Country:
    France
    I comfirm the cheat don't work on GX 008! a bug!
     
  6. Slimmmmmm
    OP

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    Superb, checked back to see if anyone posted and seems the problems found then.
    I tested some stuff and was going to post this, but you beat me to it [​IMG]
    I'll pass a bug report for this issue and hopefully we'll see it fixed in ver 9.

    Thanks for taking time to post again.

    *EDIT*

    Spoke to Tantric and he 's already fixed the problem (thanks a million), so expect it fully working in the next release.


    [​IMG]
     

Share This Page