1. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    Hi, I've updated the Nintendo Switch 11.0.1 and I've updated to the Atmosphere 0.16.2 version.

    In RCM mode ,I got the messages to the below in Tegrarcmgui 2.6;

    Switched to high buffer
    Smashing the stack!
    Smashed the stack with a 0x7000 byte SETUP request!
    Payload successfully injected
    RCM device disconnected

    Sometimes my Nintendo Switch gets black screen after Atmosphere logo appeares and sometimes it loads Atmosphere correctly. Could you help me what is the problem ?

    upload_2020-12-28_22-37-3.png
     
  2. BaamAlex

    BaamAlex CVE-2018-6242
    Member

    Joined:
    Jul 23, 2018
    Messages:
    3,262
    Country:
    Germany
    Which payload do you inject?
     
  3. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    I've injected payload.bin file
     
  4. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    8,802
    Country:
    United States
    You should use the most updated version of Fusee-Primary, it looks for for the files on your SD card after you inject it, perhaps switch from exFAT to FAT32 if you are on exFAT.
     
    Last edited by Hayato213, Dec 29, 2020
  5. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    I purchased used device and it contains sd card that is exFAT formatted. Thanks for your advice.
     
  6. iridescent

    iridescent Newbie
    Newcomer

    Joined:
    Jan 1, 2021
    Messages:
    2
    Country:
    Netherlands
    Naber lan,

    you are using all of the wrong files, basically you injected the payload from Tegra. Tegra's own payloads are older versions.

    you'll have to download atmosphere/hekate or whatever all yourself (github/google)


    the crashing could also be because you're running exfat. you probably don't have the exfat 'driver' on your nintendo switch, but even if you do or did; you should just stop and instead reformat your sd card to FAT32. (Because exfat is buggy on switch. your sd card files will keep getting corrupted)



    if your SD card is a biiiigboiii you'll have to format via a different program, windows can't format bigger cards to FAT32.

    I saw this recommended and I used it myself:

    partitionwizard (google it, i can't post links)


    IDK if this is safe, I ignored any image/popup on site because I'm paranoid and just installed the free variant.

    After choosing FAT32 etc you'll have to press apply and it'll format.
     
    Last edited by iridescent, Jan 1, 2021
  7. Sora Takihawa

    Sora Takihawa GBAtemp Psycho!
    Member

    Joined:
    Oct 11, 2015
    Messages:
    3,413
    Country:
    Germany
    xD never thought that i see another Turkish person here on GBATEMP
     
  8. iridescent

    iridescent Newbie
    Newcomer

    Joined:
    Jan 1, 2021
    Messages:
    2
    Country:
    Netherlands
    Several actually, I just made this acc to reply to the dude

    What's even weirder is that I'm re-learning how to hack my switch (since kosmos died) at the same time as this dude + I have the same name as him IRL too

    Is he me?
     
  9. Sora Takihawa

    Sora Takihawa GBAtemp Psycho!
    Member

    Joined:
    Oct 11, 2015
    Messages:
    3,413
    Country:
    Germany
    oh xD...well i am Turkish aswell
     
  10. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    13,965
    Country:
    United States
    Honestly I'd rather recommend GUIFormat.
     
  11. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    İyiyim lan sen nasılsın,

    I'have formatted the sd card with different program via rufus and sd car formatter program. But, the result is the same. I can try to use partitionwizard . Thanks for your advice.
     
  12. BaamAlex

    BaamAlex CVE-2018-6242
    Member

    Joined:
    Jul 23, 2018
    Messages:
    3,262
    Country:
    Germany
    Drivers installed?
     
  13. burhansalih

    burhansalih GBAtemp Advanced Fan
    Member

    Joined:
    Jan 11, 2009
    Messages:
    724
    Country:
    United Kingdom
    Why don't you just update to the latest version of Atmosphere?
     
  14. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    Yes, I've installed the related drivers.

    — Posts automatically merged - Please don't double post! —

    I have not updated the latest Atmosphere version yet. I am going to update the latest drivers.
     
  15. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    I've tried with the latest drivers but the result was same.
     
  16. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    13,965
    Country:
    United States
    Have you tried using other ports, cables, or operating systems?
     
  17. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    I've tried with other ports,different cables etc
     
  18. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    13,965
    Country:
    United States
    Actually I just noticed you said you use exFAT. That is most likely your problem. Format your SD card to FAT32.
     
  19. BurakC

    OP BurakC Newbie
    Newcomer

    Joined:
    Dec 28, 2020
    Messages:
    8
    Country:
    Turkey
    I'll format my sd card to FAT32. Thanks for your advice.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Smashed, request, 0x7000