Slow loading home icons after cfw?

Discussion in '3DS - Flashcards & Custom Firmwares' started by selbyftw, Sep 9, 2016.

  1. selbyftw
    OP

    selbyftw Advanced Member

    Newcomer
    83
    3
    Sep 2, 2016
    Hello does anyone know why my home icons take ages to load after installing cfw?
    I only have two games on the sd card and then fbi and luma updater and that's about it.
    My sd card is a sandisk extreme pro 95mbs so that shouldn't be the problem?

    Is there a way to do like a factory reset without losing the cfw and arm9?
     
  2. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    Doing a system format won't remove a9lh or CFW, so if you think that would help feel free to do it.

    That being said your card might be a fake, try running h2testw.
     
  3. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,673
    750
    Aug 22, 2015
    United States
    Hell
    It is just a general side effect of using cfw or possibly due to your sd card. Formatting won't remove a9lh or cfw. What size is your sd card and what is its cluster size?
     
  4. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    I've never heard of it being a side effect of CFW, are you certain?
     
    gnmmarechal likes this.
  5. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,673
    750
    Aug 22, 2015
    United States
    Hell
    I have noticed longer home screen loading times when i have certain patches enabled (i.e. region free home menu). Might just be me though...
     
    astronautlevel likes this.
  6. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    Ah, that might be a possibility then. Still though, I haven't heard about it ever taking "ages" to load, it sounds more like an SD problem.
     
  7. Exaltys

    Exaltys GBAtemp Fan

    Member
    340
    89
    Nov 10, 2009
    United States
    What is the capacity of your card? Don't larger sizes take longer regardless of how much data you have on them?
     
  8. selbyftw
    OP

    selbyftw Advanced Member

    Newcomer
    83
    3
    Sep 2, 2016
    Tested the card in h2test and It passed with no errors at all, had a green box afterwards. The speeds were around 80-90mbs which is about right for the card. I'll try a system format then and see if that improves anything. How will I install fbi and every back on there after the system format just make a back up of the sd card and copy and paste it back on after the system format?

    — Posts automatically merged - Please don't double post! —

    The size of the card is 32gb and I formatted with a 32kb cluster size as advised in the guide
     
  9. cravas

    cravas GBAtemp Advanced Fan

    Member
    867
    229
    Jul 30, 2016
    Portugal
    Oeiras
    You can format it with 64Kb cluster size (although I don't recall if Windows will do it)
     
  10. LongTimeLurker

    LongTimeLurker GBAtemp Regular

    Member
    177
    61
    Aug 25, 2016
    Canada
    I don't think you can do it with the default partition tool. I'm not sure of alternatives (thought alternatives certainly can).

    I also feel like I should note that the 3DS doesn't support the 95MB/s that the sdcard reports as it would utilize UHS to achieve that (which the 3DS does not support). As for home icons loading slow, how many do you have? I noticed mine load slow on emunand but I've been on CFW for so long and I don't really care.

    Can you elaborate on "slow"? How fast did it load before with how many icons? How fast does it load now with how many icons?
     
    Last edited by LongTimeLurker, Sep 9, 2016
  11. selbyftw
    OP

    selbyftw Advanced Member

    Newcomer
    83
    3
    Sep 2, 2016
    Well before the cfw everything was there loaded ready. Since the install it takes a while for them to pop up. I have about 15 maybe less. It's not a massive issue but just annoying. Biggest problem I have at the moment is after the system memory format I don't know where to start to get fbi and luma3ds updater back on there.
     
  12. cravas

    cravas GBAtemp Advanced Fan

    Member
    867
    229
    Jul 30, 2016
    Portugal
    Oeiras
    Just grab the fbi zip from GitHub and launch it via homebrew to install the cia version.

    Or go to the guide and follow the steps to inject it with Decrypt9:
    https://github.com/Plailect/Guide/wiki/Part-3-(arm9loaderhax)#section-v---injecting-fbi
     
    LongTimeLurker likes this.
  13. selbyftw
    OP

    selbyftw Advanced Member

    Newcomer
    83
    3
    Sep 2, 2016
    Lovely thanks I'll give that a go now. What's the different between the injecting and cia install?
     
  14. cravas

    cravas GBAtemp Advanced Fan

    Member
    867
    229
    Jul 30, 2016
    Portugal
    Oeiras
    Different procedures, only.
     
  15. LongTimeLurker

    LongTimeLurker GBAtemp Regular

    Member
    177
    61
    Aug 25, 2016
    Canada
    I think with Decrypt9 you can inject FBI into the Health and Safety app, otherwise a typical CIA install has its own icon and such :).

    Edit: Ninja'd, or maybe just this?

     
  16. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    This is the correct answer.
     
    LongTimeLurker likes this.
  17. selbyftw
    OP

    selbyftw Advanced Member

    Newcomer
    83
    3
    Sep 2, 2016
    Well everything is kinda fucked now lol
    FBI shows the FBI icon but actually loads into health and safety. I'm missing a health and safety icon altogether.
    It's still slow and laggy loading the icons.

    Is there a easy step to just get back to the 4.5 firmware I was on before I installed cfw and updated and get everything back to 100% stock? Then I can go through all steps again and take my time with it.
     
  18. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    It sounds like your FBI is just the H&S app, but the icon cache still has the FBI icon. Just inject FBI again following the steps in the guide.
     
    gnmmarechal and LongTimeLurker like this.
  19. Pacheko17

    Pacheko17 かっこい男の子

    Member
    1,258
    1,185
    Jan 31, 2015
    Brazil
    Somewhere in the south
    Most likely the SD card. I switched from a 2gb to an 8gb one and stuff now loads more slow, but the trade off was worth it.
     
  20. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,085
    Jan 26, 2016
    United States
    That Nightly Site™
    Update, an alternative (and possibly easier) way to get FBI back is install the dev branch of luma (copy the corresponding arm9loaderhax.bin from the release zip), hold select when booting, then enable the SVC check option. You can then use NASA to install the FBI CIA from the HBL.