Sky3DS Broken Save... Help needed!

Discussion in '3DS - Flashcards & Custom Firmwares' started by drfsupercenter, Jan 20, 2016.

  1. drfsupercenter
    OP

    drfsupercenter Flash Cart Aficionado

    Member
    1,898
    234
    Mar 26, 2008
    United States
    Hey guys

    This seems to be a pretty annoying problem with the blue-button Sky3DS and I can only hope the orange-button one doesn't suffer the same fate.

    I kept having this issue over and over and over again with Nintendogs+Cats, and was able to fix it myself... eventually just used the official save data transfer tool to transfer it to my eShop copy.

    Nintendogs was a launch title and uses the old encryption, which means... what I was able to do was use my NDS Adapter Plus to dump the raw save data (which the game sees as "corrupted"), then restore it to a retail cartridge (this is only necessary because Powersaves seems to hate the Sky3DS...)
    I then plop that retail cartridge into Powersaves, and apply any cheat to it, voila, their server just fixed my corrupted save... LOL

    It sounds dumb but it actually worked. I had to do this a few times as it kept breaking.

    Before I go any further I'll just explain what I think breaks it - if the 3DS is in sleep mode (lid closed) and I bump the button (which isn't all that hard to do, honestly), the blue LED blinks and just keeps blinking for several minutes. Because the 3DS is in a low-power state, I guess the card can't do its thing and it just freaks out. If I notice it happening I'll eject the cartridge to stop the blinking. Interesting to note the same behavior sometimes happens when in the rxTools launch screen, but that seems to be 50/50

    Anyway, never had this issue with CARD2 games. I have Pokémon Y, Pokémon AS and Tomodachi Life on there, have had those same copies for months and never had any issue. CARD1 games on the other hand, seems like any time it gets stuck in that low-power state where the LED just blinks forever, when it finally does stop (whether I pull the card out or it just shuts itself off after who knows how long) it does something screwy... it's like it tries to mount the emulated save data, doesn't have enough power to do so so it gives up. And somehow that makes the system think the save is corrupted.

    The kicker is it's not really corrupted. Likely just a corrupted header that can be fixed by forcing a rehash of the actual save data. Nintendogs was easy enough to fix since I own the retail copy (believe it or not, I'm not using my Sky3DS for piracy, I just dumped the saves from all my legit retail carts to it so I don't have to lug around tons of games) and it uses the old encryption.

    With Super Smash Bros, that isn't the case. I tried that - and Powersaves did what it usually does if you have a mismatched-encryption save - it uploads it to their server which promptly gives you an error and aborts.

    The other big problem with these "corrupted" saves is that the 3DS itself seems to see it as such. SaveDataFiler says "broken" in red so it doesn't let me export it. Trying the official cartridge-to-SD tool reads "The save data on the Game Card may be corrupted. Please check the save data on the Game Card and try again."

    Thought maybe homebrew could save me. I first tried profi200's save_manager, but that just gave me an error when in emuNAND (actually on both my retail SSB and the Sky, not sure why exactly, could be due to 10.4 stuff) and then I tried on my 9.2 sysNAND via Cubic Ninja and it loaded, but gave me a blank, black screen. Tried it several times to make sure it wasn't just a crash.

    I tried svdt which did its emergency dump-save-data-at-boot mode, but again it didn't see anything there (the whole "corrupted" nonsense) and gave me an empty folder. When I tried to do it manually it just gave me an error saying it couldn't read the contents.

    So I'm really out of options here. I have the raw 512KB save file that I dumped with my NDS Adapter Plus and can confirm it's not empty at all. There's tons of stuff there and the structure looks normal (a few bytes at the start, then a bunch of 0xFF followed by real data farther on). It's probably just one byte that got flipped around and is freaking the entire thing out.

    The only method I've ever been able to use to fix my saves is Datel's Powersaves, but since that doesn't work properly with CARD1 Sky3DS (interestingly it WILL work with CARD2 but ONLY if you give it a valid header by using their template tool, if not it crashes when processing)... if you use a CARD1 Sky3DS game it flickers for about a second like it's thinking about it, and then says "Unsupported game card"

    I also have a Cyber Gadget (can you tell the theme? I like any DS/3DS hacking tools hehe) but last I checked that only worked on Japanese games, and I have the US copy of Super Smash Bros.

    What else can I do?

    What would probably fix it is if I could dump my cartridge's KeyY or whatever it uses for encrypting the save data, and ignore the actual data - then decrypt the raw file using that. Then re-encrypt it with my retail game's key and so on. Once Powersaves fixes it I can use SaveDataFiler to export and re-import it to the Sky3DS

    Or... if someone can make me a hacked up SaveDataFiler that forces an export even when it thinks the save is broken.

    Or any other ideas...? I have so many hours poured into this game that I'm literally going to cry if I have to start all over because the flash cart is buggy as frick. I might have a backup from like a year ago but I sadly don't keep regular backups... this is the first time it's happened on a game other than Nintendogs or Sonic Generations (which I DID have a backup of)
     
    Last edited by drfsupercenter, Jan 20, 2016