Hacking SD2VITA on 3.73, nothing will open

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
Hi, is SD2VITA possible on 3.73? Or which firmware version is best to use?

I see different answers in different places and couldn't find a definitive or up to date answer, so I tried it, now no games or plugins are opening, I get an error.

By the way I've seen the stickied threads including the SD2VITA one but it's not clear to me about later versions.

I used autoplugin 2 to install SD2VITA and its "SD2VITA PRO" it said it was compatible with 3.73 on the listing where I bought it.
Again, it was not clear to me which version of autoplugin to use as some people said autoplugin 2 causes problems.

I've modded / installed CFW to a few other systems and normally work it out but am finding vita a tad more complicated. I'm definitely a vita n00b so sorry if I'm asking dumb questions.

Cheers
Tom
 

XpertNoobhacker

Well-Known Member
Newcomer
Joined
Nov 12, 2019
Messages
91
Trophies
0
Age
26
XP
149
Country
United States
okay so i dont know where you saw that SD2Vita worked on newest firmware i haven't seen that anywhere yet (although maybe im wrong) i just took a peek at the sd2vita having issues and it says the latest supposed version is 3.68 so im like 90 percent sure it dont work on newer firmware of if it does its a luck of the draw to my understanding.
I from experience can say its perfectly fine on 3.65 but make sure your using the latest version of storagemgr.skprx and i wouldn't use auto plugin i have a really messy config.txt from using it(again dont know why its fine on my friends vita) and to be fair it works on mine but im sure auto plugin has been like a blind rat on M**h its a real mess and if i move the config lines the apps stop working so its a leave it alone as it works at the minute...

lastly why would you not downgrade i dont think adrenaline is on the latest firmware but again i could be wrong here im not certain.
 

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
Thanks for your reply. This is really the problem. Nowhere did I see a simple answer of what firmware to use for best compatibility. People had given different answers and many of them were outdated.

I cannot see anywhere "it works on this firmware and not this" etc.

So which is best to use 3.65 or 3.68?
 

ZeroSene

Well-Known Member
Member
Joined
Aug 30, 2019
Messages
191
Trophies
0
XP
709
Country
Vietnam
From the page of storagemanager plugin
Compatible with PSVita FWs 3.60, 3.65, 3.67, 3.68, 3.69, 3.70, 3.71, 3.72 and 3.73
https://github.com/CelesteBlue-dev/PSVita-StorageMgr
From the page of Yamt plugin
Requires enso, compatible ONLY with firmware 3.60 and 3.65.
https://github.com/SKGleba/yamt-vita

So it actually depend on what plugin you use, the firmware limit is different, but those 2 are the best, Yamt has much better boot speed.
 
  • Like
Reactions: XpertNoobhacker

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
Thanks.

I'm not certain of every plugins I'm going to use but I'd like to use SD2VITA and Adrenaline at least.

I want to have PSP and PS1 games on my Vita homescreen, I want plenty of storage, and I might give the moonlight streaming a go too.

If I understand right, the 2 plugins you're talking about are plugins related to SD2VITA.
When I ran autoplugin and installed, it just called it "SD2VITA"

So with storage manager it might work on my firmware but I would prefer to avoid this issue in the future depending on what plugins I decide to install in the future. I might as well downgrade.

Now I'm thinking 3.60 or 3.65 are still the best firmwares to use but I'm still not that clear. If it's not as simple as choosing the best firmware version and depends on plugins, then has anyone done an up to date comparison of the different firmwares and their support of the most popular plugins? Even a basic one.

I just want minimum fuss solution with good overall compatibility of both plugins and games.
 

XpertNoobhacker

Well-Known Member
Newcomer
Joined
Nov 12, 2019
Messages
91
Trophies
0
Age
26
XP
149
Country
United States
Okay so I'll help clear this easy.
I'd use storage manager as that's what I've used 3 times on 3.65

However the difference between 360 and 3.65 is that on 360 you can install exploit from browser and also better compatability with homebrew and plugins (apparently) can't say I've experienced and issues though on 3.65

3.65 will need qcma and auto Hencore to push your exploit so you also need to use a pc. But you will have to have less compatability packs (these you get along with the game pkgj) but most games that I personally play work on 3.65.

Bottom line sd to vita and most homebrew if not all work on both of these and you will probably be happy either way as if you use enso you cant really 'lose'your hack
 

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
Thanks that really helps. I'm getting a clearer picture now.

Finally I have a couple questions and then I can probably work out the rest:

1) I want to downgrade the firmware soon, but I can't open any app on my vita currently, is there a safest way to reverse / fix this / disable SD2VITA so I can get my vita usable in the meantime and then start work on my firmware downgrade?

2) I used autoplugin before. I see many people saying not to use autoplugin because it causes issues etc etc. Firstly, should I be concerned with this or is it just a case of good / bad luck.
Also what I'm not clear on is what is the alternative to autoplugin? Like how do I install a plugin without autoplugin? Or is there a different process for each individual plugin that I have to somehow find? Most tutorials say to use autoplugin.

Cheers
Tom
 

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
19,996
Trophies
1
XP
12,305
Country
United States
I think it's holding L at boot to disable plugins. I'd personally use YAMT. it's quite a bit faster than storage manager from what I've heard. my system is lightning fast. I downgraded to 3.60 from 3.65. be careful on 3.73, the downgrader doesn't seem to be stable. I can't tell you how many times I've read of someone bricking downgrading from that firmware. it's a fixable brick or should be, but I don't know what to do if you can't downgrade like that.
 

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
Thanks. Holding L during startup, still cannot access any games or apps.

It gives no message or anything to say plugins disabled.

I tried "restart vita", that didn't work either.

The error I am getting is "An error has occurred. (C1-6775-5)
I can't access games and I can't load vitashell. I can load the menu and settings only.
 
Last edited by mot393,

ShroomKing

Somebody
Member
Joined
Mar 3, 2017
Messages
468
Trophies
1
Age
26
Location
in bed
XP
1,520
Country
United States
Thanks. Holding L during startup, still cannot access any games or apps.

It gives no message or anything to say plugins disabled.

I tried "restart vita", that didn't work either.

The error I am getting is "An error has occurred. (C1-6775-5)
I can't access games and I can't load vitashell. I can load the menu and settings only.
on 3.73 you have to run hencore again after restarting for homebrew to work.

I'd say use https://github.com/SKGleba/modoru to downgrade to 3.65, then install https://github.com/TheOfficialFloW/enso so you don't have to run hencore everytime.
And then you can use https://github.com/SKGleba/yamt-vita and setup your sd2vita.
 

XpertNoobhacker

Well-Known Member
Newcomer
Joined
Nov 12, 2019
Messages
91
Trophies
0
Age
26
XP
149
Country
United States
Okay do I'd like to weigh in here I've done 3 vitas and I have strong opinions about autoplugin just to answer that last question.
On 2 vitas it's left the config.txt really neat. (thus is how you alter plugins manually or at least they're path)
On my but for some reason it made a mess I did the Nondprm.skprx and adrenaline plugins and a few others manually. Left the config tidy. Used auto plug in as it was 'easier and that it was but now my config is a mess and I cannot alter it or things don't work...annoying not gonna lie but 2/3 times its worked perfectly.

Also make sure that's the right version of moduru the reason people are bricking is because there's one for 3.72 and below I think and one for 3.73 it's stable but it's confusing make sure you read the readme's and github to ensure compatability

Lastly I belive you will have to re instal the exploit as holding L only disable pligins so none will be loaded also I think it's only for enso as 3.73 shouldnt be permanent to my knowledge.
 
Last edited by XpertNoobhacker,

Demix

Well-Known Member
Member
Joined
Sep 5, 2018
Messages
184
Trophies
0
Age
29
XP
827
Country
United States
I'm on 3.72, from what I read Adeline doesn't work on my firmware, battery % mod also doesn't work.
 

Xalusc

Well-Known Member
Member
Joined
Apr 7, 2013
Messages
135
Trophies
1
Location
Zhōngguó 中国
XP
642
Country
China
I expect enso will catch up to 3.73 in a matter of...months?
It's not only Ensō. Most homebrew/plugins won't work or will have some kind of issue above 3.65.

I think it's holding L at boot to disable plugins. I'd personally use YAMT. it's quite a bit faster than storage manager from what I've heard. my system is lightning fast. I downgraded to 3.60 from 3.65. be careful on 3.73, the downgrader doesn't seem to be stable. I can't tell you how many times I've read of someone bricking downgrading from that firmware. it's a fixable brick or should be, but I don't know what to do if you can't downgrade like that.
People brick their Vita because they use the wrong version of modoru. The one they're supposed to use is https://github.com/SKGleba/modoru/releases/tag/v2.1
 
Last edited by Xalusc,
  • Like
Reactions: XpertNoobhacker

ZeroSene

Well-Known Member
Member
Joined
Aug 30, 2019
Messages
191
Trophies
0
XP
709
Country
Vietnam
I expect enso will catch up to 3.73 in a matter of...months?
Since people can downgrade 3.73 to 3.60-3.65, nobody try to make catch up anymore. Allmost all plugin stop at 3.65 now.
Since with plugin, you can play game from any firmware on 3.60-3.65, there are no reason to use 3.73 at all.
 

XpertNoobhacker

Well-Known Member
Newcomer
Joined
Nov 12, 2019
Messages
91
Trophies
0
Age
26
XP
149
Country
United States
Yeah I agree there's no incentive for development to waste time porting to newer versions when a downgrader exists

ALSO YES INDEED PEOPLE SEEM TO BRICK BECAUSE THERES TWO MODURUS CANT SRESS THIS ENOUGH make sure you use the right one
 

mot393

Member
Newcomer
Joined
Aug 24, 2020
Messages
13
Trophies
0
Age
30
XP
58
Country
United Kingdom
This is exactly what I was looking for, as a n00b it would be a helpful sticky "Best firmware to use 2020 and beyond" or something. This is the first thing I check when wishing to install CFW on any console.

--------------------- MERGED ---------------------------

Since people can downgrade 3.73 to 3.60-3.65, nobody try to make catch up anymore. Allmost all plugin stop at 3.65 now.
Since with plugin, you can play game from any firmware on 3.60-3.65, there are no reason to use 3.73 at all.
This info is what I was looking for.
 

Demix

Well-Known Member
Member
Joined
Sep 5, 2018
Messages
184
Trophies
0
Age
29
XP
827
Country
United States
done, thanks to that link and this video. Also had to rewrite new files for the sd2vita. Overwrote all other files except app...got to keep all my downloads
im on henkaku enso
 
Last edited by Demix,

Site & Scene News

General chit-chat
Help Users
  • IanSkinner1982 @ IanSkinner1982:
    Forgive me.
  • kenenthk @ kenenthk:
    You have been forgiven
  • IanSkinner1982 @ IanSkinner1982:
    Thank you.
  • IanSkinner1982 @ IanSkinner1982:
    School sure is fun. I have to fill out a chart with median income for certain fields of study.
  • Swagboi308 tempBOT:
    Swagboi308 has joined the room.
  • ILeo @ ILeo:
    so im in multiman game section and refreshed and cant see the games off the usb help?
  • ILeo @ ILeo:
    nvm i had to change the usb folders name to "GAMES"
  • torpedo_XL tempBOT:
    torpedo_XL has left the room.
  • dragonmaster @ dragonmaster:
    16 years over the gbatemp i am starting to feel ancient one :P
    +1
  • IanSkinner1982 @ IanSkinner1982:
    You've been here since before I was born.
  • kenenthk @ kenenthk:
    16 years and only 500 posts
  • IanSkinner1982 @ IanSkinner1982:
    Might've been an eof shitposter.
  • hallo23 @ hallo23:
    R A T I O
  • ILeo @ ILeo:
    how do i show my games on the xmb? do i need webman mod?
  • ILeo @ ILeo:
    how to display games from multiman
    on the xmb?
  • kenenthk @ kenenthk:
    These are thing you should probably
    asking in the PS3 section on the forums
  • ILeo @ ILeo:
    yea youre right sorry
  • Sonic Angel Knight @ Sonic Angel Knight:
    We don't get new emotes with the updates forum?
  • Sonic Angel Knight @ Sonic Angel Knight:
    Where is my food emotes. :blink:
  • kenenthk @ kenenthk:
    Eat more veggies 🍆
  • DSgodman @ DSgodman:
    this chat deeeead
    DSgodman @ DSgodman: this chat deeeead