Sata disk on IDE NA (PS2)

Discussion in 'Sony PlayStation 1 & 2' started by umbjolt, Apr 13, 2017.

  1. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Hi there!

    ATM I have a fat PS2 softmoded with FMCB and an original IDE network adapter.
    My problem is that I don't have any IDE disk anymore (I had a 40Gb disk that doesn't work with computer neither) but I have a 2.5" 700Gb sata disk and a sata <-> ide converter so I've tried to use it with NA. After my "hardmod", I went to uLaunchELF and gotto hdd manager but it freezes at "Loading HDD Modules...". If I reverse adapter (it's bidirectional) hdd manager loads and show: "Connected: NO" so my first try dunno why, freezes.

    I've used this:

    -Adapter -> https://www.amazon.es/gp/product/B007MYOC0Q/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
    (picture)
    [​IMG]
    -Adapter chipset: JM20330

    -Molex cable:
    [​IMG]

    I hope someone can help me cause this is weird.

    Thanks you very much!! :)
     


  2. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
  3. Mr. Wizard

    Mr. Wizard Ending the spread of bullshit one thread at a time

    Member
    1,112
    425
    Mar 20, 2015
    Canada
    10th Dimension
    umbjolt likes this.
  4. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Thanks you :)
    Actually, my idea of using my sata ide adapter come because of your post :P
    SD Card method will be my next project in my friend ps2 ;)
    Shall I need FHDB too? PS2 Scene is quite new for me :blush:

    Thanks you too :)
    I'm using "header strips" (I mean the "males" connectors, just like jumpers are) so I guest them are short enought :P
     
  5. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    FHDB is just FMCB ran from your HDD. It runs without needing a memory card.
     
    umbjolt likes this.
  6. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Thanks you!

    Tomorrow I'll install FHDB. Will installing it solve the freeze problem?
     
  7. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    Last edited by zfreeman, Apr 14, 2017
    umbjolt likes this.
  8. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
  9. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    FHDB installed (disk previusly formated with winHIIP). Still no dice. If I turn on ps2 with only hard drive, FHDB doesn't load. If I use MC and open uLaunchELF and HDD Manager, it still freezes.
    What's wrong with my config? Is my NA broken? Or my SATA-IDE adapter?
     
  10. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    I've run into this too. Sometimes certain hard drives don't want to work on PS2. Sometimes a PS2 doesn't want to accept any hard drive, and I just conclude that a fuse or something in the PS2 is broken. I don't suppose you have another hard drive/PS2/network adapter to cut down on variables, do you?

    Try using the "Disk Management" program of a Windows system to format the entire drive to NTFS, avoiding the 'quick format' option to ensure that all sectors are renewed. Then use WinHiip to reformat that drive for use in a PS2. And then you should finally try that HDD in the PS2 again, with the same softwares as before. Hopefully it will then work, as all sectors on the entire disk surface should then be readable. I think the PC-side of things are more lenient when accessing the HDD than the PS2. You can then format with Winhiip, trying 28bit, 48bit, and Toxic.

    Change the position of the PS2 from/to horizontal/vertical. Maybe there's a connection that's loose.
     
    Last edited by zfreeman, Apr 14, 2017
    umbjolt likes this.
  11. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    I have a 3.5" sata disk too. Yesterday I dissasembly the PS2 to try using my 3.5" and sata-ide adapter and no dice.
    I'll re-format my 2.5" drive again. I really hope this wants to show up in PS2. Also, I've read that some NA can be faulty if them are clones but I'm 90% sure mine is original (bought second hand but I remember that my IDE disk last year show Connected: YES at least one time). Or maybe is my sata - ide adapter broken. Looking it I've notice that there are some resistors and capacitors missing but again, I don't wanna buy another sata - ide adaptor before testing my NA :P

    Thanks again for you help @zfreeman :)
     
  12. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Maybe I'm getting crazy but I think I need a 40 male to 40 male gender changer conector like this:

    [​IMG]

    (because NA and my adapter are female and I'm using header strips directly
     
  13. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    That would work. Right now, I'm leaning toward the hard drive being at fault. This Windows program will check the attached hard drives' health.
     

    Attached Files:

    Last edited by zfreeman, Apr 15, 2017
    umbjolt likes this.
  14. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Thanks again for all :)
    I've made the adapter homemade but it doesn't freeze anymore but it show "Connected: NO" so I've check if molex cable was OK. 5v wire were OK but 12v doesn't show any voltage, so I've dissasembly my PS2 and found that PS10 fuse is in short!

    [​IMG]

    Do you know where I can find any CCP2E50 or ICP-S2.3 fuse to replace it? :rolleyes: :rofl:

    Thanks again for all :)
     
  15. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    FIXED!!!!!!!!!!!!

    Thanks a lot for supporting me :P

    Just a question more @zfreeman
    When I start with freehdboot, console show sony logo, then trigger FHDBOOT and stay in a screen showing "Free mcboot" (MC is removed). This was about 1:30h ago
     
  16. zfreeman

    zfreeman GBAtemp Fan

    Member
    379
    116
    Mar 9, 2013
    United States
    Pennsylvania
    You should see the Sony intro, and the FMCB logo, but it should only take a few more seconds compared to booting it with a memory card. Try turning it off and on again.
     
    umbjolt likes this.
  17. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Thanks again. After rebooting HDD stop working but I've found that one molex cable was damage. I've fix it and now it's working!! :D
     
    zfreeman likes this.
  18. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore
    Hi again!

    I have a new problem maybe related with this, who knows...
    I have launched HDLoader from USB flashdrive and installed in HDD a retail game. After successfull instalation, I press "play" and Playstation 2 logo appeared and later, black screen. Orange led turned on for about 3-4 minutes and later, it dies. After that, I've tried using OPL (I have re-installed EVERYTHING on HDD, I mean, a clean FHDB using installer and a +OPL partition and copied opl elf in +OPL partition). After pressing play on OPL, I got the same, black screen after playstation 2 logo.
    What's wrong?

    Thanks!
     
  19. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,599
    2,874
    Oct 26, 2014
    Tuvalu

    Have you seen the SATA version of the network adaptor for PS2?

    https://www.aliexpress.com/item/Sat...lgo_pvid=fb0da737-eb78-4bad-8e22-c9b1de55e2e2
     
    umbjolt likes this.
  20. umbjolt
    OP

    umbjolt Wild jolteon

    Member
    541
    138
    Sep 15, 2016
    Magnolia, Fiore

    Thanks you!
    I already know about that kind of clone adapters but I have read that clone adapter (or at least some of them) are not really good and have problems with FHDB/OPL/general compatibility with games., albeit maybe if my sony adapter->sata doesn't work, I can get one of that :P
    Any 100%-200% reliable SATA adapter that is completly compatible with no issues? ^_^

    Thanks again! :D