rxtools problem

Discussion in '3DS - Flashcards & Custom Firmwares' started by saketo123, Jun 11, 2016.

  1. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    I am trying to install rxtools on 9.2, but the i cant generate firmware.bin. I saw on a different forum that i should use python 2.7, but I am already using that. When I open cdn_firm.py it opens and closes a split second later
     
  2. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,748
    4,530
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.14.0-2-zen
    Switch to Luma3DS, it doesn't require any "firmware.bin" nonsense.
     
  3. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    hobbledehoy899 likes this.
  4. BADDINOROX99

    BADDINOROX99 GBAtemp Advanced Fan

    Member
    649
    231
    Sep 9, 2015
    United States
    look I normally don't say this but try luma it's easier to install and set up

    edit:feel dirty after typing this
     
    Last edited by BADDINOROX99, Jun 11, 2016
    samiam144 and hobbledehoy899 like this.
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,286
    5,309
    Mar 17, 2010
    Norway
    Alola
    The issue is probably that the old firmware files that rxTools uses are removed from Nintendo's servers.
    You can try to find the old files through google, but you would have a much easier time if you switched to Luma3DS.
     
  6. BADDINOROX99

    BADDINOROX99 GBAtemp Advanced Fan

    Member
    649
    231
    Sep 9, 2015
    United States
    If for some reason you can't get luma setup I can p.m. you all the files I used to install rxtools on my 3DS
     
  7. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,192
    1,448
    May 1, 2016
    United States
    At least you didn't shove A9LH down his throat. So good on you on that~

    But no seriously, unless the CFW side of things get update on rxTools, which duke_srg's fork doesn't do at all either, we shouldn't be recommending rxTools. It's extremely buggy.

    Set up Luma3DS and forget about rxTools.
     
  8. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    with luma3ds can i install unsigned cia files?
     
  9. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    yes, you can do everything rxTools did and more.
     
  10. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,192
    1,448
    May 1, 2016
    United States
    Yes. It also does AGB/TWL patching on it's own. Has region-free built in, and let's you do region//language emulation for out-of-region .cias that need it.
     
  11. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    can I play online?
     
  12. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    yes
     
  13. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    many instructions that I am finding online are very confusing
     
  14. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,595
    2,635
    Jan 10, 2016
    Canada
    NO COFFEI!
    Go to the GitHub and download the zip and extract the 3ds, luma, and Luma3ds.dat file to the root of your sd card done
     
  15. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    ok, thanks

    — Posts automatically merged - Please don't double post! —

    do I require homebrew first
     
  16. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    yes but it would be the same for rxtools
     
    TheVinAnator likes this.
  17. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    I succesfully, installed luma3ds, but when I try updating the emunand it gives me an error
     
  18. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,595
    2,635
    Jan 10, 2016
    Canada
    NO COFFEI!
    Have heard that before but not really sure what sure what to do
     
  19. saketo123
    OP

    saketo123 Member

    Newcomer
    29
    2
    Apr 2, 2012
    United States
    I updated with sysupdater and it now works

    — Posts automatically merged - Please don't double post! —

    how do I install cia files