rxTools not booting to emuNAND?

Discussion in '3DS - Flashcards & Custom Firmwares' started by elemein, Mar 2, 2016.

  1. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    Hi there!

    I am trying to make it so my emuNAND coldboots.

    However, when it tries to cold boots, it fails to load into emuNAND.

    Let me give some more information.

    My sysnNAD is 9.2, and my emuNAND is the latest firmware. I am using rxTools, and it's all installed. My NANDs are unlinked. To setup the coldboot, I installed HBL on my sysNAND through FBI, then through that, started up and installed menuhaxx. After that, I replaced the menuhaxx boot with my rxtools boot. Then I installed CtrBootManager, replaced the boot with Ctr, and made it point to the rxTools boot.

    My sysNAND bypass works fine.

    When I startup my DS, it will flash it's neon colours, shortly display the rxTools splash screen on the top screen, then try to (and fail) boot into emuNAND. However, it just freezes with two black screens, not doing anything.

    Does anyone have any idea how to remedy this? :)
     
  2. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    Try cold booting into hbl and launching rxtools from there and see if that works
     
  3. kromlech06

    kromlech06 Advanced Member

    Newcomer
    54
    6
    Dec 10, 2012
    United States
    Menuhax is intercepting the Emunand loading and resulting in a black screen. Until you unlink the NNIDs, the emunand will keep trying to use the sysnand's menuhax. First, try getting into RXtools menu by holding L after selecting it on the CTRbootman screen (you may need to stop the CTR's autoboot timer). Move to the left in RXtool's menu and launch the emunand manually (Y button I think?), but keep your menuhax override button pressed. That should get you to your Emunand homescreen.

    From there you'll need to do the necessary steps to unlink your NNIDs as soon as possible, doing this manual boot override each time until then.
     
  4. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    I do not see that option in the HBL menu :$ What is it?

    Also, rxtools boots into emuNAND when I use browserhax to get to it.
     
  5. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    You have to download the rxtools.3dsx and put it in the homebrew folder
     
  6. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    How do I unlink my NNIDs?

    This wont need me to format anything, will it? Because I've already done that twice :(

    Edit: oh, I tried what you said, but I cannot actually get into rxTool's menu during coldboot. The splash only shows up for like 200ms, then tries to boot emuNAND.
     
    Last edited by elemein, Mar 2, 2016
  7. kromlech06

    kromlech06 Advanced Member

    Newcomer
    54
    6
    Dec 10, 2012
    United States
    Sorry I missed in the OP you said you had your NNID's unlinked, however those symptoms are the exact same as what I had the first day, so I suggested what I did to get around it (I knew mine were not unlinked for a couple days after, silly me!).

    To get to the RXtools menu you can try holding L during the CTRbootman selection screen, and hitting A over RXtools, holding L the whole time. I'm pretty sure RXtools responds to L to stop its auto Emunand booting.
     
  8. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    So it turns out that I can no longer access HBL :L CTRBootManager keeps intercepting it...
     
  9. samiam144

    samiam144 RĂ©gulier

    Member
    2,872
    936
    Aug 19, 2007
    Canada
    Hold SELECT, that is the default way to go into the CTRBootManager menu. Also, you did set up boot.3dsx as one of the entries in the boot.cfg right?
     
  10. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    The boot.3dsx is the CTR one. Is that the one I need it to redirect to? Otherwise I kind of erm... deleted the others besides the rxtools one :/

    — Posts automatically merged - Please don't double post! —

    No go :( Holding L just goes to double black screens. No rxTools splash screen either.
     
  11. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    So no one knows whats going on? :$
     
  12. kromlech06

    kromlech06 Advanced Member

    Newcomer
    54
    6
    Dec 10, 2012
    United States
    My best guess is start over from the top, where you copied your RXtools over to your SD card. You may have missed a step (like getting the firmware bin into the right folder or whatever). Also you may want to leave the other CTRboot options available next time (except reinand, you probably don't need that).

    Just one extra question that I can't seem to find in what you said: are you N3DS or O3DS? If you're N3DS using a 10.6 emunand with RXtools, make sure you're using a release that actually supports N3DS after 9.5.
     
  13. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    Again I recommend turning the rxtools boot.3dsx into an rxtools.3dsx and cold booting into hbl and launching rxtools from there
     
  14. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    My rxtools boot.3dsx is a rxtools.3dsx, and I cannot access HBL anymore because CTR manager keeps intercepting it.
     
  15. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    Remove ctr
     
  16. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    Hrm, I accidentally deleted my original boot.3dsx and can no longer get into HBL because without it, it can't route back to sysNAND :( Anyone know where I can get it?
     
  17. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    Smeas site
     
  18. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
  19. bi388

    bi388 GBAtemp Advanced Fan

    Member
    769
    338
    May 29, 2015
    United States
    The download named homebrew launcher main executable a bit down
     
  20. elemein
    OP

    elemein Advanced Member

    Newcomer
    94
    2
    May 16, 2008
    Canada
    Got in and tried to start rxtools. Double black screen again : s Maybe I should try to reinstall rxtools, which is odd since I've done that already.