Rom Injector for VC Titles

Discussion in 'Wii - Hacking' started by creffca, Apr 28, 2008.

  1. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    New version!

    CHANGES v2.1:
    -Possible fix for "could not find cert folder" error (most likely will not fix 4100 and 1022 errors)
    -Code clean up
    -Colored output for easily identifying messages

    Download V2.1

    I've been coding for so long I've forgotten to enjoy the fruits of my labor. I'm gonna go play me some final fantasy 6!!!
     
  2. blu9987

    blu9987 GBAtemp Regular

    Member
    1
    May 24, 2007
    United States
    It occurred even with wads that arent on my system... like Zelda OOT wad

    oh and creffca-
    "- Invalid link
    - The file was deleted because of violating our Terms of service"
     
  3. Warren_303

    Warren_303 GBAtemp Fan

    Member
    2
    Sep 7, 2007
    United States
    Westcoast
    This stuff is so kewl I've been reading up on it like all day. Can't wait to try it!

    Amazing that all these hax are available for the Wii.
     
  4. trebulator

    trebulator Advanced Member

    Newcomer
    1
    Nov 27, 2006
    United States
    Knoxville
    That might be it... I have SSB on my Wii right now, so I'll see what happens when I take it off. I'll confirm if it works.
     
  5. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    Just when I thought I was gonna have some free time...
     
  6. Nightstalker

    Nightstalker GBAtemp Regular

    Member
    1
    Jun 17, 2006
    United States
    Rochester, NY
    creffca I know what you mean. This Injection stuff is so hard to make error free because it deals with having the right files here and there and everything. The errors are all over the map too.
     
  7. harrybuttox

    harrybuttox GBAtemp Regular

    Member
    2
    Apr 29, 2008
    United States
    megaupload link says the file is no longer available
     
  8. megabug7

    megabug7 Forum Relic

    Member
    4
    Feb 4, 2004
    London
    I was trying to install a ntsc host-rom wad over a pal host-rom wad - and it wasn't having it.

    Results were actually worse then before [​IMG]

    Trying the same technique setting the Region to 1

    EDIT: Result: This Channel Can't Be Used [​IMG]
     
  9. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
  10. trebulator

    trebulator Advanced Member

    Newcomer
    1
    Nov 27, 2006
    United States
    Knoxville
    Didn't work. T_T
    I uninstalled both S&P, the SSB using S&P channel, and set the region to 1. Got 4100'd. I'm sure the SNES Wiimote channel and the Earthbound (DKC2) channel wouldn't mess with it... right?

    I'm not sure on the actual N64 rom's region though... I grabbed it off of emu-paradise.
    And... I haven't used any of these options, just in case that might be a problem:
    -sign Trucha sign Ticket and TMD
    -T Trucha sign Ticket
    -M Trucha sign TMD
    -i ABCD Change the title id
    -w Disables watermark on the ticket and uses a compatible generic ticket.
     
  11. Bslashingu

    Bslashingu Member

    Newcomer
    1
    Aug 7, 2007
    United States
    Was wondering if anybody ever fixed the "ERROR: could not find cert folder!" error.

    The new version does not fix it at all.
     
  12. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    Are you using vista or XP?
     
  13. megabug7

    megabug7 Forum Relic

    Member
    4
    Feb 4, 2004
    London

    Hmm thats strange - the Snes Wiimote channel is independant of a VC channel and shouldn't interfere
    The DKC2 channel well I've had problems with that error when I try to install different games on different channels - it seems it either overwrites it or with the NTSC version it's blocking it.

    I believe that the Host Rom's region is more important than the injected one as you can just change the region to 0 for it to work.
    But then the host channel works regardless of region so that doesn't make sense.
    You could try uninstalling the DKC2 channel - maybe that is the problem - but it's highly unlikely

    I've confused myself lol
     
  14. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    Well hmmm, looks like for the next version I might disable region patching and leave it up to you guys to use kknn's region patcher.
     
  15. trebulator

    trebulator Advanced Member

    Newcomer
    1
    Nov 27, 2006
    United States
    Knoxville
    I just installed Emerald Dragon from stev418, so I don't think the SNES and DKC2 channels are messing with it at all. I doubt it has anything to do with region, either. Aaaah... I've been at this for hours and I still have no idea! [​IMG]
     
  16. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    Swapping ROMS is illegal here...any how, region patching might have something to do with it. There is a region flag in the title/ticket name as well. For some odd reason N64 wads seem to be more picky about ticket name than other types of wads.
     
  17. pwn3d91

    pwn3d91 Member

    Newcomer
    1
    Apr 17, 2007
    United States
    Has anyone figured out the "4KB file output" problem?
     
  18. creffca
    OP

    creffca GBAtemp Regular

    Member
    1
    Feb 1, 2007
    United States
    4kb error is due to not having common-key.bin in your install directory.
     
  19. Slave

    Slave GBAtemp Fan

    Member
    3
    Aug 29, 2006
    Canada
    Montreal, Quebec.
    anyone up to try:

    N64:
    -Killer Instinct Gold ?
    -MK Trilogy
    -WipeOut 64
    -Ogre Battle 64
    -Wetrix
    -Starcraft 64

    SNES:
    -MK1 & 2
    -Super-Punch-out!
    -Battletoads
    -all the megaman

    haha sorry, big list... but Thanks to whoever test those and update the wiki page! :-)

    Thanks!
     
  20. pwn3d91

    pwn3d91 Member

    Newcomer
    1
    Apr 17, 2007
    United States
    Thanks a lot, I'm getting a correct sized file, but it won't install. (WAD installer gives me a 4100 error)
     
Quick Reply
Draft saved Draft deleted
Loading...