1. Jerret Douglass

    OP Jerret Douglass Advanced Member
    Newcomer

    Joined:
    Feb 23, 2013
    Messages:
    87
    Country:
    United States
    I've encountered a few issues with the Revo K101 and want to know if there are fixes.

    1. Super Mario Advance 4 - Super Mario Bros. 3 sound issues
    2. Super Mario Advance 2 - Super Mario World black backgrounds in levels
    3. Pokemon Brown rom hack on screen graphical glitches
    4. Pokemon Liquid Crystal rom hack RTC doesn't work
    5. If you had any hopes of running a Pokemon Randomized Nuzlocke rom sorry to disappoint but the rom will not load

    I'll post more when I find them.

    8/7/2013 Edit: I have encountered my first save problems. My Advanced Wars and Pokemon Liquid Crystal .sav's will not load and I have to start them over. I save correctly and use *Start after I save.

    8/7/2013 Edit: I tried out GBC emulator for the first time today and games do not save at all. I have tried different games and none of them save.

    8/7/2013 Edit: Pokemon Series sound issues, hoping over ledges, healing pokemon music, pokemon fainting
     
  2. Isaac

    Isaac American
    Member

    Joined:
    Dec 8, 2012
    Messages:
    320
    Country:
    United States
    Try doing a firmware update. That may solve your problems
     
  3. Jerret Douglass

    OP Jerret Douglass Advanced Member
    Newcomer

    Joined:
    Feb 23, 2013
    Messages:
    87
    Country:
    United States
    Can you link me on how to do that?
     
  4. Isaac

    Isaac American
    Member

    Joined:
    Dec 8, 2012
    Messages:
    320
    Country:
    United States
  5. Jerret Douglass

    OP Jerret Douglass Advanced Member
    Newcomer

    Joined:
    Feb 23, 2013
    Messages:
    87
    Country:
    United States
  6. Isaac

    Isaac American
    Member

    Joined:
    Dec 8, 2012
    Messages:
    320
    Country:
    United States
    I'm not entirely sure. Try look in your options. and your settings.
     
  7. radzix

    radzix Newbie
    Newcomer

    Joined:
    Jan 2, 2017
    Messages:
    1
    Country:
    Poland
    Hi, i have problem with my two day new Revo. It just stuck on Gameboy logo, i cant do nothing. Any suggestion what can i do?
     
  8. warmo161

    warmo161 GBAtemp Regular
    Member

    Joined:
    Nov 3, 2011
    Messages:
    158
    Country:
    United Kingdom
    Ive had a lot of problems recently with my K101 plus, and it seems to me that the newer firmware actually makes my console worse! (I have rolled back to the original one it shipped with, which is the first)

    Ive had constant problems involving the power button refusing to turn the console off and the console not waking up from sleep mode. I left it on charge to other day to come back and find the green light on for no reason and I couldnt turn the console back on again

    I 'fix it' by removing the battery, although recently remembered that there is a reset button, but because of the unreliability, i cant recommend the console or even leave the house with it, just incase it gets stuck!

    My main issue with it though is that it doesnt support gameboy cartridges. Also because I dont want to end up buying tons of spares and more consoles, I am not planning to buy a 101GBA etc because its just too much money. At the moment I am waiting to see how the new Gameboy clone console by retrobit holds up and get that

    Because the console simply isnt that popular, I cant find any support for it at all and its just so fustrating :(
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Problems,