Official Retroarch WiiU (wip.)

Discussion in 'Wii U - Homebrew' started by aliaspider, Nov 6, 2016.

  1. ploggy

    ploggy WAKA! WAKA!

    Member
    12
    Aug 29, 2007
    United Kingdom
  2. MalusCalibur

    MalusCalibur Newbie

    Newcomer
    1
    Nov 9, 2009
    Apologies for not getting back to you sooner - by the time I saw this response that file had been removed and newer updates had been added, so I tried the latest one; to the same results and thus the same problem...


    Fair enough. Certainly going directly through the cores is the closest I've had to getting it to work.


    Indeed, as I gleaned from one of the tutorials, but it still doesn't seem to work - I've enclosed a screenshot of the 'media' folder (that I had to create since it isn't there by default) and all the files that are in it, in the hope you can help identify the problem since the menu icons are still all garbled.

    This time around, when I used the 'Load Content' option, I was able to navigate to a folder on the SD root I'd called 'roms', but within that folder Retroarch claimed there were no further files, when in fact there is another subfolder called 'NES' filled with NES roms (again, I'm testing all this with just the NEStopia core on the SD card). I tried moving all the roms to retroarch/downloads (as the 'directories' options menu in Retroarch pointed to this folder, even though it didn't exist at the time, so I thought it might better recognise it), but doing so made file navigation with 'Load Content' stop at the SD card root again, claiming no further files.

    I've tried using the inbuilt 'scan folder for compatible files' option, but to no avail, and I've tried using the online updater for the assets, likewise to no success.

    I'm out of ideas!
     

    Attached Files:

  3. huma_dawii

    huma_dawii GBAtemp Addict

    Member
    8
    Apr 3, 2014
    United States
    Planet Earth
    Inside your "MEDIA" folder should be ANOTHER folder called ASSETS, then inside that ASSETS folder you extract the assets.zip.
     
  4. ploggy

    ploggy WAKA! WAKA!

    Member
    12
    Aug 29, 2007
    United Kingdom
    Looking at your pic I can see your using an older Assests.zip (there's too many files in your media folder) :P this is my media folder
    Untitled.jpg
    Assets were updated recently, so your going to want to grab the newest Assests.zip from the buildbot site..
    https://buildbot.libretro.com/assets/frontend/assets.zip

    Also.. Try deleting your Retroarch.cfg, you wont believe how many times that has fixed a random issues people have :P


    There's no Assets folder.. just retroarch/media.. See my pic above :)
     
    Last edited by ploggy, Oct 11, 2018
    DarthDub likes this.
  5. huma_dawii

    huma_dawii GBAtemp Addict

    Member
    8
    Apr 3, 2014
    United States
    Planet Earth
    Weird!
    WEIRD!

    Look at mine xD
    upload_2018-10-11_11-52-43.png
     
  6. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    17
    Jan 17, 2013
    Mexico
    Mmmm perhaps something's borked with either RetroArch, the assets folder or with the configuration files.
    I'd recommend you do one of the following things (or all of them in order if one fails):
    • First and foremost, update all of your current cores and setup to the latest nightly found in http://buildbot.libretro.com/nightly/nintendo/wiiu/
    • Once updated, try using the Online Updater and try to download the "assets" package through there.
      One thing worth noting though, I heard that there's an issue with the online updater on Wii U which makes the assets folder to get stuck at 30% and then start the download over again.
      Let it do this for 2-3 times, and then reboot the Wii U.
    • Once that is done, be sure to go to Settings -> Directories and establish the Path to the Assets folder as /retroarch/media/assets.
      If you already had it like that, change it to /retroarch/media/, then save and reboot RA, and set it back up again to make sure the .cfg file is updated properly.
    • If all else fails, as Ploggy said, I recommend that you delete the .cfg file to ensure you are running something as close as a clean install is related
    This should get you back on track, if you are still experiencing issues with the assets after this, be sure to let us know.
     
  7. ploggy

    ploggy WAKA! WAKA!

    Member
    12
    Aug 29, 2007
    United Kingdom
    lol weird indeed, :P did you set the assets path manually?
     
  8. ploggy

    ploggy WAKA! WAKA!

    Member
    12
    Aug 29, 2007
    United Kingdom
    Had a chance to test the new nightly's with the new Netplay updates.. The WiiU can connect to Switch when its set as host pretty consistently with the Fceumm core but I cant connect my Switch to WiiU when the WiiU's set as host?
    When it does connect though it's perfect, no lag, no stuttering, but I bet being in the same network helps ALOT :P

    So far I havent been able to get FBA to work and snes is far too slow, Snes2010 and Snes9x are the only Snes core on Switch atm. perhaps it would be faster with Snes9x2002 or 2005, I'll have to see if any of the Switch Emu Devs are willing to compile them on Switch :P
     
    Last edited by ploggy, Oct 11, 2018
    ShadowOne333 likes this.
  9. BoxNinPlay

    BoxNinPlay GBAtemp Regular

    Member
    2
    Jan 4, 2016
    United States
    Hello Fix94, thanks for all your work, this link is not longer working, do not know if you post a new one, thanks in advance....
     
  10. huma_dawii

    huma_dawii GBAtemp Addict

    Member
    8
    Apr 3, 2014
    United States
    Planet Earth
    My assets work :v I don't have a problem
     
  11. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    Hey guys, some new developments! Thank @gblues for all this work so far!


    — Posts automatically merged - Please don't double post! —

    Interesting, can you talk with us about this on our Discord?
     
    VinsCool, A Plus Ric, oji and 2 others like this.
  12. huma_dawii

    huma_dawii GBAtemp Addict

    Member
    8
    Apr 3, 2014
    United States
    Planet Earth
    Has it been pushed to the betas?
     
  13. BoxNinPlay

    BoxNinPlay GBAtemp Regular

    Member
    2
    Jan 4, 2016
    United States
    Hello a noob question, may I use Retroarch Channel and throw the HBL at the same time, or should I use just one of them? I mean, perhaps today I use the channel and for some reason tomorrow I use throw the HBL.
     
    Last edited by BoxNinPlay, Oct 11, 2018
  14. depaul

    depaul GBAtemp Advanced Fan

    Member
    4
    May 21, 2014
    France
    You can use both methods (through launcher or load core through hbl)
     
  15. BoxNinPlay

    BoxNinPlay GBAtemp Regular

    Member
    2
    Jan 4, 2016
    United States
    Thanks...!!!
     
  16. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    I need to ask you guys a favor once the next nightlies roll off the presses -

    We need to see if netplay rooms work on WiiU.

    Try this once the nightlies are ready:
    1) Start a netplay room on another device (could be anything from RetroArch Android to RetroArch PC, doesn't matter - something that is on your LAN).
    2) Then go to RetroArch WiiU and see if you can find the room, and connect to it.
     
  17. Radius4

    Radius4 GBAtemp Fan

    Member
    6
    Sep 10, 2015
    Ecuador
    Just to clarify
    LAN rooms are clearly identified, like this.

    upload_2018-10-11_20-47-10.png
     
    A Plus Ric and ShadowOne333 like this.
  18. YukidaruPunch

    YukidaruPunch Member

    Newcomer
    1
    Oct 24, 2017
    Brazil
    Online play seems awesome! Shame I'm a fossil when it comes to those things so I doubt I'll ever be able to enjoy it.
     
  19. depaul

    depaul GBAtemp Advanced Fan

    Member
    4
    May 21, 2014
    France
    Thanks for your hard work guys. Sure I will test later my Wii U and my Android phone :)

    Edit: Thanks Netplay worked!
    -Used the latest Nightly (12/10/2018)
    -Used the game "Street Fighter 2 - World Warriors" (SNES), with core SNES9X
    -Used my android phone as a host, noted my IP
    -Connected to that IP with my Wii U, and my Wii U immediately displayed game screen and I was able to challenge as Player 2
    There are just some minor network lag.
     
    Last edited by depaul, Oct 12, 2018 at 7:37 PM
  20. MrFloyd

    MrFloyd Newbie

    Newcomer
    1
    Oct 11, 2018
    Croatia
    Hi,
    is there some how-to to get Amiga core working on Wii U?
    I have put those(guide from libretro-uae on github):
    To use disk and WHDLoad games with this core you'll need the following kickstart roms, rename them to the given name and copy the file to RetroArch system directory.

    It is critical to use kickstarts with the right MD5, otherwise the core might not start.

    Name Description System MD5
    kick34005.A500 Kickstart v1.3 (Rev. 34.005) Amiga 500 82a21c1890cae844b3df741f2762d48d
    kick40063.A600 Kickstart v3.1 (Rev. 40.063) Amiga 600 e40a5dfb3d017ba8779faba30cbd1c8e
    kick40068.A1200 Kickstart v3.1 (Rev. 40.068) Amiga 1200 646773759326fbac3b2311fd8c8793ee




    into system folder, but Retroarch freezes with black screen after loading core.
    If there is some tutorial i will be gratefull.....
     
    Last edited by MrFloyd, Oct 14, 2018 at 5:34 PM
Loading...