Retroarch | Exception (DSI) occurred

Discussion in 'Wii - Emulation and Homebrew' started by nutella, Dec 28, 2014.

  1. nutella
    OP

    nutella Low Glycemic Index

    Member
    1,097
    3
    Sep 4, 2008
    Your nearest supermarket
    Does anyone know why I get an error whenever I try to load roms in Retroarch? SNES roms work just fine, but all GBA roms and N64 roms (though I only really care about GBA roms atm) get the same error. This happens every time, with every rom.

    I made a quick video to show the error.

     
  2. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Retroarch doesn't have N64 emulator.
     
    TeamScriptKiddies likes this.
  3. nutella
    OP

    nutella Low Glycemic Index

    Member
    1,097
    3
    Sep 4, 2008
    Your nearest supermarket
    My bad, I was thinking of the PC port when I typed that. In any case, GBA games are not working still. Newly formatted SD card. Tried both SD and SDHC. Copied the app multiple times. Used different builds. All with the same result.
     
  4. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Maybe you change some setting? Did you try deleting your configuration file?
     
  5. nutella
    OP

    nutella Low Glycemic Index

    Member
    1,097
    3
    Sep 4, 2008
    Your nearest supermarket
    Yes, I have tried deleting my config file. I've tried installing different versions. No luck. Can anyone confirm that they have GBA roms working in Retroarch?
     
  6. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,227
    10,081
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    What version are you using? I'm using 1.0.0.2 the VBA Next, I've gotten this error, maybe three times at the most. Do you have any rewinding options enabled by chance? They tend to cause instability issues I noticed. 1.0.0.3 is coming out soon, and have you reported the issue on the Libretro forums about this?
     
  7. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,327
    522
    Nov 6, 2002
    United Kingdom
    Wigan, land of the Pies
    Like randomizer says rewind on will definitely cause problems on VBA Next. Otherwise it's a strange one ...do your roms have headers?
     
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,227
    10,081
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Either that or the ROM files corrupt, are zipped, or have headers on them, there are utilities out there to remove them. All the GBA ROMs I have on my SD card all boot fine, so this is a weird issue.
     
  9. nutella
    OP

    nutella Low Glycemic Index

    Member
    1,097
    3
    Sep 4, 2008
    Your nearest supermarket
    It appears that I there were two problems. One, the particular rom I kept testing got corrupted after copying it back and forth so many times, and secondly, I had rewind enabled.
    Thanks for the help everyone :)
     
    the_randomizer likes this.
  10. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,227
    10,081
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Glad we were able to help :)