[Request] Compiled version of region four OOT

Discussion in '3DS - Flashcards & Custom Firmwares' started by Rizzorules, Jun 8, 2015.

  1. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    ubergeek77 and Ronhero like this.


  2. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    Forget about it, i will compile it myself
     
    Zidapi likes this.
  3. keven3477

    keven3477 Fresh Prince of Lemonade

    Member
    867
    1,302
    Jul 12, 2012
    United States
    Somwhere you can never find.
    wish you luck.
     
    Rizzorules likes this.
  4. ubergeek77

    ubergeek77 Post editing world champ.

    Member
    556
    255
    Dec 6, 2014
    United States
    Were you able to compile it? And if so, does it work successfully? I currently need it in order to run my out of region Cubic Ninja for Pasta. If you could share it, that would be awesome.
     
  5. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    Yellows 8 helped me, i only build the save with the files he gave me, i build it using savedatafiler
    http://share.pho.to/9Tawx
     
  6. happydance

    happydance GBAtemp Advanced Fan

    Member
    578
    83
    Jul 16, 2009
    can you point me to the right direction or guide to compile this. I already got a Linux VM setup when I tired to compile OPL, but on 3ds, I'm totally clueless
     
  7. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    I didnt compile it, yellows8 gave me some files (Payload.bin and save00.bin) and i injected them with savedatafiler, you need a 4.x-9.2 to use it.
    This yellows8 files are for a Jpn New 3ds 9.8:
    https://dl.dropboxusercontent.com/u/20520664/regionFOUR_oot3d_jpn_new3ds_v98.zip
    If you have a different 3ds you should try to ask yellows8 for different files
     
  8. happydance

    happydance GBAtemp Advanced Fan

    Member
    578
    83
    Jul 16, 2009
    I am hesitant to disturb the good guy so I was asking on how to do it... and for some reason.. I'm unsure of the region of my cart

    it say LNA-CTR-AQEE-MDE and got a logo saying U.A.E. Saudi Arabia and Malaysia/Singapore on the box... it's like a crazy version of EUR/ASIA but works on my USA 3DS :wacko:
     
  9. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    MDE is Middle east if it works with your usa console then you should try usa files
     
  10. happydance

    happydance GBAtemp Advanced Fan

    Member
    578
    83
    Jul 16, 2009
    okay... tired to set up a dev environment on Ubuntu and tried to compile it but I'm having difficulties with some points

    SAVE_FILES = oot3dhax_eur.bin oot3dhax_usa.bin oot3dhax_jpn.bin (just select the region & delete the rest)
    REGIONS = 2 1 0 (which is which? for us,eu and jp)

    and for the make file command "make EXECHAX={value} FWVER={value}" it's said on the instruction that >=0x25 for system-version >=v5.0... what about 4.X or 4.4? i'm trying to test this out on my 4.x 3ds before attempting to purchase a n3ds

    don't know yellow8's user name here and can't find it, so i'll just post here, cause someone might know

    *edit
    manage to build a oot3dhax_jpn.bin that matches the md5 your save00.bin the only problem is my firmware ver and the payload since I only got oot3dhax_jpn.bin and oot3dhax_jpn.elf and no payload
     
  11. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    I dont think someone will help you, just ask yellows8 for Payload.bin and save00.bin. Just tell him your region,type of 3ds (old/new) and version. Once you have those files inject them in your catridge using savedatafiler (Gw/rxtools/pasta). You can contact him in github, go to his repo and make a comment
     
  12. happydance

    happydance GBAtemp Advanced Fan

    Member
    578
    83
    Jul 16, 2009
    got it working now, manage to inject the save and see the 1st save as Haxxxxxxxxxxxx, but I don't think regionfour is compatible on 4.X os testing it to this 3ds is usless. will try to update it and see if all is OK.

    geez all this work just to confirm my cart is compatible.
     
  13. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    Thats great!!! You should consider making a tutorial for those who want to use region four on Zelda oot, it doesnt have a big demand but it would be cool
     
  14. orangefinal

    orangefinal Newbie

    Newcomer
    2
    0
    Jun 20, 2015
    United States
    Anyone have the save/could compile for japanese n3ds firmware 9.7.0-25j?

    Also will I be able to load the save with a us old 3ds xl 9.2 system (with ninjahax and pastacfw)?
     
  15. happydance

    happydance GBAtemp Advanced Fan

    Member
    578
    83
    Jul 16, 2009
    there's a post above, that has a link to what you are looking for... post #7 to be exact...
     
  16. orangefinal

    orangefinal Newbie

    Newcomer
    2
    0
    Jun 20, 2015
    United States
    I thought that was only for 9.8? Will it work for 9.7 as well (would rather not update)?

    Also, any info on my other question?
     
  17. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1

    Originally it was only 9.2 and 9.8, but it has since been updated to support everything in between those FW's (so yes, it supports 9.7)
     
  18. Rizzorules
    OP

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    It only works in 9.8, you should update or get other files. It freezes and closes the game when you use it in 9.7
     
  19. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    You must be using a payload from before regionfour supported the other FW's
     
  20. Shadowtrance

    Shadowtrance GBAtemp Addict

    Member
    2,482
    1,515
    May 9, 2014
    Hervey Bay, Queensland
    The regionfour payload is still version/region specific.
     
    LameNobody likes this.