Homebrew Suggestion (Request) A Complete and Updated Noexes Installation Tutorial

Biggles

Active Member
OP
Newcomer
Joined
Jun 13, 2020
Messages
26
Trophies
0
XP
76
Country
United States
I've been struggling with getting Noexs to work on my switch. I've been piecing it together from several other tutorials, many of which are out of date.
I'm on 10.0.4, with atm 0.12.0. I also prefer to use my emuNAND through Hekate. I've disabled my EdiZon cheats.


My hekate_ipl.ini is set up as suggested as in the tutorial on his github page. I've tried using their latest release and the updated .kip file. When I restart my switch and choose NoExs, I get the error.
"No mandatory secmon or warmboot provided, failed to launch HOS"

Does anyone have an idea on what I should do next?

If someone could point me in the right direction for how to get it installed, I could put together a comprehensive tutorial. Or if someone else had a bit of spare time and wanted to do a tutorial themself, that would be awesome too.


__________________________________________________________________________________________________
Here's some useful links in case anyone is searching around as I have:
Noexes github page (releases)

Noexs remote debugger release page by @matt123337

Guide on how to use noexes by @wiitendo84

RAM dump parser by @RyDog

Java 10 JRE. No other version works. You need an Oracle account to download these, which is free.
 

matt123337

Well-Known Member
Member
Joined
Mar 25, 2014
Messages
151
Trophies
0
XP
603
Country
Canada
You most likely have an outdated Hekate or atmosphere install, as that error happens before Horizon even starts, let alone Noexes Try reinstalling both over what you have right now and see if that fixes it
 
  • Like
Reactions: wiitendo84

Biggles

Active Member
OP
Newcomer
Joined
Jun 13, 2020
Messages
26
Trophies
0
XP
76
Country
United States
You most likely have an outdated Hekate or atmosphere install, as that error happens before Horizon even starts, let alone Noexes Try reinstalling both over what you have right now and see if that fixes it
I updated Hekate and atm (0.13.0) and it's still not working. To be clear, I'm supposed to launch Noexs, then I'd be able to run emummc right? Would I be able to just run them together without running the .kip separately?
 

wiitendo84

Well-Known Member
Member
Joined
Jan 3, 2014
Messages
1,246
Trophies
1
Age
37
Location
New Albany, Indiana
XP
2,824
Country
United States
I messed up my sd card recently and couldnt get noexs to connect. So I was lucky to have found an old sd card setup and just copied that onto my card and overwrite everything on it. Then I downloaded the newest atmosphere and overwrite what I just put on it. Now noexs is working again. It may be just some settings that need to be tweaked.

--------------------- MERGED ---------------------------

You most likely have an outdated Hekate or atmosphere install, as that error happens before Horizon even starts, let alone Noexes Try reinstalling both over what you have right now and see if that fixes it
Matt it's been a long time man. How you been?
 

Biggles

Active Member
OP
Newcomer
Joined
Jun 13, 2020
Messages
26
Trophies
0
XP
76
Country
United States
Ok i get the same error as OP
I was able to get it to run if I set up my Hekate_ipl.ini like this:

[Noexs]
fss0=atmosphere/fusee-secondary.bin
kip1=modules/noexs/noexs.kip1
kip1patch=nosigchk
logopath=bootloader/bootlogo.bmp
atmosphere=1

I was able to connect to the java program, but it doesn't seem to want to do anything. I'll mess around with it some more today.
 

Biggles

Active Member
OP
Newcomer
Joined
Jun 13, 2020
Messages
26
Trophies
0
XP
76
Country
United States
I was able to get it to run if I set up my Hekate_ipl.ini like this:



I was able to connect to the java program, but it doesn't seem to want to do anything. I'll mess around with it some more today.
Actually, now that I've messed with it a bit more, it seems to be working fine this way.

For anyone who stumbled upon this thread needing help, I released a tutorial on how to install and run Noexes. Here's a link:

https://gbatemp.net/threads/tutoria...-debugger-on-switch-hekate-atmosphere.569079/
 
Last edited by Biggles,
General chit-chat
Help Users
  • No one is chatting at the moment.
    elBenyo @ elBenyo: links? no.