1. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    Hi,

    My daughter is running SX OS (no emunand no nothing) with the latest update that was available back then (FW 11.0.0 with SX OS 3.1.0 I believe).
    One of the games she plays won't boot because it is asking for the console to be updated to the latest FW.
    Is there a way to force it to run on her current version of the OS and get past this nag screen ?
    The games was patched with nsc builder (0.98) a command prompt application.

    Thanks.
     
  2. thesjaakspoiler

    thesjaakspoiler GBAtemp Fan
    Member

    Joined:
    Nov 20, 2018
    Messages:
    328
    Country:
    Afghanistan
    Tinfoil and GoldLeaf seem to have an option for that but I have never used it :

    goldleaf :
    - go to "manage content" (or something, i dont have it in english something),
    - choose where the game is installed (sd card or nand user),
    - select the game, then select "base title"
    - select the option to reset the launch version (its the last one just before "cancel"; be carefull to not touch anything else, especially DONT TOUCH delete ticket)

    tinfoil :
    - go into the installed game
    - hoover the game you want and click X for "uninstall" (dont worry it wont uninstal at this point)
    - select the BASE (the first one of the list) and click Y to reset version
     
  3. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    Thanks, I installed the latest builf of Goldleaf but the game is an xci on the SD card, and I am not getting any menu to change anything besides the menus that tell me some game information.

    In Tinfoil I followed the process and clicked to reset version (on the main game, the updates and DLC) and it still fails.

    Guess I am going to have to find another way to update the console. I will create a new thread to ask the questions there.
    Thanks again.
     
  4. Sammy_Lee

    Sammy_Lee Advanced Member
    Newcomer

    Joined:
    May 22, 2007
    Messages:
    91
    Country:
    Germany
    You can use the Tool SAK under Windows to patch xci for lower FW, use „patch xci“ in the upper left and it will start with FW 11.0

    https://github.com/dezem/SAK
     
    Aglae Pheryl likes this.
  5. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    Newb here: How do I grab all files at once from this link ?
     
  6. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    Thanks, just out of curiosity how do I get to do this myself so I don't have to rely on anyone else to grab all files at once ?

    — Posts automatically merged - Please don't double post! —

    Never mind, I should have looked more thoroughly

    upload_2021-5-6_15-26-29.png
    clicking latest did the trick

    Thanks
     
  7. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    BTW, it fixed the issue with the game.
     
    Sammy_Lee likes this.
  8. MachRc

    MachRc GBAtemp Regular
    Member

    Joined:
    Nov 30, 2017
    Messages:
    160
    Country:
    United States
    also, there seems to be alot of releases with "patched" at the end of the file.
    they have been steadily releasing games that are already patched to work below 12.1 or whatever SX os is stuck on.

    so check for those as well.
     
    Aglae Pheryl likes this.
  9. Aglae Pheryl

    OP Aglae Pheryl GBAtemp Fan
    Member

    Joined:
    Feb 25, 2014
    Messages:
    409
    Country:
    France
    I'd rather keep doing it myself from the 'official' release I get. This tool works just great (for now).
    Thanks anyway.
     
    Sammy_Lee likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - required, version, Remove