[RELEASE] Luma Updater

Discussion in '3DS - Flashcards & Custom Firmwares' started by KunoichiZ, May 24, 2017.

  1. codezer0

    codezer0 Gaming keeps me sane

    Member
    6
    Jul 14, 2009
    United States
    The Magic School Bus
    Has there been any progress with this? It seems to have a real problem with newer system updates, and it's basically insisting that it can't connect or download the new Luma, either.
     
  2. KunoichiZ
    OP

    KunoichiZ GBAtemp Guru

    Member
    14
    Mar 16, 2012
    United States
    This is the first I've heard of this. Do you have v2.3 installed? I'm on 11.7 and it works perfectly.
     
    Last edited by KunoichiZ, Jul 10, 2018
  3. codezer0

    codezer0 Gaming keeps me sane

    Member
    6
    Jul 14, 2009
    United States
    The Magic School Bus
    Yep. Iy seems I've been on 2.3 and now system 11.7 and since the system update, it's basically refused to check online for an update.
     
  4. mike a

    mike a GBAtemp Advanced Fan

    Member
    3
    Oct 28, 2014
    United States
    It's because of the github thing.. Mine won't update I don't know where to get the newer Luna updater. Wish the developer would have some other place for it to search for its updates.. Like a site just for Luna no github involved
     
  5. astronautlevel

    astronautlevel Cyberpunk Bartending Action!

    Member
    14
    Jan 26, 2016
    United States
    That Nightly Site™
    It's not because of the github thing, 2.3 uses libcurl which supports the TLS v1.2 protocol that GitHub uses. In fact, 2.3 was released specifically to work with the newer github standards.
     
  6. Barawer

    Barawer GBAtemp Regular

    Member
    3
    Jan 3, 2016
    Israel
    Israel
    i have no issues with it, works fine on my end.
     
  7. D34DL1N3R

    D34DL1N3R Nephilim

    Member
    4
    Dec 6, 2008
    United States
  8. KunoichiZ
    OP

    KunoichiZ GBAtemp Guru

    Member
    14
    Mar 16, 2012
    United States
    I’m sorry but I’m not going to make a site specifically for Luma Updater and its updates. As nice as it would be, it’s not necessary and I simply don’t have the time. I’ve made plenty posts regarding v2.3, status updates regarding it and the post where I actually released it. It’s not my fault that you didn’t know where to get the newest update or that you didn’t think to simply check the Github. Yes, any version 2.2 or below will not update as a result of the Github thing.

    Thank you for confirmed that it works fine! :)

    I’ve expressed my reasons for not wanting to add the nightlies back to Luma Updater multiple times now. I’ve thought about it and as of right now, my answer is still no.

    — Posts automatically merged - Please don't double post! —

    That’s on you and your connection then. Another person has stated it works perfectly fine.
     
    Last edited by KunoichiZ, Jul 10, 2018
    Quantumcat and astronautlevel like this.
  9. mike a

    mike a GBAtemp Advanced Fan

    Member
    3
    Oct 28, 2014
    United States
    OK gonna download the latest version of the updater, do I just install the CIA file? And then does it replace the one I currently have?
     
  10. KunoichiZ
    OP

    KunoichiZ GBAtemp Guru

    Member
    14
    Mar 16, 2012
    United States
    Yes to both.
     
    mike a likes this.
  11. Treeko

    Treeko GBAtemp Fan

    Member
    3
    Sep 29, 2012
    Hey I've been having issues with Lumaupdater on my systems for a while now, I am using B9S 1.2 or 1.3, I am pretty sure its either one of them, loading up lumaupdater gets to "looking for an updated updater" stage then crashes my system and forces a restart, any help would be appreciated.
     

    Attached Files:

  12. sks316

    sks316 Rainbow Dash is best pony

    Member
    8
    Nov 28, 2013
    United States
    Ponyville
    Ensure that you're using the latest updater. https://github.com/KunoichiZ/lumaupdate/releases/latest
     
  13. Treeko

    Treeko GBAtemp Fan

    Member
    3
    Sep 29, 2012
  14. Fernando51

    Fernando51 Member

    Newcomer
    3
    GBAtemp Patron
    Fernando51 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 30, 2011
    El Salvador
    Star Road
    Hey, I was wondering if there's a way to ONLY update the boot.firm on my CTRNAND. I don't want luma on my SD Card, only on my CTRNAND, but everytime I use this app (no matter if I didn't have a boot.firm on the SD card in the first place) it always updates luma on both my SD card and my CTRNAND. I thought there'd be an option to configure this behavior but it is nowhere to be found. :(
     
  15. ParzivalWolfram

    ParzivalWolfram Advanced Member

    Newcomer
    1
    Jun 28, 2017
    United States
    Yeah, just use GodMode9 for that. The payloads folder for CTRNAND are in /rw/luma/payloads, so stick GM9 there to use it whenever, SD-less.
     
  16. Fernando51

    Fernando51 Member

    Newcomer
    3
    GBAtemp Patron
    Fernando51 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 30, 2011
    El Salvador
    Star Road
    Well, I know I can just copy over the old .firm with the updated one manually, but I thought being able to use Luma Updater (and it having an option that let you update only the firm on the CTRNAND and not the one on the SD Card) would be useful for some people. But hey, I can live with that. :P
     
  17. qqq1

    qqq1 Advanced Member

    Newcomer
    3
    GBAtemp Patron
    qqq1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 14, 2009
    United States
    Same problem here. I just installed the latest to make sure that's what I had. Crashes after running a bit.

    My mistake, the new one didn't show up right away and the old one was still there. Latest version now working.
     
    Last edited by qqq1, Jul 31, 2018