[RELEASE] Luma Updater

Discussion in '3DS - Flashcards & Custom Firmwares' started by KunoichiZ, May 24, 2017.

  1. Xsprit

    Xsprit Member

    Newcomer
    1
    Jan 27, 2016
    Thank you so much for the update!
     
  2. DuliaDarling

    DuliaDarling Member

    Newcomer
    1
    Jan 26, 2018
    United States
    Okay, I'm having a rather stupid problem with this. Its worked for me before but something keepa happening. I'm using Boot9Strap, like O'm supposed to, and I have Luma 2.2 updated to 9.0. It works for the first few weeks after I install it and then for aome reason it ALWAYS does this. The only way I've found to fix it is to completely reinstall Boot9strap, and I am NOT doing that again. I can open Rosalina just fine, but once it hits this error page, it freezes my n3ds and I have to hard reboot it. Really really frusterating.
     

    Attached Files:

  3. KunoichiZ
    OP

    KunoichiZ GBAtemp Guru

    Member
    14
    Mar 16, 2012
    United States
    Install the latest version. Github removed support for TLS v1.0/v1.1, which is what previous versions of Luma Updater relied on. This has since been fixed in the latest version and you need to use that. Link to it can be found in the first post.
     
    Last edited by KunoichiZ, Mar 26, 2018
    DuliaDarling likes this.
  4. DuliaDarling

    DuliaDarling Member

    Newcomer
    1
    Jan 26, 2018
    United States
    Thank you... I knew there had to be an easier solution then what i was doing.
     
    KunoichiZ likes this.
  5. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    hello. I've tried to update luma I downloaded the .cia file and put it on the cia folder but it still shoots the -660561860 error code
     
  6. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    14
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 23, 2012
    United States
    Octo Canyon
    Luma is not a .cia...
     
  7. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    then what did I download?
     

    Attached Files:

  8. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    that is not luma, that is an application to keep luma up to date, (unsure if that's the correct source, can't remember)

    edit the latest release of luma can be found here

    https://github.com/AuroraWright/Luma3DS/releases

    (its 9.0 not the joyconhax one that was a April fools version)
     
    Last edited by ninjistix, Jun 8, 2018
  9. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    the IDK what to do nor what caused the error. good evening

    — Posts automatically merged - Please don't double post! —

    also I already have the 9.0 version.
     
  10. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    sorry i misunderstood the issue, the cia you downloaded can be installed via fbi, but its not really needed atm since your luma version is upto date.
     
  11. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    so.... why the error?
     
  12. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    where are you getting the error when trying to install the lumaupdater.cia? and how are you installing it with fbi? or some other app?
     
  13. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    when opening Luma
     
  14. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    delete it from settings, download it again from the source, and install it again through fbi
     
  15. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    where do I drop this? (I paid for the homebrew so IDK)
     

    Attached Files:

  16. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    what your showing me is the luma bootfirm nothing related to this updater. that needs boot.firm needs to go on the root of your sd card, this cia is to update that boot firm in the even that anything new comes out
     
  17. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    I don't undrestand. I install the cia I dropped on /cia. and then drop the Bootfirm on /root
     
  18. ninjistix

    ninjistix GBAtemp Regular

    Member
    3
    Aug 8, 2016
    United States
    first off all you said you purchased your homebrew? you need to figure out if your on A9HL or BS9, the current version of luma doesn't work with A9HL you need to update to bs9 for institutions see (if you are on A9HL then you need to get the boot.firm for any luma 7.x)

    https://3ds.hacks.guide/a9lh-to-b9s
     
    Last edited by ninjistix, Jun 8, 2018
  19. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
     
  20. Dargentum

    Dargentum Member

    Newcomer
    1
    Jun 8, 2018
    Chile
    I think it works now. I guess
     

    Attached Files:

Loading...