RB2 drums and guitar wont sync!!

Discussion in 'Wii - Console and Game Discussions' started by profitone, Sep 30, 2009.

Sep 30, 2009
  1. profitone

    Newcomer profitone Newbie

    Sep 13, 2009
    United States
    I just got a new in sealed box RB2 band kit for my modded wii (got RB2 from ebay)-- I dont have a physical disc but i have RB2+ GH2 on my backup harddrive-- (so i have no way to test if it works with an actual cd)
    Ive tried for hours to get the drums and or guitar to sync wirelessly and they just wont go---- I even called RB and they couldnt help me and couldnt do any RMA due to me purchasing from ebay--
    I doubt the instrument or USB dongles are defective because what are the odds of getting 2 defective components in one new kit--

    Is there a known fix or workaround for this issue? Im pretty sure this is a mod/backup issue based on the above factors---

    Im on CIOS rev 14, IOS249 -using usbloadergx or neogamma- Im not having any issues with the wii locking up-- just sync issues -- its the harmonix fender and the RB2 drums- tried replacing batteries, inserting usb directly into wii, inserting into usb hub, hitting sync buttons a zillion times-- all i get is solid lights on both the usb sender and the instrument but no light signalling that the device is actually connected to #1-#4 slots--neither device will work independently or together-

    Thanks for any help!
  2. Nedfu

    Newcomer Nedfu Newbie

    Aug 29, 2009
    United States
    You need to use the Rock Band USB instrument loader. I had the same problem (everyone does) with the drums never showing as player 2. RB uses 222/223 rather than 249, which causes the no sync issue.
  3. Sick Wario

    Member Sick Wario Club Nintendo

    Jul 24, 2006
    NNID: godrugal
    United Arab Emirates
    before you start installing more IOSs etc just load RB2 normally, get the the main menu and the drums are NOT synced.
    now reset the wii and as soon as it starts loading turn on the RB2 drums.

    im using neogamma but i had the same problem. just try loading the game once, then hit reset and try the drums again
  4. ryanvs

    Newcomer ryanvs Member

    Oct 9, 2009
    United States
    ^^ that's what we do on my friend's wii who has the same problem

Share This Page