R4i SDHC Help!

Discussion in 'R4 DS' started by tiduscrying, Jun 15, 2012.

Jun 15, 2012

R4i SDHC Help! by tiduscrying at 4:35 AM (3,785 Views / 0 Likes) 24 replies

  1. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Olright. So, I have a R4i SDHC for my DSi (It is a white card marked "Dual Core". Has a red PCB and runs the wood interface). The DSi's firmware is only at 1.4.3. Yesterday, I was trying to put a loader type thing so I could play Shin Megami Tensei: Strange Journey. The loader dual booted the official R4 YSMENU. But when I ran the dual booting program, the screen went blank and froze. Then I restarted the DSi and tried to boot back up my R4. Instead of booting back into wood, it gave me the DSi error message. I have since formatted the card with Windows and the SD formatting program. I have also reloaded my flash carts firmware four or five times. Even when I take out the micro sd card, the DSi still displays the same message. What does this mean? Does anyone have any thoughts or suggestions? This has happened to me once before, but I cannot remember what I did to the cart to make it work again. Perhaps to make sure it isn't the cart itself, should I put the cart into a standard DS Lite? This is the cards website. I have crawled it for any answers, but am still at a loss. Any help is greatly appreciated.
     


  2. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    So.... I take it no one has any ideas? Anyone...? Feelin' pretty alone here, guys. :cry:
     
  3. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    We tend to ditch clones and get carts with proper support so we don't need to dual-boot or fiddle with firmwares. :P

    Anyways it sounds like it's dead but you said this happened before, it might be a contact issue either between the cart and the DSi, or the microsd and the cart.
     
  4. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Okay, so I used a friend's DS Lite and taa-daa, the blasted card works. But only on my friends DS. I just don't get it... I have have updated kernels, formatted the SD, made sure to NOT upgrade my DSi. Urg. I guess I might just have to go for broke and get a used DS lite or a proper R4 instead. Thanks for the help anyway.
     
  5. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Why not get a new flash cart with DSi support that's updated?

    http://gbatemp.net/t290097-which-flash-cart-should-i-get

    All the carts with DSi support have updates for the latest DSi and 3DS firmwares.
     
  6. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Your card was never updated for v1.4.3 firmware. I bet your card doesn't say "new" on the sticker, does it?
     
  7. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Is it still considered bricked even though it works perfectly fine on a DS Lite?
     
  8. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Alright, alright. I am sick and tired of seeing my DSi on a shelf not being used. I had so many great games on that R4. I am totally interested on how to unbrick it with another card. A friend of mine owns a Acekard 2i and a DS lite (he is the only other guy I know who owns another flash cart). Just a refresher, I own a R4i SDHC and a DSi. Please let me know how I can unbrick the card (I am a cheapskate, I'd really rather not buy another card).
     
  9. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Your card was never updated for v1.4.3 firmware. I bet your card doesn't say "new" on the sticker, does it? Also, Google "TK Saturn Paper Trick," and use the method of putting a piece of paper/electrical tape behind the contacts, inside of the flashcard's case.
     
  10. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Contact issue, eh? Alright. I'll check it out now.
     
  11. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Test a retail game and see if it runs before you try TK Saturn's Paper Trick, and report the results.
     
  12. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    I just tried a normal DS game in the DSi. Boots fine and everything. No problems whatsoever. I am currently reading the tutorial on the TK Paper Trick.
     
  13. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    OK, your card was never updated for v1.4.3 firmware.
     
  14. tiduscrying
    OP

    Member tiduscrying that butt...

    Joined:
    Jun 12, 2012
    Messages:
    372
    Country:
    United States
    Negatory. I tried two different methods, but I feel like the card is different in its manufacturing style. The way the card was made, it has a little bar beneath the PCB meaning I cannot insert something behind it.
    [​IMG]
    Please excuse the image quality.
    [​IMG]
    The game shows up on the DSi's menu...​
    [​IMG]
    But then doesn't do jack...​
     
  15. Aeter

    Member Aeter A walking contradiction

    Joined:
    Apr 1, 2009
    Messages:
    935
    Location:
    The lands of nether
    Country:
    Netherlands
    You don't have a contact issue, if the card is recognized by your DSi.
    It's either a kernel problem or a firmware problem.
    Since the card works on a DSL it's definately a firmware problem.
    Download the latest update for your card here.
    Unpack it and put the .nds file in the root of your µSD card.
    Now run the card in the DSL and run the .nds file.
    If the update went successful, then the card should work on your DSi.
     
  16. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    benhofb I noticed you said you are running the "Wood" kernel., but your card is all white and is made by the r4isdhc.com team, get your correct kernel HERE, and more importantly, get the firmware update for your card (I can't directly link you to it because you haven't said if your card says "new" on the sticker, or not) and put it on the root of your micro sd card and run that file using your friends DS Lite. Voila, your problem should be solved.

    Your first post mentioned nothing about a firmware update to your DSi but after reading all your posts I'm 90% sure your DSi was upgraded in between the problem you stated and you writing a post for help on this forum OR you haven't checked your system settings properly to check your DSi firmware version in a while. Online help depends on correct information.
     
  17. Aeter

    Member Aeter A walking contradiction

    Joined:
    Apr 1, 2009
    Messages:
    935
    Location:
    The lands of nether
    Country:
    Netherlands
    I didn't miss anything.
    He said he updated his kernels, not his firmware/bootloader.
    No where do I see see any sign of him actually trying to update his firmware/bootloader and all signs points towards a firmware/bootloader problem.
     
  18. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Re-read my last post and you'll see I removed my statement. Honestly, I think it's "user error," and he needs to go over very preliminary tasks, before he makes any more posts in this topic. #1 would be for him to do a firmware update. #2 using the correct kernel.
     
  19. Aeter

    Member Aeter A walking contradiction

    Joined:
    Apr 1, 2009
    Messages:
    935
    Location:
    The lands of nether
    Country:
    Netherlands
    Exactly, he should run his native kernel and try to execute a bootloader update.
    You did link to the wrong kernel though, he mentioned his card is a "Dual Core".
    The latest Dual Core kernel is this one: http://down4.nds9.cn/r4isdhc-white/r4isdhc-whiteEnglish1.50.rar
     
  20. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    I know I'm very tired right now, but did he ever say he is using the r4isdhc.com Dual Core "new" card? There are two versions you know?
     

Share This Page