R4i freezing mid game

Discussion in 'R4 DS' started by Czosnek, May 2, 2013.

  1. Czosnek
    OP

    Czosnek Newbie

    Newcomer
    3
    0
    May 2, 2013
    Poland
    Hi guys
    So here is my problem. I've found my old DSI 2 weeks ago and decided I might as well play smth on it, but it keeps freezing mid game (pretty much any game i try), music is still playing, but the console is frozen, even when i close it, it doesn't go to sleep mode, just keeps playing music. Sometimes I can play like an hour, sometimes it freezes after 5 min.
    I've got R4i ultra (yeah, I know it's shit), It's 100% not sd card problem, because I've tried like 3 cards with same results. Tried official kernel, akaio and Ysmenu all the same. Tried paper tricks, pulling out a DS battery for some time, cleaning slot-1 with some compressed air and still same results.
    Basically I know something is probably broken, but the question is - Is this only my r4 broken or something in my console. Maybe someone knows? I will appreciate some help

    PS: Of course when I last played it like 1-2 years ago everything was working fine.
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
  3. aalokishere

    aalokishere GBAtemp Regular

    Member
    160
    28
    Jun 19, 2012
    Nepal
    Does it happen it other cartidges or with the R4i only? If it happens with others then maybe your DSi is at fault, if not the R4i is broken.
    Also does this happen with all ROMs or just the same one. It might also be a problem with the ROM.
     
  4. Czosnek
    OP

    Czosnek Newbie

    Newcomer
    3
    0
    May 2, 2013
    Poland
    Nope, It doesn't freeze when I shake it.
    Tried this paper trick, didn't fix the issue.

    Dunno, atm I got access only to this cartridge, so I can't tell.

    To all ROMs and this happens to the exact same ROMs I've played 1-2 years ago without problem.
     
  5. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Got another MicroSD to test?
     
  6. Czosnek
    OP

    Czosnek Newbie

    Newcomer
    3
    0
    May 2, 2013
    Poland
    I've tested at least 3 sd cards already with same results
     
  7. Trevor Belmont

    Trevor Belmont GBAtemp Regular

    Member
    136
    46
    Mar 30, 2013
    United States
    timbuk2, kamtucky
    It's probably a problem with the motherboard.
    I customize and repair DSi's and have personally run into this problem.
    It may need to either be cleaned internally, or there may have been some liquid damage somehow.
    Also check and make sure the battery is nice and clean.
    I've seen a couple with battery leakage that started like that after long storage with no use.

    On a side note, it's a good idea to remove the battery from a handheld (if possible) if you don't plan on using them for extended amounts of time, as sometimes, this can cause battery leak/corrosion, particularly if the unit(s) are NOT to be kept in a climate controlled area (i.e. air conditioned).