[QUESTION] Best working GBA emulator?

Discussion in '3DS - Homebrew Development and Emulators' started by merle alvers, Nov 1, 2015.

  1. merle alvers
    OP

    merle alvers Member

    Newcomer
    10
    0
    Oct 27, 2015
    United States
    Hi, I've been trying to find a working GBA emulator, good enough to run Pokemon, the one in retroarch isnt good, so I was wondering if anyone knows a working one at least for pokemon?
     
  2. Adeka

    Adeka Beta Tester

    Member
    4,146
    1,287
    Mar 19, 2013
    United States
    The one built into the 3ds plays them all perfectly. You need a 9.2 or below 3ds though.
     
  3. merle alvers
    OP

    merle alvers Member

    Newcomer
    10
    0
    Oct 27, 2015
    United States
    Forgot to mention, I'm on an O3DS with 10.1
     
  4. fiese_nase

    fiese_nase Advanced Member

    Newcomer
    93
    39
    Oct 21, 2015
    Gambia, The
  5. ninjanick999

    ninjanick999 Advanced Member

    Newcomer
    96
    51
    Dec 13, 2014
    United States
    Try the retroarch nightlys:
    http://buildbot.libretro.com/nightly/nintendo/3ds/

    Download the newest one in your preferred format (cia, 3ds, 3dsx)
    There are two gba emulators: gpsp and mgba.
    Your millage vary depending on what format you use and if you have a new 3ds or not. Most games are full speed on a New 3DS, Old 3DS is a bit slower.
    Retroarch for 3DS is fairly new so I suspect that performance will be better in the future.
     
    Hoppy likes this.
  6. MsMidnight

    MsMidnight part time fe modder

    Member
    1,753
    1,308
    Oct 12, 2015
    kys
    mGBA is still quite slow though
     
  7. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    1) AGB_FIRM (o3DS or n3DS on 9.2 or below)
    2) gpSP (only fast on o3DS on 9.2 or below, n3DS is fast on any firmware)
    3) mGBA (only decent on n3DS)
    4) CitrAGB (blows on anything above 9.2)
    5) 3DSGBA (just blows)

    There really is no good GBA solution for o3DS users above 9.2. Your only options are to wait and pray or buy an n3DS or buy a 9.2 or below o3DS. :)
     
    Last edited by GBAFail, Nov 1, 2015
  8. raystriker

    raystriker Alpha PC Builder

    Member
    1,271
    422
    Dec 28, 2011
    India
    Bloomington
    Big time Newbie question.
    Emunand 9.2/below or Sysnand 9.2 and below (and any emunand)?