question about otp.bin

Discussion in '3DS - Flashcards & Custom Firmwares' started by Joey23475, Jan 15, 2017.

  1. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    i recently installed A9LH on my N3DS and everything is working fine. i made a backup of my otp.bin to my laptop so i deleted the one located on my 3DS. long sotry short, my laptop became unusable until today when i had to delete all my data on it to reinstall the operating system.. so is there any way i could obtian the OTP.bin? i don't mind downgrading back to 2.1.0 and trying to run the A9LH installer to see if it will hopefully give me the OTP.bin again. but if there is a faster and more convenient way of doing it i would appreciate it if someone let me know
     
  2. rlvbrussel

    rlvbrussel Member

    Newcomer
    39
    5
    Nov 21, 2014
    Netherlands
    Nop... only if you downgrade.
     
  3. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    sweet, so i can still run the safea9lhinstaller even if a9lh already installed? as long as i am able to get that file again i dont mind going through the trouble of downgrading again
     
    rlvbrussel likes this.
  4. ShikaSan

    ShikaSan Advanced Member

    Newcomer
    57
    8
    Jun 30, 2016
    Somewhere
    I think you will still need to downgrade, and follow the guide on 3ds.guide again to obtain a back-up of your otp.bin, as it is unique to each and every 3DS.
     
  5. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    downgrading is not a issue. but im assuming that the otp.bin file is generated when running the safea9lhinstaller through the website so running it while already having a9lh will not interfere with the process, right?
     
  6. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,921
    1,211
    Aug 20, 2013
    straya m8
    The OTP.bin is like 256 bytes.... Why didn't you upload it to cloud storage?
     
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    11,914
    6,407
    Nov 23, 2014
    Australia
    Canberra, Australia
    You do not need otp.bin, so don't worry about it. Just keep your NAND backups safe. There was one idiot once that insisted on trying to brick his console to reobtain it, it was quite hilarious with everyone trying to talk him out of it, but he couldn't be dissuaded! I won't name him, he probably wants to forget about it (hopefully now he understands it was a stupid idea).
    Anyway long story short, don't be like that guy.
     
    HyperT likes this.
  8. rlvbrussel

    rlvbrussel Member

    Newcomer
    39
    5
    Nov 21, 2014
    Netherlands
    Is you can run a9lh and you have backup nand then you can restore.
    But if you get bricked hard you need aan hardmod with otp.bin and nand.bin. so it is better to downgrade and get the otp.bin.

    I have done it just follow the guide.
     
  9. Quantumcat

    Quantumcat Dead and alive

    Member
    11,914
    6,407
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can't run Luma on 2.1 on N3DS. Only way is to uninstall a9lh and downgrade to 2.1 again (basically doing the a9lh installation over again).

    — Posts automatically merged - Please don't double post! —

    You do not need otp.bin to recover a brick, only either a NAND backup or the 9.2 CTR transfer files if you lose your backup.
     
  10. rlvbrussel

    rlvbrussel Member

    Newcomer
    39
    5
    Nov 21, 2014
    Netherlands
    ?
     
    LiamTehChikorita likes this.
  11. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    so its not important? why does the tutorial warn us to keep a backup?

    and on the other message posted after it, how would one go about uninstalling a9lh from the device? i cant find a tutorial on the site that tells you how to install it
     
  12. Quantumcat

    Quantumcat Dead and alive

    Member
    11,914
    6,407
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can use your otp.bin to install a9lh on 9.2 (that's what you had to do in the first implementation of a9lh - downgrade to 2.1 to get otp.bin, compile your own arm9loaderhax.3dsx then update again and install using your 3dsx). I don't think it's super useful now though. Possibly it might be in the future (maybe with the bootrom dumps we will be able to sign NAND backups for other consoles?) but not super useful right now.

    You can use SafeArm9Installer to uninstall a9lh. You won't find a tutorial because it's not something anyone would want to do.
     
    Joey23475 likes this.
  13. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    can SafeArm9Installer run on the latest firmware? getting a black screen when launching it from homebrew
     
  14. Quantumcat

    Quantumcat Dead and alive

    Member
    11,914
    6,407
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can't run arm9 homebrew over 9.2 (without fasthax etc). Run it as a Luma payload, like all other arm9 homebrew (Decrypt9, Hourglass9, GodMode9 etc).

    Edit: the Updating A9LH page of the guide might help you. Follow the steps except choose to uninstall not update.
     
    Last edited by Quantumcat, Jan 15, 2017
  15. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    when choosing to uninstall i get "error: a FIRM equal or newer than 11.0 has been detected"
    so im guessing i have to downgrade to uninstall it?
     
  16. rlvbrussel

    rlvbrussel Member

    Newcomer
    39
    5
    Nov 21, 2014
    Netherlands
    yes..
     
  17. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    The only use for the otp.bin is to reinstall a9lh. If you get your system restored by Ninty for example - ypu can load up Sa9lhinstaller and install without downgrading.

    So besides that, don't recall any other use
     
    Quantumcat likes this.
  18. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    but it does not seem that A9LH can be reinstalled on the latest update, or am i wrong?

    i was able to successfully restore to official firmware (without A9LH), downgrade to 2.1.0 and re-install A9LH along with receiving my otp.bin that i previously lost
     
    Last edited by Joey23475, Jan 15, 2017
  19. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    fasthax=>safehax=>a9lh installer --should work fine for reinstall--

    For a9lh update you boot a9lh installer via holding a button for the payload
     
  20. Joey23475
    OP

    Joey23475 Member

    Newcomer
    48
    9
    Jan 9, 2017
    United States
    ah, then i guess you just cant uninstall it. i was given a error that i was above the supported version to uninstall, did not test installing it though. thank you for the info.