(Q): Update N3DSXL (CFW Luma) to 11.8 and Luigi's Mansion ?

Discussion in '3DS - Flashcards & Custom Firmwares' started by 2DSGamerdude, Oct 9, 2018.

  1. 2DSGamerdude
    OP

    2DSGamerdude GBAtemp Fan

    Member
    3
    Apr 6, 2015
    Greece
    Gamecube Land
    hi all,
    um I have some questions related to the upcoming Luigi's Mansion 1 (October 19), and the 11.8 update.

    1) should I update my N3DSXL (11.7 CFW luma) -> 11.8,
    since bootstrap & safeBS9 files are not recently updated, and only god mode and luma 9.1,
    I just need to only do the luma and god mode 9 steps in the update BS9 page?
    and update CTRNAND Luma3DS also?

    updating-b9s

    2) what FW is required to play the new Luigi's mansion 1?
    if it is not 11.8, then I don't need to update,
    warioware gold's fw was 11.6, so I was able to run that fine with 11.7.

    thanx
     
  2. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    6
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Yep that's it
     
    TurdPooCharger likes this.
  3. TurdPooCharger

    TurdPooCharger Meh

    Member
    8
    Jan 1, 2018
    United States
    1. Should I update my N3DSXL (11.7 CFW luma) -> 11.8.
    Yes, update your 3DS firmware to Sys 11.8.0-41E. There's no reason to stay on an older version firmware. As it doesn't provide any benefits and just locks you out from online play.

    If you're using EmuNAND or Emu, consider switching over to SysNAND. Look in the NANDManager gm9 script found in GodMode9 v1.7.1 in transferring Emu → Sys, or dumping the NAND. Just make sure you update all of your CFW first before updating the 3DS firmware.


    2. I just need to only do the luma and god mode 9 steps in the update BS9 page? And update CTRNAND Luma3DS also?

    If you're not sure what boot9strap version you have, there's a gm9 script you can use to check for this found here.

    If you ever you need to use the 3DS without an SD card, your CTRNAND should also be updated.

    Latest typical custom firmware setup should consist of Luma3DS v9.1, boot9strap v1.3, and GodMode9 v1.7.1 on both your SD card and CTRNAND.

    3. What FW is required to play the new Luigi's mansion 1?

    No one knows at this moment. The game doesn't come out until Oct 12, 2018.

    Edit - Damn, ninja'd by @zacchi4k :ninja:
     
    c4p0, 2DSGamerdude and zacchi4k like this.
  4. 2DSGamerdude
    OP

    2DSGamerdude GBAtemp Fan

    Member
    3
    Apr 6, 2015
    Greece
    Gamecube Land
    hay TurdPooCharger,
    um thanx for that bs9 ver.script, I'll use that to check my bs9 ver.
    I think it is at v1.3 (latest),
    s
    but since I have bs9 v1.3 on my system already, I just follow sections:

    Section III - Update Luma3DS
    Section IV - Configuring Luma3DS
    Section VI - CTRNAND Luma3DS

    only?

    backing up my system and SD before all this ofc (before updating to 11.8)

    I'll need to just update luma 3ds to 9.1 and godmode9 to v1.71,

     
    Last edited by 2DSGamerdude, Oct 10, 2018
  5. TurdPooCharger

    TurdPooCharger Meh

    Member
    8
    Jan 1, 2018
    United States
    That is correct. If you would like compiled guide that combines all of them:
     
    2DSGamerdude likes this.
  6. 2DSGamerdude
    OP

    2DSGamerdude GBAtemp Fan

    Member
    3
    Apr 6, 2015
    Greece
    Gamecube Land

    hay, TurdPooCharger
    thanx so much for your easy update guide!
    I did everything in it and now my N3dsxl is on luma 9.1 with sys 11.8 and everything is working great like before 11.8!
    your guide helped me with updating and fixed any issues I had :)

    this guide is a good tut for future FW and luma/BS9 dates!

    for q's 3) that I had asked a while back, since the game is out ATM (in the US mainly),
    since im on latest FW > 11.8, Luigi's Mansion 1 should work fine?
    it's FW ver required doesn't matter since it might be 11.6 or 11.7? or .8 even?

    also, to run the game, I found that you need to use Luma locale switcher (0.04?)
    since my luma is 9.1? I should use the 0.04 ver?
    um does this locale app only make changes to LM or other games?
     
    TurdPooCharger likes this.
  7. AmandaRose

    AmandaRose The Fallen Angel

    Member
    12
    Aug 19, 2015
    United Kingdom
    Glasgow
    Luma locale switcher only makes changes to the games you select for it to change
     
    2DSGamerdude and TurdPooCharger like this.
  8. 2DSGamerdude
    OP

    2DSGamerdude GBAtemp Fan

    Member
    3
    Apr 6, 2015
    Greece
    Gamecube Land
    sweet! thanx for the info! AmandaRose :)
    also using the ver 0.04 (stable) of Locale will work fine using im using luma 9.1?
     
  9. TurdPooCharger

    TurdPooCharger Meh

    Member
    8
    Jan 1, 2018
    United States
    @2DSGamerdude, I haven't played Luigi Mansion, but I read that the newest Luma Locale Switcher doesn't work playing this specific game out of region.

    This info was found from that iso site:

    There was more posts about it from that thread.
     
  10. AmandaRose

    AmandaRose The Fallen Angel

    Member
    12
    Aug 19, 2015
    United Kingdom
    Glasgow
    Thats strange I have the latest version of luma locale switcher and luigi mansion usa works perfectly on my euro orig 3ds once I had run luma switcher.
     
    Last edited by AmandaRose, Oct 16, 2018
    2DSGamerdude and TurdPooCharger like this.
  11. TurdPooCharger

    TurdPooCharger Meh

    Member
    8
    Jan 1, 2018
    United States
    Most likely explanation is that they're using an older version Luma3DS with the latest Locale Luma Switcher. I can't check for this as my n3DSXL is USA and don't feel like grabbing a EUR n3DS CTRTransfer to test for it.

    I believe you @AmandaRose that the newest switcher does work but as general advice, "your gaming mileage may vary." ¯\_(ツ)_/¯
     
    AmandaRose likes this.
  12. AmandaRose

    AmandaRose The Fallen Angel

    Member
    12
    Aug 19, 2015
    United Kingdom
    Glasgow
    Nah it's the latest luma so no idea why working for me but not for others. Sucks to be them lol well at least until the euro version is available.
     
    2DSGamerdude likes this.
  13. 2DSGamerdude
    OP

    2DSGamerdude GBAtemp Fan

    Member
    3
    Apr 6, 2015
    Greece
    Gamecube Land
    np, guys thanx for the help! just as @AmandaRose said,
    I had the same settings as her (new 3dsxl EU system luma 9.1, fw 11.8)
    so, if it worked for @AmandaRose, then it'll probably work for me aswell!

    using that trick with luma locale to get the us version to work,
    the EU ver of LM tho, will probably work fine without any extra tricks?
    (Edit: the EU copy works fine with no issues or extra stuff like the US :) )

    I got the us version to work just fine Pics for proof of concept:
    LM US working with Locale

    also do we know what FW the LM requires in order to work?
    not like it's needed as 11.8 will work fine, just out of curiosity.
     
    Last edited by 2DSGamerdude, Oct 19, 2018
Loading...