Purchasing Acekard 2i question

Discussion in 'NDS - Flashcarts and Accessories' started by coronajtv, Sep 23, 2010.

Sep 23, 2010
  1. coronajtv
    OP

    Newcomer coronajtv Newbie

    Joined:
    Sep 23, 2010
    Messages:
    5
    Country:
    United States
    Hello. I am new to this site.

    So I just bought a DSi XL with 1.4.1u installed and I was looking to buying an Acekard 2i from ShopTemp. I looked around in the forums and saw that if you select the 'Premium Flashing Service' the seller will flash/update the card for you. I would do it myself but I have no DS or DS Lite

    Since the latest firmware that Nintendo released was 1.4.2, do I have to update my Dsi XL to 1.4.2? or do I just leave it at its current firmware(1.4.1u)?

    Do I have to email the seller that I am on that specific firmware? if so what is their email address?

    Any info would be great.

    Thanks for reading.
     
  2. DigitalDeviant

    Member DigitalDeviant GBAtemp Addict

    Joined:
    Feb 14, 2010
    Messages:
    2,002
    Location:
    Solar Federation
    Country:
    United States
    never update if you wish to use flashcards.
     
  3. jbruckus

    Newcomer jbruckus Newbie

    Joined:
    Aug 6, 2009
    Messages:
    7
    Location:
    Adirondacks
    Country:
    United States
    www.acekard.com , the official site, will release new firmware. When nintendo does a firmware upgrade, do not upgrade, Unless you've already upgraded your acekard firmware that was designed for that specific nintendo update.

    I think the latest firmware from ak2i is the 1.4.1 , so I'd leave it at that. Check their site for latest updates to the card, but never upgrade thru nintendo without updating the flash card first.
     
  4. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    Latest DSi system menu is 1.4.1 for all regions except China (that is where the 1.4.2C is...but it does the same thing as 1.4.1 for the regions). Just flash for 1.4.1 and you are good to go...I'm not sure if shoptemp flashes with the 1.4 fix or the 1.4.1 fix, but it isn't too hard flashing it yourself as long as you have access to a DSi with anything below 1.4 or a DSL/DS Phat.
     
  5. coronajtv
    OP

    Newcomer coronajtv Newbie

    Joined:
    Sep 23, 2010
    Messages:
    5
    Country:
    United States
    hmmm ok. I think i will wait a little longer to buy one. Thanks for the info
     
  6. coronajtv
    OP

    Newcomer coronajtv Newbie

    Joined:
    Sep 23, 2010
    Messages:
    5
    Country:
    United States
    Sorry for the double post
     
  7. sstomouth

    Banned sstomouth Banned

    Joined:
    Sep 4, 2010
    Messages:
    83
    Country:
    United States
    hi jurassicplayer what do you mean by this. How do you flash a ndsi by using a ds phat/lite i have a phat that is below 1.4 but my dsi is currently 1.4.1 and i get an error has occurred press and hold the power button etc... to be able to do the method you where thinking off do i need a specific flash card or anyone will do?

    and could you send me a link to this tut?

    That would be GREAT!
     
  8. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
  9. Aijelsop

    Newcomer Aijelsop Question Asker

    Joined:
    Sep 11, 2010
    Messages:
    1,000
    Country:
    United States
    You should buy your Acekard from LeetMod. They have very cheap prices.

    I ordered my EZ Flash 3 in 1 and got in in two days. Free shipping. Works perfectly. [​IMG]

    Also, yeah, don't ever update your DS.
     

Share This Page