PSX Games.

Discussion in 'PSP - Hacking & Homebrew' started by Cloak519, Feb 21, 2011.

Feb 21, 2011

PSX Games. by Cloak519 at 11:45 AM (629 Views / 0 Likes) 4 replies

  1. Cloak519
    OP

    Member Cloak519 GBAtemp Advanced Fan

    Joined:
    Oct 7, 2010
    Messages:
    566
    Country:
    I'm a little confused about PSX game compatibility on 6.X firmwares...
    I've just bought myself a PSP 3000 running OFW 6.20 which I think renders it semi-hackable - a bonus I hadn't expected.
    I read on the FAQ that 6.X firmwares can't yet run PSX games, but then on another, non-stickied FAQ that they can.
    Is this true or not? And if so, what are the limitations? Can 6.X firmwares only run PSN PSX games?
    If it isn't possible, is it ever likely to happen given that the release of the NGP is just around the corner?
    Thanks in advance haha.
     
  2. Jamstruth

    Member Jamstruth Secondary Feline Anthropomorph

    Joined:
    Apr 23, 2009
    Messages:
    3,456
    Location:
    North East Scotland
    Country:
    United Kingdom
    Here's how it works at the moment.
    Got a PSX game you legally bought from PSN? You can play that on ANY firmware.
    Got a PSX game you downloaded from somewhere other then PSN BUT is a dump of the PSN version? You can play that on 6.35 Pro-A4
    Got a PSX game you made yourself from a PSX ISO and using PSX2PSP? You can't play that on any 6.xx CFW
     
  3. Cloak519
    OP

    Member Cloak519 GBAtemp Advanced Fan

    Joined:
    Oct 7, 2010
    Messages:
    566
    Country:
    Ah, I understand. Thanks for the information!
    Quick edit: To anyone that may be reading this post, can any emulators run on 6.X? GBA, N64, whatever?
     
  4. Jolan

    Member Jolan Unlimited Bear Works

    Joined:
    Mar 20, 2010
    Messages:
    1,384
    Location:
    Netherlands, currently
    Country:
    Bulgaria
    Yes, they work on 6.35 Pro-A4.
     
  5. Cloak519
    OP

    Member Cloak519 GBAtemp Advanced Fan

    Joined:
    Oct 7, 2010
    Messages:
    566
    Country:
    Thanks =) After putting in some of my own research instead of being a lazy git I think I'll wait around for 6.20 TN-D. It looks good.
     

Share This Page