Psp 2000 not turning on.

Discussion in 'PSP - Console, Accessories and Hardware' started by andy26129, Apr 23, 2012.

  1. andy26129
    OP

    andy26129 GBAtemp Fan

    Member
    376
    53
    Sep 23, 2011
    United States
    My Psp stopped turning on after I opened it and try to fix the analog problem. I have done it before with a same kind of Psp, but for some reason it just wont turn on for this one. Can someone help me.Thanks and.. yes the psp charges but thats about it.

    Any tips..ect

    Please..snip
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,113
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    http://gbatemp.net/topic/305895-psp-2000-disassembly-guide/

    Do it again and make sure everything's reconnected this time.
     
  3. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,036
    7,349
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    Same happened with me with my PSP1000. Just screw carefully the screws on the back, but not too tightly, otherwise it won't turn on. The screws responsible of this are the ones on the back of the analog, mainly.
     
  4. andy26129
    OP

    andy26129 GBAtemp Fan

    Member
    376
    53
    Sep 23, 2011
    United States
    I just finished disasembling it and putting it on together...but still wont turn on...it just charges with the orange led beaping
     
  5. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,036
    7,349
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    Again, check out the screws and don't screw them too tightly.
     
  6. andy26129
    OP

    andy26129 GBAtemp Fan

    Member
    376
    53
    Sep 23, 2011
    United States
    This time I did not screw them tightly, so what now.
     
  7. raulpica

    raulpica With your drill, thrust to the sky!

    Supervisor
    11,036
    7,349
    Oct 23, 2007
    Italy
    PowerLevel: 9001
    You probably killed something while opening it, sorry.

    Have you double-checked the ribbon connectors?
     
  8. Coto

    Coto GBAtemp Addict

    Member
    2,370
    417
    Jun 4, 2010
    Chile
    there are 2 connectors which are for motherboard & power switch behind the battery compartment (motherboard sided). One being a ribbon cable (this one is in fact the one doing soft-powerup) and the other just sends the energy fed from the AC input. check connections over there, clean the ribbon cable, and look for blown fuses:

    http://www.llamma.com/PSP/repair/PSP_fuse_repair.htm

    Good luck