Problems with M3DSReal/DSLibris combination?

Discussion in 'NDS - Emulation and Homebrew' started by hillybangcock, Apr 8, 2010.

  1. hillybangcock
    OP

    Newcomer hillybangcock Newbie

    Joined:
    Apr 8, 2010
    Messages:
    2
    Country:
    Australia
    Hi guys, Newby here, I've tried looking up FAQ's but the link no longer seems to work.
    My problem is that I seem to have some issues trying to get DSLibris to work on my M3DSReal card.
    For several years now I've used the M3/DSLite as a palm reader. A friend has used both "M3system" & DSLibris on theirs & I fancied the better formatting DSLibris offered when compared to .txt files.
    When I install DSLibris I continually get a "fatal: font not found" message. As a reader of text files I am impressed by the M3, it still works as per, although, try as I might, I cannot get the two to co-exist. My friend's DSLite/M3DSReal combination, with both systems on it is working just fine. The only difference being his was loaded via an "Apple", mine on a PC with Windows 7 loaded. I've even un-installed all my .txt files & loaded only DSLibris stuff,with a few .epub books loaded, still the same result "font not found". As a last resort I loaded some "true type" fonts from my computer just in case the fonts on the libris were corrupt, still no joy!
    I realise this stuff is all to do with the DSLibris install/application, but as it is onto the M3DSReal card I was hoping some of your members may have encountered it before & can help me with a work-around.
    Thanks for reading, hope you can assist me, regards Bill
     
  2. picketf

    Newcomer picketf Member

    Joined:
    Nov 29, 2009
    Messages:
    30
    Country:
    Fiji
    Have you tried to DLDI patch the DSLibris file before moving it to M3Real ?
     
  3. thedicemaster

    Member thedicemaster GBAtemp Addict

    Joined:
    Apr 26, 2008
    Messages:
    2,412
    Country:
    Netherlands
    are the font files in the right folder? (fat:\font\)
    and does the content of fat:\dslibris.xml correspond with the location and name of one of the font files?(open the xml with wordpad)
     
  4. hillybangcock
    OP

    Newcomer hillybangcock Newbie

    Joined:
    Apr 8, 2010
    Messages:
    2
    Country:
    Australia
    Many thanks Picketf & The Dicemaster, I've just un-installed everything, re-formatted the Micro SDcard to FAT file system, loaded GBAlpha system file then loaded my .txt files onto the system. Then loaded DSLibris. FAT:\M3DSReal, opened the file & deleted the .txt & .XML files, checked the font folder, there are the 5 fonts listed there. Then I loaded 6 EPUB format ebooks into the book folder (these ebooks were converted from MOBI format to EPUB via Calibre, the tree now reads FAT:\M3DSReal\DSLibris\book\ then the 6 titles (.epub). The tree for the fonts reads FAT:\M3DSReal\ DSLibris\font\ that opens to the 5 .ttf fonts. Now when I boot the DSLite up, I initially get a screen asking for preferred language, click on english & the 5 boot option thumbnails appear (but the animation is very fast) A scroll across to "file" brings up a GMManager tab with a System & a DSLibris folder. The DSLibris folder opens to a (.), (..), DSLibris NDS, Book, & Font sub-folders. The NDS folder opens to a "Slot1" & "Slot 2" choice. The selection of slot 1 brings up a DLDI Compatible notification, followed by a screen with green script stating: $ dslibris, progr: file system mounted, warn: can't read prefs (255), info: writing new prefs. fatal: font not found (2). This is basically what has happened all along, I've tried downloading a new DSLibris app, un-installed & re-installed everything several times over all with the same result. If I allow the "System" to load to the 2nd selection screen then click on the "info" icon the Help & Support", scroll down to the up-date history I notice the latest update is Nov 2007, could this be the problem? Many thanks again guys, regards Bill
     
  5. dilsiam

    Newcomer dilsiam Newbie

    Joined:
    Jun 26, 2009
    Messages:
    6
    Country:
    Puerto Rico
    Hi Bill:

    You have to put the book folder, the font folder, the xml file in the root of the card. Let say your computer assigns to your card the letter F:\ then you will have F:\book, F:\font, F:\dslibris.xml, the nds file I put it on the games folder I have in my card which is a M3DS Real Sakura to have the application available in the menu. Also I recommend that you delete the application and its associated files from your card and installing cleanly again.Hope this helps
    dilsiam
     
  6. MartyPoppinsFeet

    Newcomer MartyPoppinsFeet Newbie

    Joined:
    Aug 28, 2011
    Messages:
    1
    Country:
    United States
    dilsiam got's the right solution

    ...and now,
    A Duel!!!
    [​IMG] [​IMG]
     

Share This Page