Problem with Castlevania Aria of Sorrow

Discussion in 'EZ-Flash' started by Searinox, Mar 2, 2008.

Mar 2, 2008
  1. Searinox

    Member Searinox Just a taste~ ;3

    Dec 16, 2007
    NastyBadPlace Pingas: Yes sir!
    AFAIK CAoS is a SRAM game. So I had it written directly onto the EZflash. It saves and keeps save only until poweroff however. Then the data is lost. I then patched it with the 3 in 1 tool. It lost some 1.6MB in size but this time it wouldn't save AT ALL. As in even start+select+a+b soft reset shows no savegames at the start. GBATA is of no help. It already says what I know -- save type = SRAM 256kB(64KB) and therefor refuses to patch its SRAM(grayed out button). I tried the european ROM. Same result. Yes I DID cleanup by deleting the GBA_SIGN files everytime I tried a new version of the ROM. What's more whenever I load GBA ExpLoader it's asking me if I want to set the EZflash to use with it, like it usually does when there isn't a savegame. And yes the SRAM indeed no longer carries the [romname].sav file, it's , so the save gets destroyed somehow I guess. Can anyone tell me what I'm doing wrong? Only other games I tried with the EZF are pokemon games, and they still save just fine.


    I have found the issue, and it seems to be a problem on Rudolph's side. Yes, the game WILL save when patched, however, the first save will be destroyed. CAoS seems to not like how save files are "organized" for the 3 in 1. When it makes its first save it will make the save unrecognizable to both Rudolph's tool and the game itself. Once it's purged this savefile it will save correctly the second time and from then on. However, the savefile will not be recognized by Rudolph's GBA ExpLoader anymore. It will ask wether to set the EZflash for ExpLoader like it always does when there isn't/it can't see a savegame. Ironically the solution is provided BY one of his own tools. The GBA backup tool can back up and restore the saves in native format. So in other words I'll just have to use the GBA backup tool whenever I'll be managing CAoS savefiles instead of ExpLoader's own save backup system.

    UPDATE #2:

    ExpLoader 0.4's full memory dump seems to preserve the savegame also. When restored it will work properly, however at no time is the save recognized by ExpLoader. The bottom line is that the save is there and it can be backed up and restored like any other save. But ExpLoader fails to recognize it's there, and Backup Tool doesn't work properly with dumping EZflash saves for games that were SRAM-patched.

Share This Page