Preloader v0.29 - JODI Patched

Discussion in 'Wii - Hacking' started by phpgeek, Oct 4, 2009.

Oct 4, 2009

Preloader v0.29 - JODI Patched by phpgeek at 4:02 PM (33,274 Views / 0 Likes) 120 replies

  1. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    This version of preloader IS IDENTICAL to v0.29. The only difference
    is that it has been patched to boot the new version of the HBC from
    the preloader menu. I.E. It will boot "JODI" instead of "HAXX".

    Download:

    Code:
    http://www.rapidshare.com/files/288594102/preloaderv0.29-jodi.rar
    or

    Code:
    http://www.mediafire.com/download.php?hitz3ou4gwn
    Thanks to techboy for the mediafire mirror.

    or

    Code:
    http://bhast2.extroverthost.com/Wii/preloaderv0.29-jodi.rar
    Thanks to bhast2 for the private ddl mirror.


    Important Note

    If you are going to be using this on 4.2E firmware then please DO NOT use the hacks.ini file included in the rar as the codes for 4.2E are an epic fail! I have just re-ported the hacks for 4.2E and they can be downloaded from the link below!

    4.2E Preloader Hacks

    Download: http://www.rapidshare.com/files/289930068/hacks.ini


    /phpgeek
     


  2. longtom1

    Member longtom1 Keep an eye on my posts cause I quick edit frequen

    Joined:
    Jan 12, 2009
    Messages:
    2,641
    Location:
    Honey Oils inc.
    Country:
    Antarctica
    great work much appreciated
     
  3. kLiNiKaL

    Member kLiNiKaL Dr. Greenthumb

    Joined:
    May 24, 2009
    Messages:
    581
    Location:
    Los Ganjales
    Country:
    Jamaica
    how was this achieved? was it a straight hex hack?
     
  4. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    Yep, it was a simple hex hack.

    Forgot to mention that it also works with the autoboot option if you have HBC selected.
     
  5. ecw

    Member ecw GBAtemp Regular

    Joined:
    Jan 7, 2009
    Messages:
    175
    Country:
    United States
    I am still on 4.1 but updated my BootMii AND HBC through the new Hackmii installer and can't auto boot to HBC. The same SD worked before I upgraded so the card is compatible. Is there something like this for my issue? BTW, Great work. [​IMG]
     
  6. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    Just reinstall your system menu and IOS60 (wads will be fine) and then install this patched version of preloader to fix your issue.
     
  7. dajavax

    Member dajavax GBAtemp Regular

    Joined:
    Oct 29, 2008
    Messages:
    278
    Location:
    Monterrey
    Country:
    Mexico
    yeah... this is for that [​IMG]
     
  8. longtom1

    Member longtom1 Keep an eye on my posts cause I quick edit frequen

    Joined:
    Jan 12, 2009
    Messages:
    2,641
    Location:
    Honey Oils inc.
    Country:
    Antarctica
    can't you just install it straight over the top without reinstalling the system menu????
     
  9. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    Not adviseable!

    The simplest and safest way to remove preloader is to reinstall the System Menu
    using AnyRegion Changer or a WAD installer.
     
  10. bhast2

    Newcomer bhast2 Member

    Joined:
    May 22, 2009
    Messages:
    32
    Country:
    United States
  11. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
  12. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
  13. LufianGuy

    Member LufianGuy GBAtemp Regular

    Joined:
    Oct 7, 2008
    Messages:
    244
    Country:
    United States
    Step by step instructions would be nice for those trying to install this new preloader who already have it installed.

    I'm not sure but I think the steps are:
    1. Dl your system menu and IOS60 wad from NUSD
    http://wiibrew.org/wiki/NUSD
    2. Install system menu wad
    3. Install IOS60 wad
    4. Use Truncha Bug Restorer
    5. Install this new preloader

    Questions:
    1. How do I do step 1?
    2. Is step 4 necessary?
    3. Is there any other way to do this than reinstalling the system menu?
    4. Is this new preloader safe for system menu 4.0?
    5. Does this auto screw up Bootmii booting to HBC? YES
     
  14. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    awesome will probably implement into my 4.2 guide. Great job.
     
  15. LufianGuy

    Member LufianGuy GBAtemp Regular

    Joined:
    Oct 7, 2008
    Messages:
    244
    Country:
    United States
    I hope so, I wanna know what the right steps to take are.

    I'm not sure but I think the steps are:
    1. Dl your system menu and IOS60 wad from NUSD
    http://wiibrew.org/wiki/NUSD
    2. Install system menu wad
    3. Install IOS60 wad
    4. Use Truncha Bug Restorer
    5. Install this new preloader

    Questions:
    1. How do I do step 1?
    2. Is step 4 necessary?
    3. Is there any other way to do this than reinstalling the system menu?
    4. Is this new preloader safe for system menu 4.0?
    5. Does the new HBC screw up Bootmii booting to HBC also? YES
     
  16. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    Not that I am aware considering that both these apps = Team Twiizers.



    /phpgeek
     
  17. LufianGuy

    Member LufianGuy GBAtemp Regular

    Joined:
    Oct 7, 2008
    Messages:
    244
    Country:
    United States
    According to a video here:
    http://www.youtube.com/watch?v=nu_UD7PJdp4

    We have to install the latest version of Bootmii because it also cannot boot to the new HBC.

    So what would be the steps to reinstall bootmii?

    Maybe they are:
    1. Dl the hackmii installer online and throw it on your sd card or
    just dl it through HBC itself
    2. Boot the hackmii installer
    3. Uninstall Bootmii
    4. Reinstall Bootmii

    I don't like the sounds of reinstalling a boot2 bootmii.
     
  18. phpgeek
    OP

    Member phpgeek GBAtemp Regular

    Joined:
    Feb 15, 2009
    Messages:
    112
    Country:
    United Kingdom
    Yes that's correct, but if you have updated to the latest HBC I would have thought you would have also updated BootMii in the process as they both form part of the HackMii installer. If you have not yet updated BootMii then I would update it!


    /phpgeek
     
  19. Lothlorian

    Member Lothlorian GBAtemp Regular

    Joined:
    Jul 9, 2009
    Messages:
    207
    Location:
    Berdoo
    Country:
    United States
    Very nice. Only reason I have not updated to the new HBC is because pre-loader does not boot to HBC. Now we have a fix for that seeing as it does not look like Crediar is going to make a new version of Pre-loader.

    Or is Crediar going to make one? Over and over again he claims .29 will be the LAST version. Yet I hear there was an auto-update for .30 and it was taken down. Is Crediar working on a new Pre-loader or no? If not thank goodness for Hex Edit Skills!!

    Great Job...
     
  20. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    i honestly think he wont make a new version.
    i mean i seen the .30 personally in preloader, the changelog seemed nice a legit, but it wouldnt let you dl it.

    it'd be best if someone could contact him to see if this version of preloader could be put up on wiibrew.org
     

Share This Page