postLoader4

Discussion in 'Wii - Emulation and Homebrew' started by stfour, Jun 30, 2011.

  1. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    Some new bugs:

    Virtual Console/Wiiware do not load from postloader in sneek/uneek. I get the loading screen then it just goes blank.

    Code support is broken (uNEEK/no DI)(Emulated Nand/PostLoader). I've tried sd to usb to nand but they do not work.

    EDIT: Ok I found something weird with code support. If I change the games "boot method" to "load apploader" from "normal boot method", I see the message that "codes found. applying". But then the codes "only" actually work from the "NAND" selection. SD or USB do not work even though I still get the message that "Codes found. Applying". But no codes have been loaded. What ever you changed in this version has adverse effect on codes. I'd like to be able to use my SD card for codes if possible because I'm also using Accio Hacks.

    EDIT2: Using the emulated NAND function in posloader: I can only get codes to work if I use them from the NAND option. If I select SD it says "codes found. applying" but the there is "error: could not patch the hook" and something about debug not working. Same thing if I select USB for the source.

    My splash screen will not show up it's at the root of the SD card.

    Interactive sort mode does not save. I can sort my apps just fine. But after that if I launch an app or go into a folder then return, the sort just goes back to the way it was before.

    EDIT3: Had to manually (Windows XP) remove all my sort setups in the meta files then go about saving before it accepted my order.

    Also, the word "Folder" overlaps with any "short description" in a meta file that's in a sub folder when it's highlighted with the cursor (in PostLoader).


    Is their going to be support for Emulated Nand folders? So you could select/switch between different sneeks/uneeks.
    Could you split Arcade from Neogeo in the channel sort menu and have them be separate sort of each other?

    I hope this report does not discourage you. It really is still a great app. Just needs a little more polish.
     
  2. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    Absolutely not ! I must thank you and Waver (and the other that posted in postLoader threads) for your "beta testing" work. I am a coder by profession since more 20 years, and (my) development time is tipically 80% write code and 20% solve bugs [​IMG]
    pl1 took 4 realeases to run smoothly... hopes the same for pl2 (we are at the 2nd).

    Just a question about emulations.... do you find the same problems in triiforce (this one, r92 ) ? Can you kindly check ?

    Thank you ! [​IMG]
     
  3. tueidj

    tueidj I R Expert

    Member
    7
    Jan 8, 2009
    Can't get this to work at all when launched from HBC - it does the 10 second "Waiting for USB device - (A) interactive (B) interrupt" countdown, neither of the options work because the wiimote won't sync. Then it shows a "No configuration file was found, an SD or USB device is needed" prompt with an option to boot to the wii menu, but again it can't be selected without a working wiimote.
     
  4. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    This is odd... no one has reported this... do you started from hbc using sd or usb device ?
     
  5. tueidj

    tueidj I R Expert

    Member
    7
    Jan 8, 2009
    SD. Is it possible nobody else has reported it because I'm the only one without a warez cios installed as IOS 249?
     
  6. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    Oh yes, it is... you should use postloader1...

    Anyway running postloader from hbc is not so usefull...
     
  7. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    ok, I think I've found where is the problem with codes when they are on emulated nand device... I can't test triiforce now, but I will be surprised if it is able to work too.
     
  8. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    I can't reproduce this... [​IMG]
     
  9. tueidj

    tueidj I R Expert

    Member
    7
    Jan 8, 2009
    I don't see how the situation would be any different if I was autoloading postloader via priiloader, it would still be trying to load a stubbed IOS249. It would probably even crash if I tried to run it under SNEEK/UNEEK, since my emulated nand would have a stubbed IOS249 as well.
     
  10. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    If you have built your nand with modmii, maybe you have choosen to install 249v17 (or 14... I can't remember). So postLoader should work under sneek (Almost, who has tested reported so...)

    Anyway I will add a check for stubbed 249... so it can reload standard hb ios. Added to the "to-do"
     
  11. SifJar

    SifJar Not a pirate

    Member
    7
    Apr 4, 2009
    He wasn't saying that it would be different from Priiloader. He just said that its not useful from HBC because you can already load homebrew from HBC, so loading a loader from a loader is an unnecessary extra step. Presumably you just wanted to test it or something.
     
  12. zizer

    zizer GBAtemp Addict

    Member
    2
    Aug 23, 2010
    i have black screen uneek r155 cios rev14 slot249
     
  13. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    Great, wii programming is something random [​IMG] , waver seems to have the same and it works... I will check (but not before tomorrow) [​IMG]
     
  14. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    Does it support Wiiload? Just curious..
     
  15. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    actually not.. it is on the "to-do"
     
  16. Taleweaver

    Taleweaver Storywriter

    Member
    13
    Dec 23, 2009
    Belgium
    Belgium
    As my signature says: I have exactly the same now, so...

    Can you give more info on that? When does it black screen? (When starting?) Both if you run it through priiloader or also if you start it through the HBC?



    @stfour: no offense, but it's actually Wever (with an 'e'). 's okay if you make it into Weaver (which is how it's pronounced in English, so...), but Waver is just...not it. [​IMG]
     
  17. zizer

    zizer GBAtemp Addict

    Member
    2
    Aug 23, 2010
    i have black screen if i run it through priiloader and through the HBC
     
  18. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    postLoader2 b8

    * Channel browser: Full caching of title... no more wait time on change to real/emu_sd/emu_usb. Cache must be rebuilded manually
    * Now icons are loaded in background
    * Other minor fix

    postLoader2 b7 (unreleased)

    * CH: Cert.sys missing may be have fixed (must be checked)
    * CH: codes loading may be fixed
    * HB: Fixed overlap of subfolders descriptions
    * Corrected custom splash screen issue.

    Download on first post... [​IMG]
     
  19. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    I'm at work, I'll check this out when I get home. Thank you for the updates.
     
  20. Taleweaver

    Taleweaver Storywriter

    Member
    13
    Dec 23, 2009
    Belgium
    Belgium
    cert.sys is still needed. If not, it passes the test, but then fails a bit further at ES_IDENTIFY (sorry: didn't have the time to note the full error message). With cert.sys, things are still fine.

    @tueidj: for tests sake, I removed rev14 from my UNEEK setup and it still does what it should do. So whatever it is on your end, I doubt it's because of what's in the IOS249 slot.
     
Quick Reply
Draft saved Draft deleted