postLoader4

Discussion in 'Wii - Emulation and Homebrew' started by stfour, Jun 30, 2011.

  1. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    You're welcome, though I can hardly take credit for most of the code written. :P
     
  2. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    Using 4.0.7: I get the same problem. Postloader will not work with neek2o. However I can launch directly to the neek2o system menu just fine. I suppose this bug will have to wait till stfour gets back in the game from vacation.
     
  3. Etheboss

    Etheboss Official LULWUT supporter

    Member
    6
    Feb 24, 2009
    Netherlands
    Around somewhere
    This depends on which version of nee2o you are using, up to rev. 88 you should be able to work with PL..for rev 90 and up PL needs to be updated, stfour already knows this.
     
  4. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    I'm using v88. Got it from Modmii. hmmm.
     
  5. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    what's happens ?
     
  6. TheBigBentley

    TheBigBentley Newbie

    Newcomer
    2
    Nov 25, 2010
    United States
    Time to sound stupid.... Can someone tell me where this file is?

    From the ReadMii.txt
    "2) Copy to your SD root priibooterGUI.dol."

    Do I rename boot.dol in the priibootergui folder to priibooterGUI.dol and then copy that to the root of the sd card?
     
  7. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    most of readmii.txt is very old. that operation is no more needed.
     
  8. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    1] Start neek2o from postloader.
    2] neek2o starts and I can get to system menu ok.
    3] launching postloader channel takes me to the create config screen.
    4] After clicking on ok (creating config on sd or usb has same outcome) I was getting a code dump that I was going to post here today. But somehow I did mange to get to postloader, however
    5] If after the config file is created and I launch neek2o again, then launch postloader from neek2o system menu, I get just a black screen. Same out come if I set postloader up in priiloader just like my real wii. Blank Black screen.
    6] Now when I delete the config file see 1] It repeats.

    I'm still trying to get that code dump again but after several attempts I can only get to postloader (neek2o) on the first try, after that blank screen.

    Now I'm getting "postloader .dol not found on sd/usb"
     
  9. VatoLoco

    VatoLoco Don't crush that dwarf, hand me the pliers.

    Member
    8
    Jan 29, 2008
    United States
    Ya Cant Get There From Here
    Basically the same scenario as DEFIANT here.

    On 4.0.5 and 4.0.7, when i try to boot uneek(rev 88) with postLoader set as autoboot on nands (via priiloader), i just get a black screen. Booting to a nand without postLoader as autoboot works.
    When i revert back to 4.04 everything works as expected.

    From real nand postLoader i can still "switch NAND" and access/launch all my various nands of vc/wiiware and stuff, its just when trying to boot a neek2o nand with postLoader set as autoboot.
     
  10. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    Yep, still no luck here. Thanks for the confirmation VatoLocoo. I might try 4.0.4 here in a minute...my sd card needs to be reformatted (corrupted) and some of my apps redownloaded...OY!
     
  11. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    it is really strange. I've no clue on that... from 4.0.4 to 4.0.5 the difference are really just one line of code about devolution. Some concrete difference in neek where added in 4.0.6. Maybe a log can help (create ploader.log on sd root), but I have a slow internet connection and I don't think that I can submit any patch or upload new rev until september ;)
     
  12. DEFIANT

    DEFIANT GBAtemp Fan

    Member
    4
    Dec 9, 2008
    United States
    Gallifrey
    no worries...enjoy your vacation.

    It's not like I'm going to play all my stuff at once, plus I still can get to neek nand without postloader.
     
  13. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    Is it so slow that you can't even paste the patch file in a code tag like I typically do? I could upload it then into a new build for you.
     
    1 person likes this.
  14. VatoLoco

    VatoLoco Don't crush that dwarf, hand me the pliers.

    Member
    8
    Jan 29, 2008
    United States
    Ya Cant Get There From Here
    i had been using r88, but i just installed r92 of neek2o, and my blackscreen issues are gone =D
    postLoader 4.0.7 is working great with it.
     
  15. stfour
    OP

    stfour GBAtemp Advanced Maniac

    Member
    3
    May 24, 2011
    Italy
    nice, thank you ! ;)
     
  16. VatoLoco

    VatoLoco Don't crush that dwarf, hand me the pliers.

    Member
    8
    Jan 29, 2008
    United States
    Ya Cant Get There From Here
    no no no, thank you =D
    postLoader is quite the awesome app!
     
    1 person likes this.
  17. Elaugaufein

    Elaugaufein GBAtemp Regular

    Member
    4
    Jan 26, 2010
    Hi, I've used postLoader in the past and all was good , I updated recently postLoader no longer seems to be able to detect my USB drive, which is NTFS formatted, I just get told to rebuild my cache every time I try to view my wii games. Is there a configuration option, I also can't find a configuration option in Wii games to point it at my USB (I'm guessing its trying to load off my SD, which is why it isn't finding anything). Could anyone give me some pointers please ?

    Is there somewhere you have to put devolution (either the bin or a compiled version) to get devolution support, or is that automatic ?

    Thanks

    ETA - If it helps when I try to look at homebrew on my USB I get an Invalid Dev !!! message at the top, but I've used Configurable USB loader and Wiiflow to boot homebrew and games from it, so I'm not sure whats going on there.
     
  18. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    I'll address your Devolution question: loader.bin goes in (your fat device here, meaning your SD or USB):/ploader/plugins.
     
  19. Elaugaufein

    Elaugaufein GBAtemp Regular

    Member
    4
    Jan 26, 2010
    Ahh. Thanks.

    On the USB hard disk, it just occured to me that the issue might be that its one of the WD my passport drives that have a built in read-only 2nd Dev thats used to store their built in software. I could see that causing problems.
     
  20. daxtsu

    daxtsu GBAtemp Guru

    Member
    14
    Jun 9, 2007
    Antarctica
    Maybe back up their proprietary software and delete the extra partition, if it's possible?
     
Quick Reply
Draft saved Draft deleted