Please help not making a mistake while hacking my Wii

Discussion in 'Wii - Hacking' started by wiipt, Dec 21, 2013.

  1. wiipt
    OP

    wiipt Newbie

    Newcomer
    4
    0
    Mar 31, 2011
    Hi everyone,

    I own a black WII (purchased back in 2009), which was officially updated to the 4.2E System Menu version. Nonetheless, I did install the HBC with HackMii v0.8 a few years ago in order to use the WODEFlow app (I have a WODE device installed).

    I recently got a game (Just Dance 2014) which I believe it needs SM 4.3E in order to run. And this is where I need your help.

    I have been keeping my Wii on 4.2 because I am aware that 4.3 doesn't bring anything new other than exploit corrections. Nonetheless, I would like to keep my options opened, so I am not sure what to do next.

    I am not interested in USB Loaders softmodding, as I use my WODE for that. I would also like to be able to run some custom games, such as the "Sing It Star" series, which I believe it needs some cIOS installed (still not sure which one).
    So:

    1) is it safe to use the official 4.3 update? Will I be somehow capped compared to the possibilities with 4.2?
    2) will the HBC interfere with that update (I have HBC updated with the OTA update suggested by the channel itself), or is it safe to leave there before triggering the update?
    3) after the 4.3 update, will I be able to install a cIOS in order to play the custom SingItStar games?

    Thank you all for all the help you can give me.
     
  2. SickPuppy

    SickPuppy New Member

    Member
    1,789
    451
    Jul 29, 2009
    United States
    If your main method of loading backups is a hardmod then by default you should have the latest update installed to access the latest games that require the latest update, unless for some reason the latest update blocks your hardmod.

    concerning softmods-
    Games are dependent on IOS to run, no game requires a certain version of the system menu to be installed. cIOS is for running backup loaders and getting pirated games compatible with backup loaders. If you have priiloader installed then you need to set it to not accept updates from a disc or a network. Just make sure you have all IOS installed and you should be fine, it don't matter what version of the IOS is installed. I have system menu 3.2 installed and never update any IOS, I just install the newer IOS's as they are released. Never downgrade the version of an IOS unless you know what you are doing, you can brick your Wii by downgrading an IOS to one that is not compatible with your system menu or hardware.
     
  3. wiipt
    OP

    wiipt Newbie

    Newcomer
    4
    0
    Mar 31, 2011
    Thank you very much for your reply.

    About the update, it was I who never allowed the 4.3 to install, as I always heard (read) that it didn't bring anything new other than security fixes.
    It seems that Just Dance 2014 needs some updated IOS that comes with 4.3, thus I at this point I am considering upgrading.

    I am really not very informed about cIOS... but I would like to explore it in order to play custom games such as SingItStar. According to the information I was able to gather, these custom games need cIOS rev14 or newer, but I still need to figure out what that is :) and if it will work properly with 4.3E.