Playing cartridges in Classic Mode & using their saves

Discussion in '3DS - Flashcards & Custom Firmwares' started by DerGefallene, Sep 27, 2015.

  1. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    Hey guys. So I'm fairly new to Gateway and I have some problems:
    I have 2 3ds, one that has the newest SysNand 10.1 and one that has FW 4.4 but its EmuNand is 10.1 (so I'm using the newest Gateway version 3.4.1). I think about selling my 3ds with the newest sysnand so I looked if I could play all of my retail games in gateway classic mode. I have 3 games: Pokemon X, Pokemon Omega Ruby and Animal Crossing: New Leaf.
    Animal Crossing works perfectly and even recognizes my old save state.
    Pokemon X works too, but it tells me that the save data is corrupted (even after dumping the game).
    Pokemon Omega Ruby doesn't work at all. After starting it, it just stays at the red vibrating 3DS Logo.

    Does anyone know how to fix this? So to make Omega Ruby work and maybe to use my Pokemon X save state? I already used the search function but I couldn't find a fix for this.
    And also does anyone know if it's possible to use my Nintendo ID from my sysnand 3DS on my emunand 3DS because I have some money on it? Thanks in advance.
     
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,516
    5,474
    Mar 17, 2010
    Norway
    Alola
    You need a sysNAND of at least 6.0 for those saves to work, they use a different save encryption on 6.0+
     
    MelonGx likes this.
  3. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    Ok thank you. And concerning the Pokemon Omega Ruby cartridge?
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,516
    5,474
    Mar 17, 2010
    Norway
    Alola
    Not sure. There's no reason I can think of why it wouldn't work.
     
  5. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Pokemon OR:
    You may need an e-shop directly downloaded latest patch.
     
  6. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    So do I just have to put in my retail Pokemon X game without entering gateway mode to update to sysnand 6.3? Or could something happen?

    Edit: All of this now got me confused..like I said I have SysNand 4.4 and EmuNand 10.1. All saves from the roms I dumped are now on v. 10.1 correct? Because it said that when updating sysnand to 6.x or higher then 4.x saves will be corrupted but because I'm on EmuNand 10.1 that doesn't concern me, does it?
    So if I update to 6.x via Pokemon X or to 7.x via Pokemon Omega Ruby (if I got that right) then I can play these cartridged with their save file and the rom-saves on my SD card will still work, right?
     
    Last edited by DerGefallene, Sep 27, 2015
  7. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    SysNAND 4.x + 6.x Cartridge saved on 4.x = OK
    SysNAND 4.x + 6.x Cartridge saved on 6.x = Save Corrupt
    SysNAND 6.x + 6.x Cartridge saved on 4.x = Save Corrupt
    SysNAND 6.x + 6.x Cartridge saved on 6.x = OK

    Only SysNAND determines your cartridge save's recognization.
    emuNAND is always useless here regardless of its version.

    6.x Cartridge saved on 4.x = Cartridge played on Sys 4.x Classic Mode (Already messed up but matched for the messed-up machine)
    6.x Cartridge saved on 6.x = Normally playing
     
    Last edited by MelonGx, Sep 27, 2015
  8. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    Ok thank you! So could you please answer me: If I update my SysNand via Pokemon OR update, will my emunand be affected somehow or can I update my 3DS to 7.x without any problem?
     
  9. Arkansaw

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    Edit: In your case, you should just update the sysnand to 6.x, and system transfer from 10.1 sysnand to 10.1 emunand if you want to keep the nnid
     
    Last edited by Arkansaw, Sep 28, 2015
  10. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    Ok so just to ask again (I just don't want to make any mistakes): I can just put in my Pokemon Omega Ruby game and let it update to sysnand 7.x and then my emunand will be fine? And then I can just go back into emunand 10.1 and do a system transfer from my other 3ds' sysnand 10.1 to keep my nnid? What about the new nnid I created for my emunand 3ds? can I just delete it? Sorry for all these questions.
     
  11. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Cartridge updating SysNAND is OK.
    But it generates a new problem - Since Cart-update NEVER updates the Browser, it may cause some unexpected error on booting rxTools by URL.
     
  12. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    That's okay. I never used rxTools and it wasn't part of my plan. I got everything working now! Here's what I did: (Sysnand 3DS = 1; Emunand 3DS = 2)
    1.) Made a backup of nand, the 3DS SD Card and so on (in case something goes wrong)
    2.) Deleted my existing nnid on 2
    3.) Formated 2
    4.) On this new formated 3DS I inserted Pokémon Omega Ruby and let it update to FW 7.2
    5.) Did a system transfer from 1 to 2 (while 2 was in emunand)
    6.) Launched the exploit (if I got that right: Now that I'm on fw 4.5+ I can't use the blue card exploit anymore and have to use the Browser, right?)
    7.) Checked Gateway mode first: Games and Multi-Rom works; then I checked Classic mode: My 3 games all work and their savestates too!
    + now I have my nnid on 2 and and my 10 bucks that I had still on it!

    I also know now why Omega Ruby didn't work before: Somehow my emunand was resetted to v. 4.4 I don't know why..but that's history!

    One last question regarding 6.) : Is it true what I wrote there? And if yes: Somehow I can get the exploit to work only when I type in the gateway site on google and then click on the link in the 3ds browser. When I type in the link directly, I get to a blank site saying "loading" and then I get back into the 3ds menu saying "An error has occured". Anybody knows how to fix?
     
  13. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    The Spider Hack only works perfectly on complete SysNAND upgrades.
    If your SysNAND is cartridge-updated, which means your Browser is not matched to your SysNAND, the Spider Hack may return unknown errors on booting.
     
  14. DerGefallene
    OP

    DerGefallene Newbie

    Newcomer
    9
    0
    Aug 31, 2015
    Gambia, The
    Ok now I got it. Thank you all for your help!