PKMN Diamond On DS-X Saver Issue

Discussion in 'NDS - Console and Game Discussions' started by Nega, Apr 23, 2007.

  1. Nega
    OP

    Nega Newbie

    Newcomer
    3
    0
    Dec 20, 2006
    Ok, this may seem weird, but whenever I load Diamond on My DS-X, it doesnt use the save file.
    I have deleted the save file itself off my DS-X and i can load the rom and the save is still there, also when I load Pearl, it uses the same save file, the one that doesnt exist anymore... has anyone else had this problem?
     
  2. Emerson

    Emerson Advanced Member

    Newcomer
    57
    0
    Dec 24, 2006
    United States
    I was having similar problems. Basically what I would do is:

    Load Pokemon, save, and turn off DS.
    Load up DS-X, let eeprom save.
    Load a different rom, play around a bit and save.
    Load up DS-X, let eeprom save.
    Delete the lgc-pkmd.sav, replace it with whatever.

    It took me quite a bit of fooling around to get right, something like this should do it.
     
  3. SammyMac

    SammyMac Newbie

    Newcomer
    1
    0
    Apr 23, 2007
    I have been having the exact same problem, I will try this and see if it works, thanks.
     
  4. KirbyPink

    KirbyPink GBAtemp Fan

    Member
    391
    0
    Jun 30, 2006
    Gbatemp
    I know the issue. If you hit New game it will tell you how to delete the save game.
    Do so and the save file is officaly gone.But here it is just in case.
    Press Up + Select + B at the TITLE SCREEN ( From the menu where it says new game and load game press B button to go to TITLE SCREEN if you jumped passed it) then do this command. DO NOT turn off power. Trust me , DON`T.
     
  5. Emerson

    Emerson Advanced Member

    Newcomer
    57
    0
    Dec 24, 2006
    United States
    What KirbyPink said could very well work, but when I was trying to replace my save I deleted my old one in the process and my data was corrupted and I couldn't replace it.
     
  6. Nega
    OP

    Nega Newbie

    Newcomer
    3
    0
    Dec 20, 2006
    I have tried that, but to no success yet, it is becoming frustrating...
    It seems like the SAV itself is staying in the EEPROM of the DS-X instead of completely saving, which is unusual...
     
  7. Emerson

    Emerson Advanced Member

    Newcomer
    57
    0
    Dec 24, 2006
    United States
    It does stay there, which is why you have to let it dump before you do anything to the save file. If you do that and it still doesn't work I'm not really sure what's wrong.
     
  8. zeroblitzt

    zeroblitzt Newbie

    Newcomer
    7
    0
    Dec 19, 2006
    United States
    Yup, i've had this problem. The Select+B+Up delete thing doesn't work either. Nega, you're right, it seems like the DS-X is not writing from the EEPROM to the sav file.
     
  9. jesterscourt

    jesterscourt Not Brad.

    Member
    2,199
    74
    Jan 3, 2007
    United States
    Is this similar to the problem people were having with Hotel Dusk and Custom Robo Arena?