PC only sees Switch as unknown device

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Blackforce, Jul 21, 2019.

  1. Blackforce
    OP

    Blackforce Member

    Newcomer
    2
    Nov 18, 2016
    Canada
    I currently have my brothers switch here and have a problem. It has AutoRCM and emuMMC and worked fine until this morning when I decided to turn it off and back on to switch from the OFW into emuMMC. Plugged it into my PC and my PC tells me that it is an unknown device. Tried another USB Cable, same message. Tried another PC, same message. So I took my Switch and sure enough my PC instantly recognizes it and I can launch Hekate. So, there seems to be a problem with my brothers Switch but I just can't figure out what it is. Everything worked just fine until today and now I just can't get it started...
     
    NoNAND likes this.
  2. Resaec

    Resaec GBAtemp Fan

    Member
    5
    Dec 19, 2017
    Germany
    Try this:
    1. connect the Switch to your PC
    2. enter RCM (reboot if needed/already in RCM)
    3. force APX driver installation using TegraRcmGUI
     
  3. Waicol

    Waicol Member

    Newcomer
    2
    Nov 11, 2018
    Afghanistan
    Maybe a defective type c port, try cleaning it with a piece of paper first.
     
    Blackforce likes this.
  4. Blackforce
    OP

    Blackforce Member

    Newcomer
    2
    Nov 18, 2016
    Canada
    So, I tried to reinstall the APX drivers and my PC just won't and said that it failed. I cleaned the USB port and tried again and it worked. Don't know if it was just luck or it really solved the problem, but hey, at least I could start the switch again and it seems to be charging in the dock.
     
    Waicol and NoNAND like this.
  5. NoNAND

    NoNAND GBAtemp's Official NAND/emuMMC multipurpose tool

    Member
    10
    Aug 22, 2015
    Antarctica
    Area 51
    Waicol and Blackforce like this.
Loading...