Hacking Question Partial Brick / Error 2001-0114 / No WiFi Network Can Be Detected


Well-Known Member
Sep 14, 2009
Some months ago I purchased a Nintendo Switch "as is" from someone online who wouldn't tell me what was 'wrong' with the system or how it came to happen that the device is no longer working. I was simply told that it is stuck on the Switch logo. Since it was a launch (unpatched) unit, I decided to take a gamble.

Initially, I made this thread here, back when I had no idea what was wrong with it: https://gbatemp.net/threads/possibl...-logo-then-turns-of-hekate-loads-fine.567657/

However, I decided to create a new thread as I now have a far more extensive understanding of what seems to be wrong with it. I could identify from the burnt fuse count that it was running a version of 10.0.x.

The Switch would generally hang on the Switch screen as described. Using Hekate I was able to launch Hekate itself, but I was not originally able to boot into system or Atmosphere. I was advised to use this guide (https://switch.homebrew.guide/usingcfw/manualchoiupgrade.html) to downgrade it. However, before I proceeded with this technique, I managed to identify a way to consistently get it to 'boot' just fine.

Specifically, if I use Hekate and then load Lockpick_RCM.bin (the latest one, if it matters) from the options, I can get the Switch to boot fine by using the option to "reboot to system" from within the Lockpick_RCM boot screen. I know it is weird, but it is the only way to get it to boot: If I choose reboot to system from Hekate it won't normally load and it will hang. Interestingly enough, if I add atmosphere files on SD and push the fusee-primary.bin from Hekate, I can also get it to load Atmosphere just fine.

So, in other words, I can load into both the system itself and Atmosphere. I can verify that it is currently running on 10.0.3

But the Switch is still not 'OK'. While it seems to function just fine (touch screen, sound, video, controllers, all buttons, cartridges, dock output, bluetooth, etc, all work fine) it has two (possibly interconnected) issues:

1. The first is that if it automatically goes to sleep, or I press the power button to get it to sleep, it will crash with the error code 2001-0114. It works fine if I do not send it to sleep or let it sleep automatically.

2. The second is that it won't find any WiFi networks. It seems to "search" but finds nothing. It does not give a specific error for this. The Switch seems to think that it is "searching", but nothing is found.

I am able to entirely circumvent issue 1 by simply changing the settings to prevent sleep altogether (set to "Never" for both handheld and docked mode, and set Sleep to "Never" from the options). That way, I can turn off the screen just fine and the Switch will no longer crash with Error code 2011-0114.

Likewise, by setting Flight mode to On, and manually turning on bluetooth connection, the Switch no longer has to use its WiFi card.

With these two solutions in combination, I am able to do just about anything with it. It plays games, installs games, it simply works just fine. It is not a 'fix', but it seems to help with stability. I have not had the crash error after employing these two methods.

I do not know whether these two solutions are connected (for example, whether the crash and stuck on logo issue has been solved), but they do seem to be.

I have already performed a full reset from the settings. I can confirm that I have not yet found a way to boot into the recovery screen. If I try to enter the recovery by pressing Vol + and - simultaneously on boot, I am stuck on the logo instead. If I turn off the Switch, it will also get stuck on the logo -- and will only get unstuck if I use the abovementioned method to boot system or Atmosphere. I do not know if the reset from recovery is more thorough than the one from the settings screen and whether that would make a difference.

I have a few solutions/options available to me, but I want to approach this carefully.

My first option, but one I want to avoid if possible, is to physically open it up and inspect whether the WiFi board is problematic or disconnected. I have another functional Switch to test and verify if it is the WiFi board that is causing this problem. I want to avoid this option, however, in case it is NOT the WiFi board and it is something else hardware related. Ideally, I want to be able to send it to Nintendo itself if it is another motherboard issue that I cannot fix.

My second option is to downgrade/upgrade as advised. I could have used ChoiDujour from Hekate itself, but now that I can consistently boot into the system, I can also use the far easier method of ChoiDujourNX. I have not yet done this mostly because I want to receive updated advice from GBATemp given this new information I can provide about the system's condition and verified issues. I have already made a full backup of everything, so I am fairly confident that I could try just about anything and simply restore the backup.

My third option, although I don't know how workable that is, is to use emuMMC to update only the emuNAND to the latest version (or an earlier version) and see if that helps. I am not sure if and why this would be preferable to the second option however.

Can anyone point me in the right direction? It would be so awesome to fix a Switch that had been written off!


1: I tried installing Ubuntu on the Switch and I can confirm that WiFi does not work under Ubuntu either. This probably points towards a problematic WiFi module. I am fairly confident replacing it will fix this Switch.

2: I managed to get it to perform a full hardware reset with the Power plus Volume + and - option. It did not fix the issue however.

3: I opened it and had a quick look. It had plenty of dust but nothing that would signify any kind of obvious damage. I believe it may be that the WiFi chip, which is sadly soldered on the console, may be bust. Interestingly, the same chip sends both bluetooth and WiFi signals, but the bluetooth is working fine.
Last edited by grcd, , Reason: New Information Provided

You may also like...

General chit-chat
Help Users
    BigOnYa @ BigOnYa: Don't Do it! :evil: