Hardware Nintendo Switch LCD issue?

Subaru-2

New Member
Newbie
Joined
Jul 14, 2020
Messages
1
Trophies
0
Age
21
XP
23
Country
United States
I just recently read a thread in which the community here gave some super valuable advice and was hoping to receive some myself. Recently my Switches screen started acting up out of nowhere. When I power it on or wake it the screen is covered in multicolored horizontal lines with a sort of grid pattern, after about 1-3 seconds the screen will go black with backlighting still present. The digitizer seems to work perfectly as well, and the Switch functions normally when docked. This problem seems to have appeared out of the blue with no forewarning. It seems to have occurred in the span of about 5-10 minutes. I plugged my switch into the charger and left the room for a moment, upon returning the screen was completely covered in the aforementioned lines. I’m not sure if it’s an issue with the lcd or possibly an issue with the motherboard. I opened the switch up and there doesn’t seem to be any issue with the ribbon cables or connection. Any help would be very very much appreciated.
 

Fixyourtechnology

New Member
Newbie
Joined
Sep 1, 2020
Messages
3
Trophies
0
Age
35
XP
20
Country
United Kingdom
I have the exact same problem with two switch's i'm working on, When i find the answer i will let you know,
tried replacing the connector and tried with a known working screen but still just a black screen with back-light,
when screen is unplugged the screens test-point is presenting 1.6v as if the screen is plugged in,
everything else works perfectly,
if anyone knows the ic or diode\cap\resistor causing this issue please let us know.
Thanks in advance
 

Fixyourtechnology

New Member
Newbie
Joined
Sep 1, 2020
Messages
3
Trophies
0
Age
35
XP
20
Country
United Kingdom
Found my problem it was the IC marked "8316 8f40" to the left of the connector, there was slight burn damage and showed the solder point underneath at an angle, totally missed it on first few passes, hope this helps mate
 

Site & Scene News

General chit-chat
Help Users
  • DSgodman @ DSgodman:
    lol wat is this
  • Maq47 @ Maq47:
    Ur mum. lol xD
  • wiiuepiccpu @ wiiuepiccpu:
    F u n n i t e x t
  • PeeJay Bonobo @ PeeJay Bonobo:
    I wonder what the speeds are with this upload I'm doing, because I have a reason to believe that YouTube is barely taking advantage of my upload speed under Firefox.
  • Ishzark @ Ishzark:
    did your upload slow down? V:
  • Ishzark @ Ishzark:
    #+
  • Ishzark @ Ishzark:
    oops
  • PeeJay Bonobo @ PeeJay Bonobo:
    No, I've checked my upload, it's still good.
  • Ishzark @ Ishzark:
    so Youtube is not the one at fault
  • PeeJay Bonobo @ PeeJay Bonobo:
    I blame Firefox. I can't believe I'm saying this, but if this was Chrome, the video would be processing right now.
  • CeeDee @ CeeDee:
    @wolffangalchemist you're just doing it wrong, smh
  • Ishzark @ Ishzark:
    greedy Firefox
  • CeeDee @ CeeDee:
    comic sans is pretty awesome
  • CeeDee @ CeeDee:
    I mean... at least I think so... HAH
  • VinsCool @ VinsCool:
    poop
  • Olmectron @ Olmectron:
    bread
  • boomy @ boomy:
    bread
  • Olmectron @ Olmectron:
    breadofthewild
    +1
  • RichardTheKing @ RichardTheKing:
    ^ That explains why that game feels so stale and old and gross; thanks!
  • Asia81 @ Asia81:
    pooping a bread in the wild
    +2
  • kenenthk @ kenenthk:
    Yo found my PS1 pizza hut demo disc
  • thehawksfuckingdead7 @ thehawksfuckingdead7:
    ps1 games are wild man
  • RichardTheKing @ RichardTheKing:
    Okay, how do I disable that "GBAtemp wants to enable push notifications" banner at the bottom of the screen? It keeps appearing whenever I visit the home page, and I can't enable them.
    RichardTheKing @ RichardTheKing: Okay, how do I disable that "GBAtemp wants to enable push notifications" banner at the bottom of...