Nintendo Switch Drawing 0.06A

Discussion in 'Switch - Console, Accessories & Hardware' started by K1ck09, Jul 15, 2019.

  1. K1ck09
    OP

    K1ck09 Member

    Newcomer
    1
    Jan 29, 2019
    Portugal
    Hello Guys,

    A few months ago I asked where in the forum about a Nintendo switch crashing in some payloads and mattygrog suggested changing the BQ24193. Today I got time and I replaced it and now it draws 0.06A and still doesn't turn on. I found some caps shorting right around the phase buck converter below the eMMC. Everything around M92T36 is fine. The BQ24193 while 0.06A gets warm to the touch but nothing like crazy hot!

    Best Regards.
     
  2. Agilato

    Agilato Advanced Member

    Newcomer
    1
    Jun 21, 2019
    United States
    Check voltage on M92T36 on pin 5-6, should be 3-5v, check both with pressed power button.
     
  3. K1ck09
    OP

    K1ck09 Member

    Newcomer
    1
    Jan 29, 2019
    Portugal
    It's around 4.5v
     
  4. Agilato

    Agilato Advanced Member

    Newcomer
    1
    Jun 21, 2019
    United States
    On both?
     
  5. K1ck09
    OP

    K1ck09 Member

    Newcomer
    1
    Jan 29, 2019
    Portugal
    Yes
     
  6. Agilato

    Agilato Advanced Member

    Newcomer
    1
    Jun 21, 2019
    United States
    May i have a picture of the replaced BQ? And check 3v on testpoint - 3 zone L
     

    Attached Files:

  7. K1ck09
    OP

    K1ck09 Member

    Newcomer
    1
    Jan 29, 2019
    Portugal
    Today I re measure the PIN 5 and PIN 6: 3.25v
    On testpoint 3 Zone L: 3.8v

    My BQ is getting really hot now
     
  8. TariqSoftDev

    TariqSoftDev ~Zexceil

    Member
    5
    Sep 18, 2013
    London
    If the BQ is getting hot that may be the issues, voltage being around 4.5v on the MT is normal if you are NOT using the default the AC charger supplied with the system; if you do you'll read 15v around the M92T and BQ input that is passed from the M92T controlled gates.

    If you want more help PM me.
     
  9. Testo

    Testo Member

    Newcomer
    1
    Jun 13, 2019
    Germany
    On my last repair all cap's and voltages around the M92T36 where correct but it still wasn't charging. I replaced it and it worked again. Also if the BQ gets hot, the is a chance that you shorted some pins while replacing it.
     
Loading...