1. momo240

    OP momo240 Newbie
    Newcomer

    Joined:
    Mar 3, 2021
    Messages:
    2
    Country:
    Belgium
    Hello everyone,

    I have a problem with my switch, it doesn't turn on anymore. When I put it on the docn, the led blink one time and then nothing.

    I put the broken motherboard in a functional switch but same result, but the switch turn on with the functional motherboard.

    I check short circuit around the ICs M92T36, P13USB and BQ24193 but everything looks good.

    What other check can I do?

    Thank you.
     
  2. thesjaakspoiler

    thesjaakspoiler GBAtemp Regular
    Member

    Joined:
    Nov 20, 2018
    Messages:
    259
    Country:
    Afghanistan
    Do the M92T36, P13USB and BQ24193 actually get power?
    Something as simple a broken USB-C port can also prevent any power from reaching the usb/charger chips.
    Also, the Switch won't turn on if the battery does't have sufficient power anymore.
    Another thing is that your switch turns on but is in AutoRCM mode waiting for a payload to be injected.
     
  3. de9ed

    de9ed GBAtemp Regular
    Member

    Joined:
    Oct 22, 2020
    Messages:
    105
    Country:
    Canada
    Try a spare battery to determine if either autorcm or charging port is broken.
     
  4. momo240

    OP momo240 Newbie
    Newcomer

    Joined:
    Mar 3, 2021
    Messages:
    2
    Country:
    Belgium
    Hello and thanks for your help.

    I put the motherboard on a functional switch so it's the motherboard the problem.

    I don't have any short around the chips, do you have the nominal voltage on the chips pins thejaakspoilerv?

    How can I check that the switch is in autoRCM?

    I buy the switch like that so I don't know his history.
     
    Last edited by momo240, Mar 9, 2021
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Nintendo, Switch, doesnt