New update?

Discussion in 'Wii - Hacking' started by grimmreapervi, Dec 1, 2009.

  1. grimmreapervi
    OP

    grimmreapervi Member

    Newcomer
    22
    2
    Nov 30, 2009
    Cyprus
    Hi guys! Today I popped in my Metroid Trilogy Disk, and it won't let me play unless I UPDATE MY SYSTEM? wtf? I thought 4.2 was the latest version! Did Nintendo give us a Xmas Present early? Is there any workaround to it?
     
  2. Hatsu

    Hatsu Someone's been killing, eh?

    Banned
    2,143
    0
    Oct 19, 2009
    __________________ Warn: 50%
    So you've softmodded?

    If you have, use Preloader 0.30 with 4.2 hacks (for your region) and enable Block Disc Updates
     
  3. B-Blue

    B-Blue slut

    Member
    GBAtemp Patron
    B-Blue is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,448
    288
    Sep 18, 2006
    Antarctica
    nvm...
     
  4. grimmreapervi
    OP

    grimmreapervi Member

    Newcomer
    22
    2
    Nov 30, 2009
    Cyprus
    That's weird, it can't find hacks.ini on either FAT or NAND. But it IS in the root of my SD card. ;/
     
  5. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    make sure its not zipped or rared and that it is for your region. Could also be that preloader doesnt like your SD.
     
  6. grimmreapervi
    OP

    grimmreapervi Member

    Newcomer
    22
    2
    Nov 30, 2009
    Cyprus
    Probably. My card is a couple of years old (came with a camera). Didn't any1 else get this update? O_O
     
  7. dottor_male

    dottor_male GBAtemp Regular

    Member
    181
    0
    Oct 30, 2008
    Italy
    I use metroid trilogy on 4.2E and it doesn't ask me to update. But I have also starpatch, so maybe I have disabled disk updates, I don't remeber...
     
  8. vegemikee

    vegemikee GBAtemp Fan

    Member
    356
    6
    Aug 17, 2008
    you probably updated a few IOS' and the system menu.
    i think that option only shows up if the wii detects that the selected IOS, SM and boot2 (in this case) havent all been updated.
    if preloader cant read your SD card because its a HC, try updating to Priiloader rev15. that fixed my problem
     
  9. Chris_Skylock

    Chris_Skylock GBAtemp Advanced Maniac

    Member
    1,501
    0
    Dec 26, 2008
    Philippines
    Wii Sports Resort didnt asked for any updates when I bought it 2 days ago and Im on 4.2U softmod. But Pokemon Battle Revolution asked for one when I was still in 3.1
     
  10. ballboff

    ballboff Member

    Newcomer
    21
    0
    Nov 9, 2009
    It's not a firmware update, just something to allow your console to play a game from a different region. It can brick your wii by doing so however. I wouldn't even play metroid prime trilogy through the disc channel anyway, as it contains 3 alternate dol's on the disc. You choose number 1 to play metroid 1, 2 for metroid 2 etc. Oh hang on, is this an original disc? mmmm.... ok yeah what he said lol. Or you could try startpatch, that works a bit better than the preloader hacks. And yeah, you need to enable the "block disc updates" feature.
     
  11. grimmreapervi
    OP

    grimmreapervi Member

    Newcomer
    22
    2
    Nov 30, 2009
    Cyprus
    Startpatch worked for me!
    I also got the very useful Auto-press A at startup [​IMG]
    Everything works now, thanks guys!