New Exploit Video

Discussion in 'Wii - Hacking' started by Rock Raiyu, Apr 10, 2009.

Apr 10, 2009

New Exploit Video by Rock Raiyu at 8:10 AM (4,469 Views / 0 Likes) 19 replies

  1. Rock Raiyu
    OP

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States


    Due out by the end of the week supposedly. Not sure if this video has been posted yet though.
     
  2. Kirbzy

    Newcomer Kirbzy Newbie

    Joined:
    Jan 25, 2008
    Messages:
    3
    Country:
    Australia
    I accentally deleted the homebrew channel through any title deleter under 4.0 and I thought that I was screwed for a while. If this is real, there is a god!
     
  3. TheOnlyOneHeFear

    Newcomer TheOnlyOneHeFear Member

    Joined:
    Apr 7, 2009
    Messages:
    46
    Country:
    United Kingdom
    This isn't for 4.0 surely, because where's the SD card icon next to the Wii button on the bottom left hand side? It doesn't look like he's running 4.0

    EDIT: Duh, I should learn to read the video description, it's on 3.2 in the video but apparently only requires a small fix to work on 3.4/4.0
     
  4. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,941
    Location:
    This planet
    Country:
    Belgium
    He isn't running 4.0
    But you can't tell if it doesn't work on 4.0
     
  5. kornychaos

    Member kornychaos Organized.

    Joined:
    Jul 7, 2007
    Messages:
    275
    Country:
    United States
    Quote taken from djdynamite123 @ TehSkeen"
     
  6. UranusKiller

    Member UranusKiller TranceMaster

    Joined:
    Feb 9, 2009
    Messages:
    951
    Location:
    Redcar, England, UK.
    Country:
    United Kingdom
    heh, yeah most people on here don't read and then speculate a load of cock & bullcrap, which is bad, suddenly saying ITS FAKE ITS FAKE, i mean come on really?

    e.g. http://emulatemii.com/wordpress/?p=94
     
  7. TheOnlyOneHeFear

    Newcomer TheOnlyOneHeFear Member

    Joined:
    Apr 7, 2009
    Messages:
    46
    Country:
    United Kingdom
     
  8. wolffangalchemist

    Member wolffangalchemist This is bat country!

    Joined:
    Nov 23, 2008
    Messages:
    1,406
    Location:
    middleofnowhere, AL
    Country:
    United States
    YES! finally!
    i can't freakin wait!
     
  9. feidhlim1986

    Member feidhlim1986 GBAtemp Regular

    Joined:
    Oct 18, 2008
    Messages:
    299
    Country:
    Ireland
    Sweet! I'm waiting to get my Wii back from Nintendo and chances are they'll put 4.0 on it without asking me:P

    Even with the HBC on a virgin 4.0 will you still not need a cIOS to actually do anything?
     
  10. Scarfish

    Member Scarfish GBAtemp Regular

    Joined:
    Jan 5, 2009
    Messages:
    101
    Country:
    Netherlands
    I'm wondering if the Homebrew Channel can be installed this way on 4.0. The bug that they were using for installing the HBC is patched right?
     
  11. TheOnlyOneHeFear

    Newcomer TheOnlyOneHeFear Member

    Joined:
    Apr 7, 2009
    Messages:
    46
    Country:
    United Kingdom
    This uses a different exploit, so yes it can be used to install the HBC
     
  12. kedest

    Member kedest GBAtemp Psycho!

    Joined:
    Feb 6, 2007
    Messages:
    3,283
    Country:
    Netherlands
    Well that's not sure. So this exploit can run homebrew. What that homebrew can do, that's another question.
     
  13. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Maybe not. This only allows to run code, but being able to run code doesn't mean you can install whatever you want. Or else you wouldn't need IOS16, a cIOS or to downgrade to use WAD Manager. If team twizzers told that the bug that was used to install the HBC was fixed, chances are you can run the HBC installer, but it won't install the HBC.
     
  14. TheOnlyOneHeFear

    Newcomer TheOnlyOneHeFear Member

    Joined:
    Apr 7, 2009
    Messages:
    46
    Country:
    United Kingdom
    Hmm, OK, fair enough, I was probably oversimplifying/don't actually know enough about it [​IMG] Actually, now that I look at marcan's 4.0 run down, the HBC bug was fixed. In that case, ignore everything I just said, I just assumed based on the video/video description
     
  15. Apekop

    Member Apekop GBAtemp Regular

    Joined:
    Apr 9, 2009
    Messages:
    223
    Location:
    Location, location, location.
    Country:
    Netherlands
    yes it was
     
  16. Screemer

    Member Screemer GBAtemp Maniac

    Joined:
    Sep 21, 2008
    Messages:
    1,248
    Country:
    Germany
    i guess it is absolutely doable on 4.0. the dvdx 4.0 installer shows that. dvdx is nothing more than a "hidden" channel. it seems that they found a bug to lower the version number of ios35 and install one with the truchabug present. at least that's what the 4.0 with hbc downgrader tutorial is implying. because after the installation of dvdx the version number of ios35 is 0 and you can install a newer one with the bug present.
     
  17. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Ok worst case is then that you need to downgrade your IOS first and then run the HBC installer. The problem are again the new unsoftmoddable Wiis. Which IOS can you downgrade with that downgrader and which IOS is used by the HBC installer? If there isn't a match this means no HBC installer for 4.0 on these Wiis. And even with a match it's not sure if it will work, because you can install a cIOS of these Wiis, but not use and nobody knows why.
     
  18. fogbank

    Member fogbank GBAtemp Fan

    Joined:
    Oct 28, 2008
    Messages:
    413
    Country:
    United States
    I wouldn't be too sure. The "dvdx 4.0 installer" works on older Wii's that had been upgraded, not newer Wii's with 4.0 installed at the factory.
     
  19. fogbank

    Member fogbank GBAtemp Fan

    Joined:
    Oct 28, 2008
    Messages:
    413
    Country:
    United States
    I agree.

    I wouldn't be at ALL surprised if newer Wii's shipping with 4.0 are in the same situation as the "unsoftmoddable" Wii's with 3.4 that we've been talking about. Why wouldn't they be?

    Once 4.0 Wii's are widely available in stores, and assuming that the new exploit can even install HBC on them, the "unsoftmoddable" Wii issue will get a lot more focus.
     
  20. vettacossx

    Member vettacossx Wii Theme Team Founder

    Joined:
    Sep 19, 2008
    Messages:
    1,329
    Location:
    Right Behind You! Uh Oh!
    Country:
    Ireland
    the person who made the vid should know the reason they get the green on the bottom when recording with a pinicle or adtech usb capture device is they need to update the DivX codecs [​IMG] and even downgrade in some cases with adstechs dvdxpressDX2...that green line is the codec though....


    on topic sweet video! and thanks for the share Raiyu245
     

Share This Page