Need Some Advice

Discussion in '3DS - Console, Accessories and Hardware' started by TheStoneBanana, Feb 7, 2016.

  1. TheStoneBanana
    OP

    TheStoneBanana GBAtemp Fan

    Member
    495
    867
    Aug 19, 2015
    United States
    So, I'm in a bit of a pickle here.
    You see, for Pokemon's 20th Birthday, they're releasing those super smexy New 3DSs, and I absolutely love them to death. With the money I currently have, as well as money that I would get from selling my Old 3DS, I should have enough to grab one.

    ...But I really don't know if it's worth it or not.
    Sure, Nintendo is going to say, "Yeah, its a great time to upgrade!" but I know the NX is around the corner, so I'm conflicted as to whether or not it'd be worthwhile to upgrade a system I already have that I'd only be using for a couple of months or so (providing the NX DOES come this year).

    Thoughts?
     
  2. hippy dave

    hippy dave BBMB

    Member
    2,600
    1,809
    Apr 30, 2012
    United Kingdom
    If you're going to hack it and play emulators etc then an n3ds is great. If you want to be able to play all 3ds games in 3d then an n3ds is much better for that.
     
  3. TheStoneBanana
    OP

    TheStoneBanana GBAtemp Fan

    Member
    495
    867
    Aug 19, 2015
    United States
    Yes, I'm going all in with my 3DS in terms of homebrew AND the latest games.
    That leads me to another issue, though. Considering this will be the latest N3DS model, would it come preshipped with 10.5, or would it still be plausible for it to have 10.3?
    If it has 10.3, I can downgrade an do what I need to do, but if it has 10.5, I'm screwed.
     
  4. TheKawaiiDesu

    TheKawaiiDesu Ball of Kawaiiness

    Member
    1,432
    1,506
    Aug 23, 2015
    Korea, North
    Lowee
    You have a good chance those will still be on 10.3. We can't be sure - so it would be better to wait for someone to report what firmware the consoles come - but in any case, if it's on 10.3, you'll need CN, OOT or SSB to launch the Homebrew Launcher, as the browser will be locked. It's also recommended to have a hardmod, as N3DS downgrade seems to be unstable for a lot of people (even if it worked flawlessly for me).

    EDIT: And also, even if your console comes with 10.5, you can still downgrade it with a hardmod.
     
    Last edited by TheKawaiiDesu, Feb 7, 2016
  5. Shadowfied

    Shadowfied GBAtemp Advanced Maniac

    Member
    1,926
    1,771
    Dec 6, 2014
    When you say
    Do you mean these?
    [​IMG]
     
  6. TheStoneBanana
    OP

    TheStoneBanana GBAtemp Fan

    Member
    495
    867
    Aug 19, 2015
    United States
    Yes, those. They look so amazing, and they apparently come with a matching theme too.
     
  7. Shadowfied

    Shadowfied GBAtemp Advanced Maniac

    Member
    1,926
    1,771
    Dec 6, 2014
    But they're just coverplates... :|
    They do look amazing though
     
  8. Devastus

    Devastus Advanced Member

    Newcomer
    67
    15
    Jan 28, 2016
    United States
    Browser blocked on old firmwares now?
     
  9. TheStoneBanana
    OP

    TheStoneBanana GBAtemp Fan

    Member
    495
    867
    Aug 19, 2015
    United States
    I understand that, but...
    1. They'll most likely never be sold separately.
    2. The bundle comes with Pokemon Red and Blue preinstalled as a perk.
    3. It just looks plain awesome.
    Once again, this all really makes me want to get one and upgrade, but I'm afraid that the NX will come later in the year, and I'll have basically wasted money (especially with having a perfectly working 3DS already).