Need help with Ninjhax installation

Discussion in '3DS - Homebrew Development and Emulators' started by BelgianROFLz, Jun 19, 2015.

  1. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    I'm on version 7.1.0-10U according to my System Settings on an O3DS. I have a stable internet connection on my console. Every time I scan the QR code, it does the black screen, I install, then it asks me to run the exploit. I select A: Yes and it runs 20%, then 40%, then launches my web browser. The web browser shows a loading bar that fills up and then the 3DS chimes, and after the chime it is completely locked up. I have to power it down completely in order to use my device.
     
  2. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,740
    367
    May 3, 2006
    France
    I have the exact same problem with my O3DS 8.1EUR.
    I only got Ninjhax successfully working on 4.5 & 9.2 firmwares.
     
  3. zoogie

    zoogie simple pimp tool

    Member
    6,508
    8,381
    Nov 30, 2014
    United States
    downgrade to 4.5

    browser vers -10 or less doesn't work with 5.x and higher for some reason.
     
  4. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    Can you downgrade without having Homebrew installed?
     
  5. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,740
    367
    May 3, 2006
    France
    You mean Ninjhax doesn't work on 5.x and higher firmware?
     
  6. clank

    clank Advanced Member

    Newcomer
    85
    24
    Jan 24, 2015
    Only if your browser version is higher than 10. Did you update your 3ds through a game cartridge maybe?
     
  7. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    The most recent game I got was the rerelease of Majora's Mask, I think I had to update from the cart to play it.
     
  8. marc00077

    marc00077 GBAtemp Regular

    Member
    125
    35
    May 21, 2014
    Netherlands Antilles
    Catalunya
    Smea couldn't test all the versions so some of them don't work. You simply need another version but you can't update it through the config because it will update to last version wich cant be xploited so be sure to NEVER update from there. You have to downgrade to 4.5 with gateway's launcher.dat (there is full of tutorials of this on the web, just search for them). You don't need any game neither any flashcard.

    Hope this helps
     
    Last edited by marc00077, Jun 19, 2015
  9. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    I don't have a Gateway, or any other flash cart or whatever they're called. I was hoping to do softmodding with Ninjhax and Pasta. I haven't seen anything saying that was impossible, but I suppose I haven't seen anything saying it was possible either. Is a Gateway required?
     
  10. marc00077

    marc00077 GBAtemp Regular

    Member
    125
    35
    May 21, 2014
    Netherlands Antilles
    Catalunya
    No, it's not required.
     
  11. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    I'm seeing Super Smash Brothers Demo at 8.x.x, does that mean I could download the demo and install it to update to not-the-most-recent-firmware or would I have to upgrade in order to access the virtual store in order to find the demo?
     
  12. clank

    clank Advanced Member

    Newcomer
    85
    24
    Jan 24, 2015
    How would you download said demo then??
    Just downgrade using Gateway's method. Go to their website and download the latest GW Ultra package, inside the compressed file you should find some instructions.
     
  13. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    I was looking at 3ds.essh.co as someone else suggested, I was not browsing with my 3DS. That's what I was asking about. I would prefer to upgrade to the most compatible version rather than downgrade and lose functionality, if possible.

    — Posts automatically merged - Please don't double post! —

    Besides that, wouldn't I need to have a Gateway to use a Gateway downgrade?
     
  14. marc00077

    marc00077 GBAtemp Regular

    Member
    125
    35
    May 21, 2014
    Netherlands Antilles
    Catalunya
    You HAVE to downgrade to get the version 8 of the browser, wich works with ninjhax (at least on 4.5). Then, you update with Majora's Mask and you should be able to run ninjhax and play your games.
     
  15. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    Would it be safer to upgrade via another cart rather than downgrade and then come back up? What versions are confirmed functional? I thought mine would be as it's described as working from 4.x all the way up to... 9.2, but if that's not the case, which ones DO work? It wouldn't be a big thing to go snag a used copy of like... Spongebob Heropants and upgrade to 8.1.0, provided that version works.

    In other news, I appreciate your time in answering my questions!
     
  16. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,740
    367
    May 3, 2006
    France
    If I update through a game, the web browser will not be updated?
     
    marc00077 likes this.
  17. MRJPGames

    MRJPGames Pretty great guy

    Member
    1,111
    717
    Aug 17, 2013
    Netherlands
    The Netherlands
    1. Download the latest version of Gateway from the gateway site
    2. Download the downgrade package from gateway site for your region (DO NOT USE ANOTHER REGION OR YOUR 3DS WILL BE BRICKED!)
    3. copy Launcher.dat and the downgrade file you've downloaded to your SD card
    4. open brower on 3DS and go to go.gateway-3ds.com (if it doesn't work clear cookies and browser history and try again)
    5. Go all the way to the right in the menu using the d-pad and select downgrade with the A button
    6. Follow on screen instructions

    You do not require the gateway card for this to work!

    When on 4.5:
    1. Boot CN
    2. In the main menu press L+R+X+Y
    3. Choose yes and then yes again to remove the save (and the exploit)
    4. Reinstall the exploit now for 4.5

    If you want to be on 9.x for the new encryption (handy if you want to use new titles with Pasta) just search around and find a tutorial on how to update to 9.2 using Pasta.
    The browser WILL NOT be updated with using a game cart. The problem is not your system version (8.0) but the fact that the -10 means you have a browser that is from an older version (4.x). Smea hasn't made the exploit work with that specific combination and thus you'll have to first downgrade then upgrade using pasta (which will update the browser as well), and then reinstall ninjhax again to get it working on a 5.x or higher firmware (9.2 would be recommended as it's the latest version that is exploitable)
     
    marc00077 and BelgianROFLz like this.
  18. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    Thank you for the clear and informative response! I'll be getting right on it :)
     
    MRJPGames likes this.
  19. BelgianROFLz
    OP

    BelgianROFLz Member

    Newcomer
    15
    2
    Jun 19, 2015
    United States
    Wahoo, it's up and running! Thank you so much for your help, everyone!