1. Wavy

    OP Wavy Did you quit QUAKE? Did the monsters frighten you?
    Member

    Joined:
    Aug 24, 2020
    Messages:
    204
    Country:
    Australia
    I found out that ctrQuake has a hardware rendering branch here. I tried to compile it but it gave me an error relating to how it can't find a gl.h header file. But all I needed was to install a library from the same creator called picaGL (which you can get here) in my devkitPro directory. I tried to make ctrQuake again but it threw a lot of warnings/notes at me then after that it was linking to "ctrQuake.elf" it gave me this:
    Code:
    linking ctrQuake.elf
    /opt/devkitpro/devkitARM/bin/../lib/gcc/arm-none-eabi/10.2.0/../../../../arm-none-eabi/bin/ld: gl_screen.o:(.bss+0x4b8): multiple definition of `sb_lines'; sbar.o:(.bss+0x514): first defined here
    /opt/devkitpro/devkitARM/bin/../lib/gcc/arm-none-eabi/10.2.0/../../../../arm-none-eabi/bin/ld: gl_warp.o:(.bss+0x10): multiple definition of `skytexturenum'; gl_rsurf.o:(.bss+0x758): first defined here
    collect2: error: ld returned 1 exit status
    make[1]: *** [/opt/devkitpro/devkitARM/3ds_rules:42: /home/devkitpro/ctrQuake/ctrQuake.elf] Error 1
    make: *** [Makefile:182: build] Error 2
    Just for some info, I'm running this in Ubuntu under WSL. So any help on compiling this would be nice! If you need more info, tell me
     
    Last edited by Wavy, Sep 16, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - compiling, rendering, ctrQuake